summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-arch/zpipe
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-arch/zpipe')
-rw-r--r--app-arch/zpipe/Manifest1
-rw-r--r--app-arch/zpipe/metadata.xml8
-rw-r--r--app-arch/zpipe/zpipe-2.01-r1.ebuild30
3 files changed, 39 insertions, 0 deletions
diff --git a/app-arch/zpipe/Manifest b/app-arch/zpipe/Manifest
new file mode 100644
index 000000000000..f8eb2a0d78cc
--- /dev/null
+++ b/app-arch/zpipe/Manifest
@@ -0,0 +1 @@
+DIST zpipe.201.zip 42173 SHA256 742f0da404fd279683e87e66001093bef7cca268b59a774d580c54bfeff4f1a5 SHA512 4c7fc5afd96c3db806679a56863752a18889d8e8dad7648b993a32bfa7ceb426782ec5f83567ad58ca5c5b79f145e8953667dc1a3b854fc8a76eaac165e28cb7 WHIRLPOOL 1ec1f7ca647fe6375900fdf61dc43a1a6a69f62ebd574b2190d5f12a0c45a6852d09fd856aa23ac1ac53f048d438b6179810cc0bf1e6c28091509601e8925b07
diff --git a/app-arch/zpipe/metadata.xml b/app-arch/zpipe/metadata.xml
new file mode 100644
index 000000000000..5cb9324943ab
--- /dev/null
+++ b/app-arch/zpipe/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-arch/zpipe/zpipe-2.01-r1.ebuild b/app-arch/zpipe/zpipe-2.01-r1.ebuild
new file mode 100644
index 000000000000..53985a440783
--- /dev/null
+++ b/app-arch/zpipe/zpipe-2.01-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit toolchain-funcs
+
+MY_P=${PN}.${PV/./}
+DESCRIPTION="Pipe compressor/decompressor for ZPAQ"
+HOMEPAGE="http://mattmahoney.net/dc/zpaq.html"
+SRC_URI="http://mattmahoney.net/dc/${MY_P}.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="<app-arch/libzpaq-7"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}
+
+src_compile() {
+ emake CXX="$(tc-getCXX)" LDLIBS=-lzpaq "${PN}"
+}
+
+src_install() {
+ dobin ${PN}
+}