summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2016-06-30 03:32:20 +1000
committerMichael Palimaka <kensington@gentoo.org>2016-06-30 03:32:41 +1000
commit1e3f09e05fd96cf49f3cffe816fcb94b2a912703 (patch)
tree5e58b587c2929ce7e65f620f275970937ced5506 /app-arch
parentdev-php/pecl-libevent: Replace php5-4 USE with php5-6 (diff)
downloadgentoo-1e3f09e05fd96cf49f3cffe816fcb94b2a912703.tar.gz
gentoo-1e3f09e05fd96cf49f3cffe816fcb94b2a912703.tar.bz2
gentoo-1e3f09e05fd96cf49f3cffe816fcb94b2a912703.zip
app-arch/xdms: revision bump to avoid calling prepalldocs
Gentoo-bug: 587256 Package-Manager: portage-2.3.0
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/xdms/xdms-1.3.2-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-arch/xdms/xdms-1.3.2-r1.ebuild b/app-arch/xdms/xdms-1.3.2-r1.ebuild
new file mode 100644
index 000000000000..86711fcd1e95
--- /dev/null
+++ b/app-arch/xdms/xdms-1.3.2-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="xDMS - Amiga DMS disk image decompressor"
+HOMEPAGE="http://zakalwe.fi/~shd/foss/xdms"
+SRC_URI="http://zakalwe.fi/~shd/foss/xdms/${P}.tar.bz2"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE=""
+
+pkg_setup() {
+ tc-export CC
+}
+
+src_prepare() {
+ default
+ sed -i Makefile.in \
+ -e "s:COPYING::" \
+ -e "s:share/doc/xdms-{VERSION}:share/doc/xdms-${PF}:" || die
+ sed -i -e "s:-O2::" src/Makefile.in || die
+}
+
+src_configure() {
+ ./configure --prefix=/usr --package-prefix="${D}" || die
+}