summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-10-04 17:46:36 +0200
committerMichał Górny <mgorny@gentoo.org>2019-10-04 18:08:45 +0200
commit23890eafc162bd4aae052b896eb238fe5eaa990a (patch)
tree434bf4f1336859a3d3d86370642fca7552787438 /app-arch
parentapp-arch/lzlib: Bump to 1.11 (diff)
downloadgentoo-23890eafc162bd4aae052b896eb238fe5eaa990a.tar.gz
gentoo-23890eafc162bd4aae052b896eb238fe5eaa990a.tar.bz2
gentoo-23890eafc162bd4aae052b896eb238fe5eaa990a.zip
app-arch/pdlzip: Bump to 1.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/pdlzip/Manifest1
-rw-r--r--app-arch/pdlzip/pdlzip-1.10.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/app-arch/pdlzip/Manifest b/app-arch/pdlzip/Manifest
index 86df21ce7498..9f2b38dcbce0 100644
--- a/app-arch/pdlzip/Manifest
+++ b/app-arch/pdlzip/Manifest
@@ -1 +1,2 @@
+DIST pdlzip-1.10.tar.gz 62416 BLAKE2B 7e8a4bc5793e10a819e911535149336138473b30b552e6d728b3f547e13e34540ac8fa91d84656c3feeb2816c06cd636cf3eafc5b031cca2b63e704a8f7f6ee8 SHA512 a0da45df3af68176d1ebceccba833d0d41b04750d37e90b3da6f1bdc98a41fffcb8e0ce04a296a31351aa7babd1dcaddf08f616d103970ad5fbf13e469f287ad
DIST pdlzip-1.8.tar.gz 60564 BLAKE2B 2fd38cb6d17e0344a73cb44d36c53be373ae0ddfaa88af01c78dd54f33c6fd7ec5b52a61fbf6c134b080f42006c01d24a419bbae91d23205fd7902c312952050 SHA512 ecab8500105754499448c0cc481917404ce5b9dcfb6ba66c5c51fbc8a6189b109d025f38bc7c497aa2f602e7722f302d6b05e4ee37c5ec8f97cdf253c128ad9e
diff --git a/app-arch/pdlzip/pdlzip-1.10.ebuild b/app-arch/pdlzip/pdlzip-1.10.ebuild
new file mode 100644
index 000000000000..efe20269ed4d
--- /dev/null
+++ b/app-arch/pdlzip/pdlzip-1.10.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Public-domain version of lzip compressor"
+HOMEPAGE="http://www.nongnu.org/lzip/pdlzip.html"
+SRC_URI="http://download.savannah.gnu.org/releases/lzip/pdlzip/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86 ~x86-fbsd"
+IUSE=""
+
+src_configure() {
+ local myconf=(
+ --prefix="${EPREFIX}"/usr
+ CC="$(tc-getCC)"
+ CFLAGS="${CFLAGS}"
+ CPPFLAGS="${CPPFLAGS}"
+ LDFLAGS="${LDFLAGS}"
+ )
+
+ # not autotools-based
+ ./configure "${myconf[@]}" || die
+}