summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-12-28 22:46:22 +0000
committerSam James <sam@gentoo.org>2022-12-28 22:46:22 +0000
commit320f20babbe68947121b65c0e233f63234afd542 (patch)
tree68b7b0ba53a642fb7d31fae778a1a3e1e8754469 /app-arch
parentsec-keys/openpgp-keys-tor: Stabilize 20221213 sparc, #888799 (diff)
downloadgentoo-320f20babbe68947121b65c0e233f63234afd542.tar.gz
gentoo-320f20babbe68947121b65c0e233f63234afd542.tar.bz2
gentoo-320f20babbe68947121b65c0e233f63234afd542.zip
app-arch/gzip: add 1.12_p20221228 (unkeyworded, RC)
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/gzip/Manifest2
-rw-r--r--app-arch/gzip/gzip-1.12_p20221228.ebuild99
2 files changed, 101 insertions, 0 deletions
diff --git a/app-arch/gzip/Manifest b/app-arch/gzip/Manifest
index bf24f30d7571..670e486ce3fe 100644
--- a/app-arch/gzip/Manifest
+++ b/app-arch/gzip/Manifest
@@ -1,2 +1,4 @@
DIST gzip-1.12.tar.xz 825548 BLAKE2B 7e2d482c08555f5fb0ff5408c0afe48c61034e9779eed6e3dd8046c847234c0a8a6bc34d49a934a54db0d73033e12c71a228d373551384a4cd663315071637e0 SHA512 116326fe991828227de150336a0c016f4fe932dfbb728a16b4a84965256d9929574a4f5cfaf3cf6bb4154972ef0d110f26ab472c93e62ec9a5fd7a5d65abea24
DIST gzip-1.12.tar.xz.sig 833 BLAKE2B ab7b4a759ef163d67f20773607ba0408ea9f1f7c7c224f43635fc3752acc521b74dbea4ec9ebb58a2f4fa13ecae19e00779b4b56c2cb95976301445beff817aa SHA512 1f4702797f7c5f1873c2f9c2f6210ba23824455d17ee82f50f0bf24240ed5bdf0090cf85338ccf76ba82422f8b4ad3a329d8bbf1350cb094d7bd61aa45550397
+DIST gzip-1.12_p20221228.tar.xz 806448 BLAKE2B 278eb44caca7ee16ca5d0210673726a1daebef6da7eaf0a87fc24590cb4c53d4ebe2decb6b8975440e1eb2c2cfebb69f091c658f9a7430a1717f0477fec279da SHA512 87d1fccb9603ec336c89689337e3cf3cfef70054ab4416bd8380fee011e9f517555d80a2a009bd312a58c34fdaf48778e5f0e9bea350ae280b440a325a837866
+DIST gzip-1.12_p20221228.tar.xz.sig 833 BLAKE2B b59d4677d15e2461d5fa95b4d53e94914e14cad613a9766aa3e51bfcece84ec0c4dd752c0d124cb76cc2240f9460f809c5bbbab958522c795e94026c8d4206ef SHA512 09a3a6687c80d7ec7e97ebd4c679e4d162729232d77966352c2f7ddd45594d79039ff33a93592889137605412b18b7868ea19ba4f4d162a5912a3978b3d67dd2
diff --git a/app-arch/gzip/gzip-1.12_p20221228.ebuild b/app-arch/gzip/gzip-1.12_p20221228.ebuild
new file mode 100644
index 000000000000..5e5dd9d96e0a
--- /dev/null
+++ b/app-arch/gzip/gzip-1.12_p20221228.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/gzip.asc
+inherit flag-o-matic verify-sig
+
+DESCRIPTION="Standard GNU compressor"
+HOMEPAGE="https://www.gnu.org/software/gzip/"
+if [[ ${PV} == *_p* ]] ; then
+ # Note: could put this in devspace, but if it's gone, we don't want
+ # it in tree anyway. It's just for testing.
+ MY_SNAPSHOT="$(ver_cut 1-2).31-7553"
+ SRC_URI="
+ https://meyering.net/gzip/gzip-${MY_SNAPSHOT}.tar.xz -> ${P}.tar.xz
+ verify-sig? (
+ https://meyering.net/gzip/gzip-${MY_SNAPSHOT}.tar.xz.sig -> ${P}.tar.xz.sig
+ )
+ "
+ S="${WORKDIR}"/${PN}-${MY_SNAPSHOT}
+else
+ SRC_URI="
+ mirror://gnu/gzip/${P}.tar.xz
+ verify-sig? (
+ mirror://gnu/gzip/${P}.tar.xz.sig
+ )
+ "
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+if [[ ${PV} != *_p* ]] ; then
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+IUSE="pic static"
+
+BDEPEND="verify-sig? ( sec-keys/openpgp-keys-gzip )"
+RDEPEND="!app-arch/pigz[symlink(-)]"
+PDEPEND="
+ app-alternatives/gzip
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.3.8-install-symlinks.patch"
+)
+
+src_configure() {
+ use static && append-flags -static
+
+ # Avoid text relocation in gzip
+ use pic && export DEFS="NO_ASM"
+
+ # bug #663928
+ econf --disable-gcc-warnings
+}
+
+src_install() {
+ default
+
+ docinto txt
+ dodoc algorithm.doc gzip.doc
+
+ # Avoid conflict with app-arch/ncompress
+ rm "${ED}"/usr/bin/uncompress || die
+
+ # keep most things in /usr, just the fun stuff in /
+ # also rename them to avoid conflict with app-alternatives/gzip
+ dodir /bin
+ local x
+ for x in gunzip gzip zcat; do
+ mv "${ED}/usr/bin/${x}" "${ED}/bin/${x}-reference" || die
+ done
+ sed -i -e 's:exec gzip:&-reference:' \
+ "${ED}"/bin/{gunzip,zcat}-reference || die
+ mv "${ED}"/usr/share/man/man1/gzip{,-reference}.1 || die
+ rm "${ED}"/usr/share/man/man1/{gunzip,zcat}.1 || die
+}
+
+pkg_postinst() {
+ if [[ -n ${REPLACING_VERSIONS} ]]; then
+ local ver
+ for ver in ${REPLACING_VERSIONS}; do
+ if ver_test "${ver}" -lt "1.12-r2"; then
+ ewarn "This package no longer installs 'uncompress'."
+ ewarn "Please use 'gzip -d' to decompress .Z files."
+ fi
+ done
+ fi
+
+ # ensure to preserve the symlinks before app-alternatives/gzip
+ # is installed
+ local x
+ for x in gunzip gzip zcat; do
+ if [[ ! -h ${EROOT}/bin/${x} ]]; then
+ ln -s "${x}-reference" "${EROOT}/bin/${x}" || die
+ fi
+ done
+}