summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-11-22 14:53:24 +0100
committerThomas Deutschmann <whissi@gentoo.org>2018-11-22 14:53:24 +0100
commit3a418bfc82713d71cdefa33db2a04aebc78fd052 (patch)
treead02af49c70cea575bb74b928aeb714273928c65 /app-arch
parentdev-libs/libmspack: fix big endian (diff)
downloadgentoo-3a418bfc82713d71cdefa33db2a04aebc78fd052.tar.gz
gentoo-3a418bfc82713d71cdefa33db2a04aebc78fd052.tar.bz2
gentoo-3a418bfc82713d71cdefa33db2a04aebc78fd052.zip
app-arch/cabextract: fix big-endian
Closes: https://bugs.gentoo.org/670654 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/cabextract/cabextract-1.9-r1.ebuild (renamed from app-arch/cabextract/cabextract-1.9.ebuild)5
-rw-r--r--app-arch/cabextract/files/cabextract-1.9-fix-bigendian.patch17
-rw-r--r--app-arch/cabextract/files/cabextract-1.9-remove-spurious-test_files.patch17
3 files changed, 39 insertions, 0 deletions
diff --git a/app-arch/cabextract/cabextract-1.9.ebuild b/app-arch/cabextract/cabextract-1.9-r1.ebuild
index 547506966c97..f435083a5f26 100644
--- a/app-arch/cabextract/cabextract-1.9.ebuild
+++ b/app-arch/cabextract/cabextract-1.9-r1.ebuild
@@ -31,6 +31,11 @@ DEPEND="${LIBMSPACK_DEPEND}
virtual/pkgconfig"
RDEPEND="extras? ( dev-lang/perl )"
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-bigendian.patch
+ "${FILESDIR}"/${P}-remove-spurious-test_files.patch
+)
+
src_prepare() {
if [[ ${PV} == "9999" ]] ; then
# Re-create file layout from release tarball
diff --git a/app-arch/cabextract/files/cabextract-1.9-fix-bigendian.patch b/app-arch/cabextract/files/cabextract-1.9-fix-bigendian.patch
new file mode 100644
index 000000000000..760dd9dbb013
--- /dev/null
+++ b/app-arch/cabextract/files/cabextract-1.9-fix-bigendian.patch
@@ -0,0 +1,17 @@
+https://github.com/kyz/libmspack/commit/c19e707936947b45cf05bc9aaee68517c6c2aca6
+
+---
+ configure.ac | 1 +
+ 1 files changed, 1 insertions(+)
+
+diff --git a/configure.ac b/configure.ac
+--- a/configure.ac
++++ b/configure.ac
+@@ -30,6 +30,7 @@ AC_CHECK_HEADERS([inttypes.h])
+ # Checks for typedefs, structures, and compiler characteristics.
+ AC_C_CONST
+ AC_C_INLINE
++AC_C_BIGENDIAN
+ AC_TYPE_MODE_T
+ AC_TYPE_OFF_T
+ AC_TYPE_SIZE_T
diff --git a/app-arch/cabextract/files/cabextract-1.9-remove-spurious-test_files.patch b/app-arch/cabextract/files/cabextract-1.9-remove-spurious-test_files.patch
new file mode 100644
index 000000000000..d80b8704834c
--- /dev/null
+++ b/app-arch/cabextract/files/cabextract-1.9-remove-spurious-test_files.patch
@@ -0,0 +1,17 @@
+https://github.com/kyz/libmspack/commit/2f78851e3927b05931574b380ca6dccaf91e3807
+
+---
+ test/bugs.test | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- a/test/bugs.test
++++ b/test/bugs.test
+@@ -2,7 +2,7 @@
+ # test that known crash bugs remain fixed
+ . test/testcase
+
+-$cabextract -t $test_files/bugs/*.cab
++$cabextract -t bugs/*.cab
+
+ # fail if exit code indicates a crash (SIGBUS, SIGSEGV, etc.)
+ test $? -le 1