summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-07-03 15:27:05 +0200
committerMichał Górny <mgorny@gentoo.org>2016-07-03 15:29:24 +0200
commit7b99fb52d2c9f8e3a3ffc9659bfe17c8906af09d (patch)
tree4cb2bd54bdde20af72645642f9095173b6a83e51 /app-arch
parentmedia-video/obs-studio: New package. (diff)
downloadgentoo-7b99fb52d2c9f8e3a3ffc9659bfe17c8906af09d.tar.gz
gentoo-7b99fb52d2c9f8e3a3ffc9659bfe17c8906af09d.tar.bz2
gentoo-7b99fb52d2c9f8e3a3ffc9659bfe17c8906af09d.zip
app-arch/zpaq: Merge libzpaq into the package
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/zpaq/zpaq-7.13-r1.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/app-arch/zpaq/zpaq-7.13-r1.ebuild b/app-arch/zpaq/zpaq-7.13-r1.ebuild
new file mode 100644
index 000000000000..a05100ba5228
--- /dev/null
+++ b/app-arch/zpaq/zpaq-7.13-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit flag-o-matic toolchain-funcs
+
+MY_P=${PN}${PV/./}
+DESCRIPTION="Journaling incremental deduplicating archiving compressor"
+HOMEPAGE="http://mattmahoney.net/dc/zpaq.html"
+SRC_URI="http://mattmahoney.net/dc/${MY_P}.zip"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +jit"
+
+# now 2in1!
+RDEPEND="!app-arch/libzpaq"
+# perl for pod2man
+DEPEND="
+ app-arch/unzip
+ dev-lang/perl"
+
+S=${WORKDIR}
+
+src_prepare() {
+ default
+ sed -i -e '/^zpaq:/,+1s/libzpaq\.o/$(SONAME)/' Makefile || die
+}
+
+src_compile() {
+ use debug || append-cppflags -DNDEBUG
+ use jit || append-cppflags -DNOJIT
+ emake CXX="$(tc-getCXX)" CXXFLAGS="${CXXFLAGS}"
+}
+
+src_test() {
+ local -x LD_LIBRARY_PATH=".${LD_LIBRARY_PATH+:${LD_LIBRARY_PATH}}"
+ default
+}
+
+src_install() {
+ emake install PREFIX="${ED%/}"/usr LIBDIR="\$(PREFIX)/$(get_libdir)"
+ einstalldocs
+}
+
+pkg_postinst() {
+ if ! has_version app-arch/zpaq-extras; then
+ elog "You may also want to install app-arch/zpaq-extras package which provides"
+ elog "few additional configs and preprocessors for use with zpaq."
+ fi
+}