summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2017-01-15 18:29:47 +0900
committerAaron Bauman <bman@gentoo.org>2017-01-15 18:30:48 +0900
commitbcad3a81ff68f920a9dcedb3d9fb5c08599243e3 (patch)
tree14433760d61799fd9e95dd2a981bde810edb9b7e /app-arch
parentapp-arch/libarchive: Security cleanup (bug #598950) (diff)
downloadgentoo-bcad3a81ff68f920a9dcedb3d9fb5c08599243e3.tar.gz
gentoo-bcad3a81ff68f920a9dcedb3d9fb5c08599243e3.tar.bz2
gentoo-bcad3a81ff68f920a9dcedb3d9fb5c08599243e3.zip
app-arch/libarchive: drop unused patches
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/libarchive/files/libarchive-3.2.1-fix-tests-gnu99.patch47
-rw-r--r--app-arch/libarchive/files/libarchive-3.2.1-osx-fix-acl.patch32
-rw-r--r--app-arch/libarchive/files/libarchive-3.2.1-xz-utils-thread-detection.patch27
3 files changed, 0 insertions, 106 deletions
diff --git a/app-arch/libarchive/files/libarchive-3.2.1-fix-tests-gnu99.patch b/app-arch/libarchive/files/libarchive-3.2.1-fix-tests-gnu99.patch
deleted file mode 100644
index ec249c34102b..000000000000
--- a/app-arch/libarchive/files/libarchive-3.2.1-fix-tests-gnu99.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-From 11f5b75c9ba12ba73b5fa34dc9d285983d99c01b Mon Sep 17 00:00:00 2001
-From: Joerg Sonnenberger <joerg@bec.de>
-Date: Wed, 22 Jun 2016 23:09:27 +0200
-Subject: [PATCH] Avoid use of C99 for-scope declarations to fix issue #729.
-
----
- libarchive/test/test_write_format_gnutar_filenames.c | 6 ++++--
- 1 file changed, 4 insertions(+), 2 deletions(-)
-
-diff --git a/libarchive/test/test_write_format_gnutar_filenames.c b/libarchive/test/test_write_format_gnutar_filenames.c
-index 38b4ca9..26457d3 100644
---- a/libarchive/test/test_write_format_gnutar_filenames.c
-+++ b/libarchive/test/test_write_format_gnutar_filenames.c
-@@ -42,6 +42,7 @@ DEFINE_TEST(test_write_format_gnutar_filenames)
- struct archive_entry *ae, *template;
- struct archive *a;
- size_t used;
-+ int i;
-
- buff = malloc(buffsize); /* million bytes of work area */
- assert(buff != NULL);
-@@ -55,7 +56,7 @@ DEFINE_TEST(test_write_format_gnutar_filenames)
- archive_entry_set_mode(template, S_IFREG | 0755);
- archive_entry_set_size(template, 8);
-
-- for (int i = 0; i < 2000; ++i) {
-+ for (i = 0; i < 2000; ++i) {
- filename[i] = 'a';
- filename[i + 1] = '\0';
- archive_entry_copy_pathname(template, filename);
-@@ -97,6 +98,7 @@ DEFINE_TEST(test_write_format_gnutar_linknames)
- struct archive_entry *ae, *template;
- struct archive *a;
- size_t used;
-+ int i;
-
- buff = malloc(buffsize); /* million bytes of work area */
- assert(buff != NULL);
-@@ -110,7 +112,7 @@ DEFINE_TEST(test_write_format_gnutar_linknames)
- archive_entry_set_mode(template, S_IFLNK | 0755);
- archive_entry_copy_pathname(template, "link");
-
-- for (int i = 0; i < 2000; ++i) {
-+ for (i = 0; i < 2000; ++i) {
- filename[i] = 'a';
- filename[i + 1] = '\0';
- archive_entry_copy_symlink(template, filename);
diff --git a/app-arch/libarchive/files/libarchive-3.2.1-osx-fix-acl.patch b/app-arch/libarchive/files/libarchive-3.2.1-osx-fix-acl.patch
deleted file mode 100644
index f3d136352d93..000000000000
--- a/app-arch/libarchive/files/libarchive-3.2.1-osx-fix-acl.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From 3e66829717c8fde611b2b611497f08a46da40ce7 Mon Sep 17 00:00:00 2001
-From: Joerg Sonnenberger <joerg@bec.de>
-Date: Tue, 21 Jun 2016 18:29:07 +0200
-Subject: [PATCH] Dummy out copy_acls if sys/acl.h is missing or ACL support is
- disabled.
-
----
- libarchive/archive_write_disk_posix.c | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/libarchive/archive_write_disk_posix.c b/libarchive/archive_write_disk_posix.c
-index 6737cd7..67aacf1 100644
---- a/libarchive/archive_write_disk_posix.c
-+++ b/libarchive/archive_write_disk_posix.c
-@@ -3487,6 +3487,9 @@ copy_xattrs(struct archive_write_disk *a, int tmpfd, int dffd)
- static int
- copy_acls(struct archive_write_disk *a, int tmpfd, int dffd)
- {
-+#ifndef HAVE_SYS_ACL_H
-+ return 0;
-+#else
- acl_t acl, dfacl = NULL;
- int acl_r, ret = ARCHIVE_OK;
-
-@@ -3514,6 +3517,7 @@ copy_acls(struct archive_write_disk *a, int tmpfd, int dffd)
- if (dfacl)
- acl_free(dfacl);
- return (ret);
-+#endif
- }
-
- static int
diff --git a/app-arch/libarchive/files/libarchive-3.2.1-xz-utils-thread-detection.patch b/app-arch/libarchive/files/libarchive-3.2.1-xz-utils-thread-detection.patch
deleted file mode 100644
index dda2359ac92e..000000000000
--- a/app-arch/libarchive/files/libarchive-3.2.1-xz-utils-thread-detection.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From 7c3148ec0a2fed4834c6f9869ff7d2da77ba804c Mon Sep 17 00:00:00 2001
-From: Joerg Sonnenberger <joerg@bec.de>
-Date: Wed, 22 Jun 2016 23:03:43 +0200
-Subject: [PATCH] Ignore the MT encoder in XZ 5.2 prerelease versions.
-
----
- configure.ac | 7 +++++--
- 1 file changed, 5 insertions(+), 2 deletions(-)
-
-diff --git a/configure.ac b/configure.ac
-index 64775fa..4f7f432 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -374,8 +374,11 @@ if test "x$with_lzma" != "xno"; then
- AC_CACHE_CHECK(
- [whether we have multithread support in lzma],
- ac_cv_lzma_has_mt,
-- [AC_COMPILE_IFELSE([
-- AC_LANG_PROGRAM([[#include <lzma.h>]],
-+ [AC_LINK_IFELSE([
-+ AC_LANG_PROGRAM([[#include <lzma.h>]
-+ [#if LZMA_VERSION < 50020000]
-+ [#error unsupported]
-+ [#endif]],
- [[lzma_stream_encoder_mt(0, 0);]])],
- [ac_cv_lzma_has_mt=yes], [ac_cv_lzma_has_mt=no])])
- if test "x$ac_cv_lzma_has_mt" != xno; then