summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNP-Hardass <NP-Hardass@gentoo.org>2016-07-04 15:54:48 -0400
committerNP-Hardass <NP-Hardass@gentoo.org>2016-07-05 15:26:10 -0400
commiteb38d016eda247952828b7c3de6d1fd4cb558cf5 (patch)
treee6b6b7415a9c0be109d55b381ed8eb5ddc3895d0 /app-arch
parentsys-devel/llvm: Drop 3.4.2 (diff)
downloadgentoo-eb38d016eda247952828b7c3de6d1fd4cb558cf5.tar.gz
gentoo-eb38d016eda247952828b7c3de6d1fd4cb558cf5.tar.bz2
gentoo-eb38d016eda247952828b7c3de6d1fd4cb558cf5.zip
app-arch/libarchive: Add src_prepare w/ eautoreconf, fix OSX acl #587890
Package-Manager: portage-2.2.28
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/libarchive/files/libarchive-3.2.1-osx-fix-acl.patch32
-rw-r--r--app-arch/libarchive/libarchive-3.2.1-r3.ebuild (renamed from app-arch/libarchive/libarchive-3.2.1-r2.ebuild)10
2 files changed, 41 insertions, 1 deletions
diff --git a/app-arch/libarchive/files/libarchive-3.2.1-osx-fix-acl.patch b/app-arch/libarchive/files/libarchive-3.2.1-osx-fix-acl.patch
new file mode 100644
index 000000000000..f3d136352d93
--- /dev/null
+++ b/app-arch/libarchive/files/libarchive-3.2.1-osx-fix-acl.patch
@@ -0,0 +1,32 @@
+From 3e66829717c8fde611b2b611497f08a46da40ce7 Mon Sep 17 00:00:00 2001
+From: Joerg Sonnenberger <joerg@bec.de>
+Date: Tue, 21 Jun 2016 18:29:07 +0200
+Subject: [PATCH] Dummy out copy_acls if sys/acl.h is missing or ACL support is
+ disabled.
+
+---
+ libarchive/archive_write_disk_posix.c | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/libarchive/archive_write_disk_posix.c b/libarchive/archive_write_disk_posix.c
+index 6737cd7..67aacf1 100644
+--- a/libarchive/archive_write_disk_posix.c
++++ b/libarchive/archive_write_disk_posix.c
+@@ -3487,6 +3487,9 @@ copy_xattrs(struct archive_write_disk *a, int tmpfd, int dffd)
+ static int
+ copy_acls(struct archive_write_disk *a, int tmpfd, int dffd)
+ {
++#ifndef HAVE_SYS_ACL_H
++ return 0;
++#else
+ acl_t acl, dfacl = NULL;
+ int acl_r, ret = ARCHIVE_OK;
+
+@@ -3514,6 +3517,7 @@ copy_acls(struct archive_write_disk *a, int tmpfd, int dffd)
+ if (dfacl)
+ acl_free(dfacl);
+ return (ret);
++#endif
+ }
+
+ static int
diff --git a/app-arch/libarchive/libarchive-3.2.1-r2.ebuild b/app-arch/libarchive/libarchive-3.2.1-r3.ebuild
index 3b514eb67afc..362bf6332397 100644
--- a/app-arch/libarchive/libarchive-3.2.1-r2.ebuild
+++ b/app-arch/libarchive/libarchive-3.2.1-r3.ebuild
@@ -36,7 +36,15 @@ DEPEND="${RDEPEND}
e2fsprogs? ( sys-fs/e2fsprogs )
)"
-PATCHES=( "${FILESDIR}/${P}-fix-tests-gnu99.patch" )
+PATCHES=(
+ "${FILESDIR}/${P}-fix-tests-gnu99.patch"
+ "${FILESDIR}/${P}-osx-fix-acl.patch" #587890
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
multilib_src_configure() {
export ac_cv_header_ext2fs_ext2_fs_h=$(usex e2fsprogs) #354923