summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2022-12-25 17:01:16 -0500
committerMike Gilbert <floppym@gentoo.org>2022-12-25 17:01:16 -0500
commitf3bd0e67477a3ce383aef383c8c1f2d1f363c9b6 (patch)
tree399900759c25d0413b02158a46b3c5510d09219f /app-arch
parentmedia-libs/libpng-compat: EAPI 8 (diff)
downloadgentoo-f3bd0e67477a3ce383aef383c8c1f2d1f363c9b6.tar.gz
gentoo-f3bd0e67477a3ce383aef383c8c1f2d1f363c9b6.tar.bz2
gentoo-f3bd0e67477a3ce383aef383c8c1f2d1f363c9b6.zip
app-arch/upx: disable -Werror
Closes: https://bugs.gentoo.org/887613 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/upx/upx-4.0.1.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/app-arch/upx/upx-4.0.1.ebuild b/app-arch/upx/upx-4.0.1.ebuild
index 04a011030c35..1a9d20a8f767 100644
--- a/app-arch/upx/upx-4.0.1.ebuild
+++ b/app-arch/upx/upx-4.0.1.ebuild
@@ -17,6 +17,13 @@ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
RDEPEND="!app-arch/upx-bin"
BDEPEND="app-arch/xz-utils[extra-filters]"
+src_configure() {
+ local mycmakeargs=(
+ -DUPX_CONFIG_DISABLE_WERROR=ON
+ )
+ cmake_src_configure
+}
+
src_test() {
# Don't run tests in parallel, #878977
cmake_src_test -j1