summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2016-10-30 15:14:05 -0400
committerAnthony G. Basile <blueness@gentoo.org>2016-10-30 15:14:05 -0400
commit40156a1bbec0f147f5aee9b1ba363f25cbf5ab13 (patch)
tree54b53ef5dc1736b4f3b6005a9c69691a9f20be18 /app-backup/borgbackup/borgbackup-1.0.8.ebuild
parentapp-portage/euscan: replace python_export_best with python_setup (diff)
downloadgentoo-40156a1bbec0f147f5aee9b1ba363f25cbf5ab13.tar.gz
gentoo-40156a1bbec0f147f5aee9b1ba363f25cbf5ab13.tar.bz2
gentoo-40156a1bbec0f147f5aee9b1ba363f25cbf5ab13.zip
app-backup/borgbackup: version bump to 1.0.8
Package-Manager: portage-2.3.0
Diffstat (limited to 'app-backup/borgbackup/borgbackup-1.0.8.ebuild')
-rw-r--r--app-backup/borgbackup/borgbackup-1.0.8.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-backup/borgbackup/borgbackup-1.0.8.ebuild b/app-backup/borgbackup/borgbackup-1.0.8.ebuild
new file mode 100644
index 000000000000..065fdc13465b
--- /dev/null
+++ b/app-backup/borgbackup/borgbackup-1.0.8.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+PYTHON_COMPAT=( python3_{4,5} )
+
+inherit distutils-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/${PN}/borg.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Deduplicating backup program with compression and authenticated encryption."
+HOMEPAGE="https://borgbackup.readthedocs.io/"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="libressl +fuse"
+
+# Unformately we have a file conflict with app-office/borg, bug #580402
+RDEPEND="
+ !!app-office/borg
+ app-arch/lz4
+ dev-python/msgpack[${PYTHON_USEDEP}]
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ fuse? ( dev-python/llfuse[${PYTHON_USEDEP}] )
+"
+
+DEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+ ${RDEPEND}
+"