summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@integralblue.com>2016-07-12 14:03:10 -0400
committerGöktürk Yüksek <gokturk@gentoo.org>2016-07-13 21:29:46 -0400
commit932c16f63b5beb8f798ebf021a38fbbbee794072 (patch)
tree4981eda0fc19973efac2d4387a8dbaa37088f8f8 /app-backup/btrbk/btrbk-9999.ebuild
parentapp-admin/needrestart: fix dependencies (diff)
downloadgentoo-932c16f63b5beb8f798ebf021a38fbbbee794072.tar.gz
gentoo-932c16f63b5beb8f798ebf021a38fbbbee794072.tar.bz2
gentoo-932c16f63b5beb8f798ebf021a38fbbbee794072.zip
app-backup/btrbk: initial commit for versions 0.23.3 and 9999
btrbk is a backup tool for btrfs subvolumes, taking advantage of btrfs specific capabilities to create atomic snapshots and transfer them incrementally to backup locations via ssh. Gentoo-bug: 564780
Diffstat (limited to 'app-backup/btrbk/btrbk-9999.ebuild')
-rw-r--r--app-backup/btrbk/btrbk-9999.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-backup/btrbk/btrbk-9999.ebuild b/app-backup/btrbk/btrbk-9999.ebuild
new file mode 100644
index 000000000000..45cbbca331fe
--- /dev/null
+++ b/app-backup/btrbk/btrbk-9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit systemd
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://dev.tty0.ch/btrbk.git"
+ inherit git-r3
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="https://digint.ch/download/btrbk/releases/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Tool for creating snapshots and remote backups of btrfs subvolumes"
+HOMEPAGE="https://digint.ch/btrbk/"
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="+pv"
+
+DEPEND=""
+RDEPEND="dev-lang/perl
+ net-misc/openssh
+ pv? ( sys-apps/pv )
+ >=sys-fs/btrfs-progs-3.18.2"
+
+src_install() {
+ emake DESTDIR="${D}" DOCDIR="/usr/share/doc/${PF}" SYSTEMDDIR="$(systemd_get_systemunitdir)" install
+}