summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Freeman <rich0@gentoo.org>2021-05-25 10:26:55 -0400
committerRichard Freeman <rich0@gentoo.org>2021-05-25 10:27:09 -0400
commitbf784961992ed85dbf9cb237c9d08d2d64cde0ab (patch)
tree916d184e7551be61fc59e85108cb8b99d9bff0a6 /app-backup/duplicity/duplicity-0.8.18.ebuild
parentprofiles/package.mask: mask >=sci-geosciences/qmapshack-1.16.0 (diff)
downloadgentoo-bf784961992ed85dbf9cb237c9d08d2d64cde0ab.tar.gz
gentoo-bf784961992ed85dbf9cb237c9d08d2d64cde0ab.tar.bz2
gentoo-bf784961992ed85dbf9cb237c9d08d2d64cde0ab.zip
app-backup/duplicity: clean old versions
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Richard Freeman <rich0@gentoo.org>
Diffstat (limited to 'app-backup/duplicity/duplicity-0.8.18.ebuild')
-rw-r--r--app-backup/duplicity/duplicity-0.8.18.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/app-backup/duplicity/duplicity-0.8.18.ebuild b/app-backup/duplicity/duplicity-0.8.18.ebuild
deleted file mode 100644
index 4b901f06dcdb..000000000000
--- a/app-backup/duplicity/duplicity-0.8.18.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_7 python3_8 python3_9 )
-
-inherit distutils-r1
-
-DESCRIPTION="Secure backup system using gnupg to encrypt data"
-HOMEPAGE="https://www.nongnu.org/duplicity/"
-SRC_URI="https://code.launchpad.net/${PN}/$(ver_cut 1-2)-series/$(ver_cut 1-3)/+download/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-macos"
-IUSE="s3 test"
-
-CDEPEND="
- net-libs/librsync
- app-crypt/gnupg
- dev-python/fasteners[${PYTHON_USEDEP}]
-"
-DEPEND="${CDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- test? (
- app-arch/par2cmdline
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pexpect[${PYTHON_USEDEP}]
- )
-"
-RDEPEND="${CDEPEND}
- dev-python/paramiko[${PYTHON_USEDEP}]
- dev-python/future[${PYTHON_USEDEP}]
- s3? ( dev-python/boto[${PYTHON_USEDEP}] )
-"
-
-RESTRICT="test"
-
-PATCHES=(
- "${FILESDIR}/${P}-fix-docs-cmd.patch"
-)
-
-python_test() {
- esetup.py test
-}
-
-pkg_postinst() {
- elog "Duplicity has many optional dependencies to support various backends."
- elog "Currently it's up to you to install them as necessary."
-}