summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Freeman <rich0@gentoo.org>2020-05-07 12:30:52 -0400
committerRichard Freeman <rich0@gentoo.org>2020-05-07 12:52:46 -0400
commitd554635fb1e0683395b6cf1c8ac205e8c9bc0327 (patch)
tree357fbb370038dd0dae1ac18273193964ebced70e /app-backup/duplicity/files
parentnet-misc/teamviewer: fix manifest (diff)
downloadgentoo-d554635fb1e0683395b6cf1c8ac205e8c9bc0327.tar.gz
gentoo-d554635fb1e0683395b6cf1c8ac205e8c9bc0327.tar.bz2
gentoo-d554635fb1e0683395b6cf1c8ac205e8c9bc0327.zip
app-backup/duplicity: setup.py fix to allow python-exec wrapping
Thanks to Alexander who discovered the root cause of this problem. Credit: Alexander Tsoy Closes: https://bugs.gentoo.org/710500 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Richard Freeman <rich0@gentoo.org>
Diffstat (limited to 'app-backup/duplicity/files')
-rw-r--r--app-backup/duplicity/files/duplicity-0.8.12.1612-fix-docs-cmd.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-backup/duplicity/files/duplicity-0.8.12.1612-fix-docs-cmd.patch b/app-backup/duplicity/files/duplicity-0.8.12.1612-fix-docs-cmd.patch
new file mode 100644
index 000000000000..89cd583e6bff
--- /dev/null
+++ b/app-backup/duplicity/files/duplicity-0.8.12.1612-fix-docs-cmd.patch
@@ -0,0 +1,29 @@
+--- duplicity-0.8.12.1612/setup.py 2020-05-07 12:07:21.571865871 -0400
++++ duplicity-0.8.12.1612/setup.py 2020-05-07 12:08:29.617846122 -0400
+@@ -88,18 +88,6 @@
+ u'bin/rdiffdir.1'
+ ]
+ ),
+- (u'share/doc/duplicity-%s' % version_string,
+- [
+- u'AUTHORS',
+- u'CHANGELOG',
+- u'Changelog.GNU',
+- u'COPYING',
+- u'README',
+- u'README-LOG',
+- u'README-REPO',
+- u'README-TESTING',
+- ],
+- ),
+ ]
+
+ if not os.environ.get(u'READTHEDOCS') == u'True':
+@@ -265,7 +253,6 @@
+ ],
+ test_suite=u"testing",
+ cmdclass={
+- u"build_scripts": BSCommand,
+ u"install": InstallCommand,
+ u"test": TestCommand,
+ },