summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-23 11:52:29 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-23 11:53:31 +0200
commit409d596d048a300233d0e439007f343b805c86ad (patch)
treea73dfffe0af75d4eae0f84f2441ae84b78ec6926 /app-backup/kup
parentdev-python/junit-xml: Remove last-rited pkg (diff)
downloadgentoo-409d596d048a300233d0e439007f343b805c86ad.tar.gz
gentoo-409d596d048a300233d0e439007f343b805c86ad.tar.bz2
gentoo-409d596d048a300233d0e439007f343b805c86ad.zip
app-backup/kup: Remove last-rited pkg
Closes: https://bugs.gentoo.org/713366 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-backup/kup')
-rw-r--r--app-backup/kup/Manifest1
-rw-r--r--app-backup/kup/files/kup-0.7.3-libgit2.patch140
-rw-r--r--app-backup/kup/kup-0.7.3.ebuild57
-rw-r--r--app-backup/kup/metadata.xml8
4 files changed, 0 insertions, 206 deletions
diff --git a/app-backup/kup/Manifest b/app-backup/kup/Manifest
deleted file mode 100644
index 8b2e2f05fe33..000000000000
--- a/app-backup/kup/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST kup-0.7.3.tar.gz 1024916 BLAKE2B aab2a1c58bc7feb6cc734a61385841b9c9b47995ba0c7e66b0596ddd7ae77b2a2b750f23f452e591c609f4a59a894815f8cfcb82c8bc266769b6e908463c009c SHA512 62609eb3c9a873045a9f02d22be5413f73f909e77d82f287ff5b2f816d2d6930a8d8ca77537a52189a98fe11441eb10f5530dfdab02ed0c09b53a2c4b5b4be80
diff --git a/app-backup/kup/files/kup-0.7.3-libgit2.patch b/app-backup/kup/files/kup-0.7.3-libgit2.patch
deleted file mode 100644
index a6b1c536afc1..000000000000
--- a/app-backup/kup/files/kup-0.7.3-libgit2.patch
+++ /dev/null
@@ -1,140 +0,0 @@
-From 2ca19e917f895e24a5379be669b9ad77ff5692f5 Mon Sep 17 00:00:00 2001
-From: Simon Persson <simon.persson@mykolab.com>
-Date: Mon, 16 Mar 2020 17:03:33 +0800
-Subject: Remove copy of libgit2
-
-API seems to have stabilized a lot, such that different distros can be
-expected to have a compatible version.
----
- CMakeLists.txt | 13 +-
- filedigger/CMakeLists.txt | 2 +-
- filedigger/main.cpp | 12 -
- kioslave/CMakeLists.txt | 2 +-
- kioslave/bupslave.cpp | 8 -
-
-From ee720980113162c019eecabc01dfa5763cfb7585 Mon Sep 17 00:00:00 2001
-From: Adriaan de Groot <groot@kde.org>
-Date: Mon, 6 Apr 2020 23:06:53 +0200
-Subject: Link to libgit2 via imported target
-
----
- filedigger/CMakeLists.txt | 2 +-
- kioslave/CMakeLists.txt | 2 +-
- 2 files changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 2118193..76a1367 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -6,18 +6,7 @@ set(CMAKE_MODULE_PATH ${ECM_MODULE_PATH})
-
- project(kup)
-
--# Use this option if you want to use the system LibGit2 library.
--# This is not recommended unless you know what you are doing.
--option(USE_SYSTEM_LIBGIT2 "Don't set this option unless your are sure that your system version of LibGit2 library is fully compatible with Kup." OFF)
--if (USE_SYSTEM_LIBGIT2)
-- find_package(LibGit2 REQUIRED)
-- set(libgit_link_name git2)
--else (USE_SYSTEM_LIBGIT2)
-- set(BUILD_SHARED_LIBS ON)
-- add_subdirectory(libgit2-0.19.0)
-- include_directories(${CMAKE_SOURCE_DIR}/libgit2-0.19.0/include)
-- set(libgit_link_name git24kup)
--endif (USE_SYSTEM_LIBGIT2)
-+find_package(LibGit2 REQUIRED)
-
- if("${CMAKE_BUILD_TYPE}" STREQUAL "Debug" OR "${CMAKE_BUILD_TYPE}" STREQUAL "DebugFull")
- message(WARNING "enabling debug output!")
-diff --git a/filedigger/CMakeLists.txt b/filedigger/CMakeLists.txt
-index 2fcdd82..fd6a3a0 100644
---- a/filedigger/CMakeLists.txt
-+++ b/filedigger/CMakeLists.txt
-@@ -37,7 +37,7 @@ KF5::I18n
- KF5::I18n
- KF5::IconThemes
- KF5::JobWidgets
--${libgit_link_name}
-+LibGit2::LibGit2
- )
-
- ########### install files ###############
-diff --git a/filedigger/main.cpp b/filedigger/main.cpp
-index 6682985..43fe9ae 100644
---- a/filedigger/main.cpp
-+++ b/filedigger/main.cpp
-@@ -21,11 +21,7 @@
- #include "filedigger.h"
- #include "mergedvfs.h"
-
--#if LIBGIT2_VER_MAJOR == 0 && LIBGIT2_VER_MINOR >= 24
- #include <git2/global.h>
--#else
--#include <git2/threads.h>
--#endif
-
- #include <KAboutData>
- #include <KLocalizedString>
-@@ -66,19 +62,11 @@ int main(int pArgCount, char **pArgArray) {
- }
-
- // This needs to be called first thing, before any other calls to libgit2.
-- #if LIBGIT2_VER_MAJOR == 0 && LIBGIT2_VER_MINOR >= 24
- git_libgit2_init();
-- #else
-- git_threads_init();
-- #endif
-
- FileDigger *lFileDigger = new FileDigger(lRepoPath, lParser.value(QStringLiteral("branch")));
- lFileDigger->show();
- int lRetVal = lApp.exec();
-- #if LIBGIT2_VER_MAJOR == 0 && LIBGIT2_VER_MINOR >= 24
- git_libgit2_shutdown();
-- #else
-- git_threads_shutdown();
-- #endif
- return lRetVal;
- }
-diff --git a/kioslave/CMakeLists.txt b/kioslave/CMakeLists.txt
-index 7187f33..83e6122 100644
---- a/kioslave/CMakeLists.txt
-+++ b/kioslave/CMakeLists.txt
-@@ -17,7 +17,7 @@ target_link_libraries(kio_bup
- Qt5::Core
- KF5::KIOCore
- KF5::I18n
--${libgit_link_name}
-+LibGit2::LibGit2
- )
-
- install(TARGETS kio_bup DESTINATION ${PLUGIN_INSTALL_DIR})
-diff --git a/kioslave/bupslave.cpp b/kioslave/bupslave.cpp
-index 1a7e1a3..0812658 100644
---- a/kioslave/bupslave.cpp
-+++ b/kioslave/bupslave.cpp
-@@ -64,22 +64,14 @@ BupSlave::BupSlave(const QByteArray &pPoolSocket, const QByteArray &pAppSocket)
- {
- mRepository = nullptr;
- mOpenFile = nullptr;
-- #if LIBGIT2_VER_MAJOR == 0 && LIBGIT2_VER_MINOR >= 24
- git_libgit2_init();
-- #else
-- git_threads_init();
-- #endif
- }
-
- BupSlave::~BupSlave() {
- if(mRepository != nullptr) {
- delete mRepository;
- }
-- #if LIBGIT2_VER_MAJOR == 0 && LIBGIT2_VER_MINOR >= 24
- git_libgit2_shutdown();
-- #else
-- git_threads_shutdown();
-- #endif
- }
-
- void BupSlave::close() {
---
-cgit v1.1
-
diff --git a/app-backup/kup/kup-0.7.3.ebuild b/app-backup/kup/kup-0.7.3.ebuild
deleted file mode 100644
index 8af41a81c73b..000000000000
--- a/app-backup/kup/kup-0.7.3.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-ECM_HANDBOOK="forceoptional"
-KFMIN=5.60.0
-QTMIN=5.12.3
-inherit ecm kde.org
-
-DESCRIPTION="Backup scheduler for KDE's Plasma desktop"
-HOMEPAGE="https://www.linux-apps.com/p/1127689"
-SRC_URI="https://github.com/spersson/${PN^}/archive/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="5"
-KEYWORDS="~amd64"
-IUSE=""
-
-DEPEND="
- dev-libs/libgit2:=
- >=dev-qt/qtdbus-${QTMIN}:5
- >=dev-qt/qtgui-${QTMIN}:5
- >=dev-qt/qtnetwork-${QTMIN}:5
- >=dev-qt/qtwidgets-${QTMIN}:5
- >=kde-frameworks/kcompletion-${KFMIN}:5
- >=kde-frameworks/kconfig-${KFMIN}:5
- >=kde-frameworks/kconfigwidgets-${KFMIN}:5
- >=kde-frameworks/kcoreaddons-${KFMIN}:5
- >=kde-frameworks/kdbusaddons-${KFMIN}:5
- >=kde-frameworks/ki18n-${KFMIN}:5
- >=kde-frameworks/kiconthemes-${KFMIN}:5
- >=kde-frameworks/kidletime-${KFMIN}:5
- >=kde-frameworks/kinit-${KFMIN}:5
- >=kde-frameworks/kio-${KFMIN}:5
- >=kde-frameworks/kjobwidgets-${KFMIN}:5
- >=kde-frameworks/knotifications-${KFMIN}:5
- >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
- >=kde-frameworks/kxmlgui-${KFMIN}:5
- >=kde-frameworks/plasma-${KFMIN}:5
- >=kde-frameworks/solid-${KFMIN}:5
-"
-RDEPEND="${DEPEND}
- app-backup/bup
- >=dev-qt/qtdeclarative-${QTMIN}:5
- >=dev-qt/qtsvg-${QTMIN}:5
- net-misc/rsync
-"
-
-S="${WORKDIR}/${PN^}-${P}"
-
-PATCHES=( "${FILESDIR}/${P}-libgit2.patch" )
-
-src_prepare() {
- ecm_src_prepare
- rm -r libgit2-0.19.0 || die "Failed to remove bundled libgit2-0.19.0"
-}
diff --git a/app-backup/kup/metadata.xml b/app-backup/kup/metadata.xml
deleted file mode 100644
index 2fdbf33d963d..000000000000
--- a/app-backup/kup/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>kde@gentoo.org</email>
- <name>Gentoo KDE Project</name>
- </maintainer>
-</pkgmetadata>