summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-12-28 15:54:31 +0100
committerDavid Seifert <soap@gentoo.org>2017-12-28 16:07:18 +0100
commit0e161febc73b6a3713f76fd64f0584cb7fa1ebfe (patch)
tree62dd6db3ca0a7756427f1da8eef2da8aec634f22 /app-backup/vzdump/vzdump-1.2.ebuild
parentapp-backup/ccollect: Port to EAPI 6 (diff)
downloadgentoo-0e161febc73b6a3713f76fd64f0584cb7fa1ebfe.tar.gz
gentoo-0e161febc73b6a3713f76fd64f0584cb7fa1ebfe.tar.bz2
gentoo-0e161febc73b6a3713f76fd64f0584cb7fa1ebfe.zip
app-backup/vzdump: Port to EAPI 6
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-backup/vzdump/vzdump-1.2.ebuild')
-rw-r--r--app-backup/vzdump/vzdump-1.2.ebuild25
1 files changed, 13 insertions, 12 deletions
diff --git a/app-backup/vzdump/vzdump-1.2.ebuild b/app-backup/vzdump/vzdump-1.2.ebuild
index eb385bda0694..7027a1cd9fe0 100644
--- a/app-backup/vzdump/vzdump-1.2.ebuild
+++ b/app-backup/vzdump/vzdump-1.2.ebuild
@@ -1,7 +1,9 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="2"
+EAPI=6
+
+inherit perl-functions
DESCRIPTION="A utility to make consistent snapshots of running OpenVZ containers"
HOMEPAGE="http://pve.proxmox.com/wiki/VZDump"
@@ -12,22 +14,21 @@ SLOT="0"
KEYWORDS="~x86 ~amd64"
IUSE=""
-RDEPEND="dev-lang/perl
+DEPEND="dev-lang/perl:="
+RDEPEND="${DEPEND}
+ app-misc/cstream
dev-perl/LockFile-Simple
- virtual/perl-Getopt-Long
- sys-cluster/vzctl
net-misc/rsync
- app-misc/cstream
+ sys-cluster/vzctl
+ sys-fs/lvm2
virtual/mta
- sys-fs/lvm2"
+ virtual/perl-Getopt-Long"
src_compile() {
- :;
+ return
}
src_install() {
- local installvendorlib
- eval "$(perl -V:installvendorlib )"
- make PERLLIBDIR="${installvendorlib}/PVE" DESTDIR="${D}" install || die "make install failed"
- dodoc ChangeLog TODO
+ emake PERLLIBDIR="$(perl_get_vendorlib)/PVE" DESTDIR="${D}" install
+ einstalldocs
}