summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Roman <davidroman96@gmail.com>2017-02-07 19:53:41 +0000
committerGöktürk Yüksek <gokturk@gentoo.org>2017-02-08 19:12:36 -0500
commit052ca64684c09ab1b503c959438e15a2bef3b3e5 (patch)
tree28883fc7560fd85e459270c107e54967092c2ed8 /app-backup
parentnet-misc/ssh-askpass-fullscreen: remove unused patches. (diff)
downloadgentoo-052ca64684c09ab1b503c959438e15a2bef3b3e5.tar.gz
gentoo-052ca64684c09ab1b503c959438e15a2bef3b3e5.tar.bz2
gentoo-052ca64684c09ab1b503c959438e15a2bef3b3e5.zip
app-backup/restic: New package
app-backup/restic: version bump to 0.4.0
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/restic/Manifest1
-rw-r--r--app-backup/restic/metadata.xml13
-rw-r--r--app-backup/restic/restic-0.4.0.ebuild43
3 files changed, 57 insertions, 0 deletions
diff --git a/app-backup/restic/Manifest b/app-backup/restic/Manifest
new file mode 100644
index 000000000000..95e41794e4b4
--- /dev/null
+++ b/app-backup/restic/Manifest
@@ -0,0 +1 @@
+DIST restic-0.4.0.tar.gz 22926188 SHA256 746dbc7b73f5a542be57b71714b243266a011f1d750f56f5100c08a59df1aeac SHA512 ccd15f010f8da3bae3d33698e70ff1d9565f52fb56991b78d35f95493417a4ab050021153d81c424947233255d9553d050f7a66e1c709843fe3b2d323a81f85b WHIRLPOOL 94e6b9ed777a86cb6e46cf734b9280e68cc2ce1ea061c8a94409dca594add1ec24fb736a56e35571302ff5043a60bef7f60ff3b39b038ee128bc815f7d3d48cd
diff --git a/app-backup/restic/metadata.xml b/app-backup/restic/metadata.xml
new file mode 100644
index 000000000000..83330b851258
--- /dev/null
+++ b/app-backup/restic/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>davidroman96@gmail.com</email>
+ <name>David Roman</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-backup/restic/restic-0.4.0.ebuild b/app-backup/restic/restic-0.4.0.ebuild
new file mode 100644
index 000000000000..93688562021b
--- /dev/null
+++ b/app-backup/restic/restic-0.4.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="restic is a backup program that is fast, efficient and secure"
+HOMEPAGE="https://restic.github.io/"
+SRC_URI="https://github.com/restic/restic/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DOCS=( README.md CONTRIBUTING.md doc/Design.md doc/FAQ.md doc/index.md doc/Manual.md doc/REST_backend.md )
+
+DEPEND="dev-lang/go
+ test? ( sys-fs/fuse )"
+
+RDEPEND="sys-fs/fuse"
+
+src_compile() {
+ local mygoargs=(
+ -v
+ -work
+ -x
+ -tags release
+ -ldflags "-w -X main.version=${PV}"
+ -o "${S}"/restic cmds/restic
+ )
+
+ GOPATH="${S}:${S}/vendor" go build "${mygoargs[@]}" || die
+}
+
+src_test() {
+ GOPATH="${S}:${S}/vendor" go test -v -work -x restic/... cmds/... || die
+}
+
+src_install() {
+ dobin restic
+ einstalldocs
+}