summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-02-02 07:41:34 +1300
committerKent Fredric <kentnl@gentoo.org>2017-02-02 11:21:49 +1300
commit6787ee8c5e83ee250d6df5d61d38aa8cba75eb53 (patch)
tree8dbb43771efe57f6e91e626578b597f1884207ac /app-backup
parentdev-perl/Apache-SizeLimit: Block tests against mpm-itk re bug #607964 (diff)
downloadgentoo-6787ee8c5e83ee250d6df5d61d38aa8cba75eb53.tar.gz
gentoo-6787ee8c5e83ee250d6df5d61d38aa8cba75eb53.tar.bz2
gentoo-6787ee8c5e83ee250d6df5d61d38aa8cba75eb53.zip
app-backup/backuppc: Cleanup versions broken by Perl 5.22
Bug: https://bugs.gentoo.org/580254 Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/backuppc/Manifest1
-rw-r--r--app-backup/backuppc/backuppc-3.3.0-r2.ebuild223
-rw-r--r--app-backup/backuppc/backuppc-3.3.1-r2.ebuild195
3 files changed, 0 insertions, 419 deletions
diff --git a/app-backup/backuppc/Manifest b/app-backup/backuppc/Manifest
index 07d699958f74..8201ca74a0c7 100644
--- a/app-backup/backuppc/Manifest
+++ b/app-backup/backuppc/Manifest
@@ -1,2 +1 @@
-DIST BackupPC-3.3.0.tar.gz 554155 SHA256 8a9c1b6faa4502b4c40617be97e806813815d9e22544854d99983c3da7c1f69b SHA512 67ec1ca4d22ab1e81f9c0f409c758347a6c772e3d1aa39c93207f9d328176ac7b4e679d0b03972fc5870c37dde0480d28c61ae19975d54e144235ea0e84e9901 WHIRLPOOL 23a9ce5dd600843cea72354e1afe595e3779f883839f8d3feca7f1355ed20048026090097ddfbcf394632672b42bef4884bc6661203542d6fe2c6bc2e8ad7b96
DIST BackupPC-3.3.1.tar.gz 556461 SHA256 c9cc4aec28a7474a68d40f4bc460ff15140e05c96900c7f98ff3ef06c4f6ae4c SHA512 b6bb9de3103c5062098d80755055b7461ae9133a4a46a66b3d0af89d081086571694db1898e7d85880defa15b030bad522812116ae5361c0fbde90b877d139c6 WHIRLPOOL 1d895f530932fc1287cde9db584befc6ca0850b5841cc4e60927442d0db662ec092bda4efa4953650d3bfa13deb6e9fafa25c10f82e19b39c67969bb4e143bac
diff --git a/app-backup/backuppc/backuppc-3.3.0-r2.ebuild b/app-backup/backuppc/backuppc-3.3.0-r2.ebuild
deleted file mode 100644
index 7ea269c294c1..000000000000
--- a/app-backup/backuppc/backuppc-3.3.0-r2.ebuild
+++ /dev/null
@@ -1,223 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-
-inherit eutils systemd webapp user
-
-MY_P="BackupPC-${PV}"
-
-DESCRIPTION="A high-performance system for backing up computers to a server's disk"
-HOMEPAGE="http://backuppc.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-KEYWORDS="amd64 ~arm x86"
-
-IUSE="rss samba"
-
-DEPEND="dev-lang/perl
- app-admin/apache-tools
- app-admin/makepasswd"
-RDEPEND="${DEPEND}
- virtual/perl-IO-Compress
- dev-perl/Archive-Zip
- dev-perl/libwww-perl
- >=app-arch/tar-1.13.20
- app-arch/par2cmdline
- app-arch/gzip
- app-arch/bzip2
- virtual/mta
- www-apache/mod_perl
- www-servers/apache
- net-misc/rsync
- >=dev-perl/File-RsyncP-0.68
- rss? ( dev-perl/XML-RSS )
- samba? ( net-fs/samba )"
-
-WEBAPP_MANUAL_SLOT="yes"
-SLOT="0"
-
-S=${WORKDIR}/${MY_P}
-
-CONFDIR="/etc/BackupPC"
-DATADIR="/var/lib/backuppc"
-LOGDIR="/var/log/BackupPC"
-
-pkg_setup() {
- webapp_pkg_setup
- enewgroup backuppc
- enewuser backuppc -1 /bin/bash /var/lib/backuppc backuppc
-}
-
-src_prepare() {
- epatch "${FILESDIR}/3.3.0/01-fix-configure.pl.patch"
- epatch "${FILESDIR}/3.3.0/02-fix-config.pl-formatting.patch"
- epatch "${FILESDIR}/3.3.0/03-reasonable-config.pl-defaults.patch"
-
- # Fix the documentation location in the CGI interface
- epatch "${FILESDIR}/3.2.0/04-add-docdir-marker.patch"
- sed -i "s+__DOCDIR__+/usr/share/doc/${PF}+" "lib/BackupPC/CGI/View.pm"
-
- epatch "${FILESDIR}/3.2.0/05-nicelevel.patch"
- sed -i -e 's/--chuid ${USER}//' "${S}"/init.d/src/gentoo-backuppc || die "Failed to fix the init script"
-}
-
-src_test() {
- true
-}
-
-src_install() {
- webapp_src_preinst
-
- local myconf
- myconf=""
- if use samba ; then
- myconf="--bin-path smbclient=$(type -p smbclient)"
- myconf="${myconf} --bin-path nmblookup=$(type -p nmblookup)"
- fi
-
- /usr/bin/env perl ./configure.pl \
- --batch \
- --bin-path perl=$(type -p perl) \
- --bin-path tar=$(type -p tar) \
- --bin-path rsync=$(type -p rsync) \
- --bin-path ping=$(type -p ping) \
- --bin-path df=$(type -p df) \
- --bin-path ssh=$(type -p ssh) \
- --bin-path sendmail=$(type -p sendmail) \
- --bin-path hostname=$(type -p hostname) \
- --bin-path gzip=$(type -p gzip) \
- --bin-path bzip2=$(type -p bzip2) \
- --config-dir ${CONFDIR} \
- --install-dir /usr \
- --data-dir ${DATADIR} \
- --hostname $(hostname) \
- --uid-ignore \
- --dest-dir "${D%/}" \
- --html-dir ${MY_HTDOCSDIR}/image \
- --html-dir-url /image \
- --cgi-dir ${MY_HTDOCSDIR} \
- --fhs \
- ${myconf} || die "failed the configure.pl script"
-
- ebegin "Installing documentation"
-
- pod2man \
- -errors=none \
- --section=8 \
- --center="BackupPC manual" \
- "${S}"/doc/BackupPC.pod backuppc.8 || die "failed to generate man page"
-
- doman backuppc.8
-
- # Place the documentation in the correct location
- dodoc "${D}/usr/doc/BackupPC.html"
- dodoc "${D}/usr/doc/BackupPC.pod"
- rm -rf "${D}/usr/doc"
-
- eend 0
-
- # Setup directories
- dodir ${CONFDIR}/pc
-
- keepdir ${CONFDIR}
- keepdir ${CONFDIR}/pc
- keepdir ${DATADIR}/{trash,pool,pc,cpool}
- keepdir ${LOGDIR}
-
- ebegin "Setting up init.d/conf.d/systemd scripts"
- newinitd "${S}"/init.d/gentoo-backuppc backuppc
- newconfd "${S}"/init.d/gentoo-backuppc.conf backuppc
- systemd_dounit "${FILESDIR}/${PN}.service"
- eend 0
-
- ebegin "Setting up an apache instance for backuppc"
-
- cp "${FILESDIR}/apache2-backuppc."{conf,init} "${WORKDIR}/"
- cp "${FILESDIR}/httpd.conf" "${WORKDIR}/httpd.conf"
- sed -i -e "s+HTDOCSDIR+${MY_HTDOCSDIR}+g" "${WORKDIR}/httpd.conf"
- sed -i -e "s+AUTHFILE+${CONFDIR}/users.htpasswd+g" "${WORKDIR}/httpd.conf"
-
- moduledir="/usr/lib/apache2/modules"
-
- # Check if the Apache ServerRoot is real.
- # This is sometimes broken on older amd64 systems.
- # In this case we just patch our config file appropriately.
- if [[ ! -d "/usr/lib/apache2" ]]; then
- if [[ -d "/usr/lib64/apache2" ]]; then
- sed -i -e "s+/usr/lib/apache2+/usr/lib64/apache2+g" "${WORKDIR}/httpd.conf"
- sed -i -e "s+/usr/lib/apache2+/usr/lib64/apache2+g" "${WORKDIR}/apache2-backuppc.conf"
- moduledir="/usr/lib64/apache2/modules"
- fi
- fi
-
- # Check if we're using mod_cgid instead of mod_cgi
- # This happens if you install apache with USE="threads"
- if [[ -f "${moduledir}/mod_cgid.so" ]]; then
- sed -i -e "s+mod_cgi+mod_cgid+g" "${WORKDIR}/httpd.conf"
- sed -i -e "s+cgi_module+cgid_module+g" "${WORKDIR}/httpd.conf"
- fi
-
- # Install conf.d/init.d files for apache2-backuppc
- if [ -e /etc/init.d/apache2 ]; then
- newconfd "${WORKDIR}/apache2-backuppc.conf" apache2-backuppc
- newinitd /etc/init.d/apache2 apache2-backuppc
- else
- newconfd "${WORKDIR}/apache2-backuppc.conf" apache2-backuppc
- newinitd "${WORKDIR}/apache2-backuppc.init" apache2-backuppc
- fi
-
- insopts -m 0644
- insinto ${CONFDIR}
- doins "${WORKDIR}/httpd.conf"
-
- eend $?
-
- webapp_src_install || die "webapp_src_install"
-
- # Make sure that the ownership is correct
- chown -R backuppc:backuppc "${D}${CONFDIR}"
- chown -R backuppc:backuppc "${D}${DATADIR}"
- chown -R backuppc:backuppc "${D}${LOGDIR}"
-}
-
-pkg_postinst() {
- # This is disabled since BackupPC doesn't need it
- # webapp_pkg_postinst
-
- elog "Installation finished, now may now start using BackupPC."
- elog ""
- elog "- Read the documentation in /usr/share/doc/${PF}/BackupPC.html"
- elog " Please pay special attention to the security section."
- elog ""
- elog "- You can launch backuppc and it's apache web interface by running:"
- elog " # /etc/init.d/backuppc start"
- elog " # /etc/init.d/apache2-backuppc start"
-
- if [[ ! -e /etc/runlevels/default/backuppc ]]; then
- elog ""
- elog "- You also might want to add these scripts to your default runlevel:"
- elog " # rc-update add backuppc default"
- elog " # rc-update add apache2-backuppc default"
- fi
-
- # Generate a new password if there's no auth file
- if [[ ! -f "${CONFDIR}/users.htpasswd" ]]; then
- adminuser="backuppc"
- adminpass=$( makepasswd --chars=12 )
- htpasswd -bc "${CONFDIR}/users.htpasswd" $adminuser $adminpass
-
- elog ""
- elog "- Created admin user $adminuser with password $adminpass"
- elog " To add new users, run: "
- elog " # htpasswd ${CONFDIR}/users.htpasswd newUser"
- fi
-
- if [[ -d "/etc/backuppc" ]]; then
- ewarn ""
- ewarn "Detected old config directory in /etc/backuppc"
- ewarn "Please migrate relevant config files to ${CONFDIR} before starting backuppc"
- fi
-}
diff --git a/app-backup/backuppc/backuppc-3.3.1-r2.ebuild b/app-backup/backuppc/backuppc-3.3.1-r2.ebuild
deleted file mode 100644
index a40e0ae64728..000000000000
--- a/app-backup/backuppc/backuppc-3.3.1-r2.ebuild
+++ /dev/null
@@ -1,195 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit depend.apache eutils user systemd
-
-MY_P="BackupPC-${PV}"
-
-DESCRIPTION="High-performance backups to a server's disk"
-HOMEPAGE="http://backuppc.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~x86"
-
-IUSE="rss samba"
-
-# The CGI modules are handled in $RDEPEND.
-APACHE_MODULES="apache2_modules_alias," # RedirectMatch
-APACHE_MODULES+="apache2_modules_authn_core," # AuthType
-APACHE_MODULES+="apache2_modules_authz_core," # Require
-APACHE_MODULES+="apache2_modules_authz_host," # Require host
-APACHE_MODULES+="apache2_modules_authz_user" # Require valid-user
-
-DEPEND="dev-lang/perl
- app-admin/apache-tools
- app-admin/makepasswd"
-
-# Older versions of mod_perl think they're compatibile with apache-2.4,
-# so we require the new one explicitly.
-RDEPEND="${DEPEND}
- virtual/perl-IO-Compress
- dev-perl/Archive-Zip
- dev-perl/libwww-perl
- app-arch/tar
- app-arch/par2cmdline
- app-arch/gzip
- app-arch/bzip2
- virtual/mta
- >=www-apache/mod_perl-2.0.9
- www-apache/mpm_itk
- || ( >=www-servers/apache-2.4[${APACHE_MODULES},apache2_modules_cgi]
- >=www-servers/apache-2.4[${APACHE_MODULES},apache2_modules_cgid]
- >=www-servers/apache-2.4[${APACHE_MODULES},apache2_modules_fcgid] )
- net-misc/rsync
- dev-perl/File-RsyncP
- rss? ( dev-perl/XML-RSS )
- samba? ( net-fs/samba )"
-
-need_apache2_4
-
-SLOT="0"
-
-S="${WORKDIR}/${MY_P}"
-
-CGIDIR="/usr/lib/backuppc/htdocs"
-CONFDIR="/etc/BackupPC"
-DATADIR="/var/lib/backuppc"
-DOCDIR="/usr/share/doc/${PF}"
-LOGDIR="/var/log/BackupPC"
-
-pkg_setup() {
- enewgroup backuppc
- enewuser backuppc -1 /bin/bash /var/lib/backuppc backuppc
-}
-
-src_prepare() {
- epatch "${FILESDIR}/3.3.0/01-fix-configure.pl.patch"
- epatch "${FILESDIR}/3.3.0/02-fix-config.pl-formatting.patch"
- epatch "${FILESDIR}/3.3.0/03-reasonable-config.pl-defaults.patch"
-
- epatch "${FILESDIR}/3.2.0/04-add-docdir-marker.patch"
- epatch "${FILESDIR}/3.2.0/05-nicelevel.patch"
-
- # Fix docs location using the marker that we've patched in.
- sed -i "s+__DOCDIR__+${DOCDIR}+" "lib/BackupPC/CGI/View.pm" \
- || die "failed to sed the documentation location"
-}
-
-src_install() {
- local myconf
- myconf=""
- if use samba ; then
- myconf="--bin-path smbclient=$(type -p smbclient)"
- myconf="${myconf} --bin-path nmblookup=$(type -p nmblookup)"
- fi
-
- /usr/bin/env perl ./configure.pl \
- --batch \
- --bin-path perl=$(type -p perl) \
- --bin-path tar=$(type -p tar) \
- --bin-path rsync=$(type -p rsync) \
- --bin-path ping=$(type -p ping) \
- --bin-path df=$(type -p df) \
- --bin-path ssh=$(type -p ssh) \
- --bin-path sendmail=$(type -p sendmail) \
- --bin-path hostname=$(type -p hostname) \
- --bin-path gzip=$(type -p gzip) \
- --bin-path bzip2=$(type -p bzip2) \
- --config-dir "${CONFDIR}" \
- --install-dir /usr \
- --data-dir "${DATADIR}" \
- --hostname 127.0.0.1 \
- --uid-ignore \
- --dest-dir "${D%/}" \
- --html-dir "${CGIDIR}"/image \
- --html-dir-url /image \
- --cgi-dir "${CGIDIR}" \
- --fhs \
- ${myconf} || die "failed the configure.pl script"
-
- ebegin "Installing documentation"
-
- pod2man \
- -errors=none \
- --section=8 \
- --center="BackupPC manual" \
- "${S}"/doc/BackupPC.pod backuppc.8 \
- || die "failed to generate man page"
-
- doman backuppc.8
-
- # Place the documentation in the correct location
- dodoc "${D}/usr/doc/BackupPC.html"
- dodoc "${D}/usr/doc/BackupPC.pod"
- rm -rf "${D}/usr/doc" || die
-
- eend 0
-
- # Setup directories
- dodir "${CONFDIR}/pc"
-
- keepdir "${CONFDIR}"
- keepdir "${CONFDIR}/pc"
- keepdir "${DATADIR}"/{trash,pool,pc,cpool}
- keepdir "${LOGDIR}"
-
- ebegin "Setting up init.d/conf.d/systemd scripts"
- newinitd "${S}"/init.d/gentoo-backuppc backuppc
- newconfd "${S}"/init.d/gentoo-backuppc.conf backuppc
- systemd_dounit "${FILESDIR}/${PN}.service"
-
- insinto "${APACHE_MODULES_CONFDIR}"
- doins "${FILESDIR}"/99_backuppc.conf
-
- # Make sure that the ownership is correct
- chown -R backuppc:backuppc "${D}${CONFDIR}" || die
- chown -R backuppc:backuppc "${D}${DATADIR}" || die
- chown -R backuppc:backuppc "${D}${LOGDIR}" || die
-}
-
-pkg_postinst() {
- elog "Installation finished, you may now start using BackupPC."
- elog
- elog "- Read the documentation in /usr/share/doc/${PF}/BackupPC.html"
- elog " Please pay special attention to the security section."
- elog
- elog "- You can launch backuppc by running:"
- elog
- elog " # /etc/init.d/backuppc start"
- elog
- elog "- To enable the GUI, first edit ${ROOT}etc/conf.d/apache2 and add,"
- elog
- elog " \"-D BACKUPPC -D PERL -D MPM_ITK\""
- elog
- elog " to the APACHE2_OPTS line."
- elog
- elog " Then you must edit ${ROOT}etc/apache2/modules.d/00_mpm_itk.conf"
- elog " and adjust the values of LimitUIDRange/LimitGIDRange to include"
- elog " the UID and GID of the backuppc user."
- elog
- elog " Finally, start apache:"
- elog
- elog " # /etc/init.d/apache2 start"
- elog
- elog " The web interface should now be running on,"
- elog
- elog " http://127.0.0.1:8080/"
- elog
-
- # Generate a new password if there's no auth file
- if [[ ! -f "${CONFDIR}/users.htpasswd" ]]; then
- adminuser="backuppc"
- adminpass=$( makepasswd --chars=12 )
- htpasswd -bc "${CONFDIR}/users.htpasswd" $adminuser $adminpass
-
- elog ""
- elog "- Created admin user $adminuser with password $adminpass"
- elog " To add new users, run: "
- elog ""
- elog " # htpasswd ${CONFDIR}/users.htpasswd newUser"
- fi
-}