summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-11-09 13:16:08 +0100
committerMarek Szuba <marecki@gentoo.org>2020-11-09 13:19:08 +0100
commit6b1096e875544600baf5fc48609ce9da12c7edad (patch)
tree153f87401a88c73a2d0926f1fb76f4ad5bcec34a /app-backup
parentnet-libs/nodejs: add self as maintainer (diff)
downloadgentoo-6b1096e875544600baf5fc48609ce9da12c7edad.tar.gz
gentoo-6b1096e875544600baf5fc48609ce9da12c7edad.tar.bz2
gentoo-6b1096e875544600baf5fc48609ce9da12c7edad.zip
app-backup/burp: bump to 2.3.38
Development release. Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/burp/Manifest1
-rw-r--r--app-backup/burp/burp-2.3.38.ebuild121
2 files changed, 122 insertions, 0 deletions
diff --git a/app-backup/burp/Manifest b/app-backup/burp/Manifest
index c85a56596000..33972f1b98de 100644
--- a/app-backup/burp/Manifest
+++ b/app-backup/burp/Manifest
@@ -1,2 +1,3 @@
DIST burp-2.2.18.tar.gz 632805 BLAKE2B 6106aa4bd96db035ad5893c2fe314537e620a67519295fdf99efaf2c5a639bedd15b4c8d95caa3daa3072dfac28a1ba7fd7bb4f949d9ea2b70bd13060a22f2c6 SHA512 beb14c61ace6d61b98a10fc4e6709eec9722e28990de862eef6a75984f9fbd0f903c5fe64d20ed84c95528a9889bc22618ba6d2318318cf5d515b35688db0a4d
DIST burp-2.3.36.tar.gz 619564 BLAKE2B 8f30fb8808c8a3167467ef0bcdc84cd7c2e885ee6a8aa285d96f9187aeb33eacb90fefe382ddb74bbabcfefde6faa9ac6125e3bf4a6eb9778b650e74e812991d SHA512 48b852aca8ccf0abd696b9434cb83c0447845192096d0f3f0c032c328dcc20314faf68db94fa14da72692327432b78eb3680e83b1e892dd30c9aa2f340838ee3
+DIST burp-2.3.38.tar.gz 623925 BLAKE2B f6aabfd23213c4fde58fbe75227a6b2aaccef2adf345e88661e1bf48cb4b4c04d8ba9c484127a1af2efdd20416c34725a75514298daf4da6443c1fc1e2f1b3f6 SHA512 825ecd289d52cc378d5f681f30e57daf5413f64039131daebe74dc2cbe0e288a4528092a6988a216143f1410cf7f3e49f1227303eea999442d33c3d006b9db6f
diff --git a/app-backup/burp/burp-2.3.38.ebuild b/app-backup/burp/burp-2.3.38.ebuild
new file mode 100644
index 000000000000..a72b5a23100f
--- /dev/null
+++ b/app-backup/burp/burp-2.3.38.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools systemd
+
+DESCRIPTION="Network backup and restore client and server for Unix and Windows"
+HOMEPAGE="https://burp.grke.org/"
+SRC_URI="https://github.com/grke/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="acl ipv6 libressl test xattr"
+
+RESTRICT="!test? ( test )"
+
+CDEPEND=" acct-group/burp
+ acct-user/burp
+ dev-libs/uthash
+ net-libs/librsync
+ sys-libs/ncurses:0=
+ sys-libs/zlib
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ acl? ( sys-apps/acl )
+ xattr? ( sys-apps/attr )"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig
+ test? ( dev-libs/check )"
+RDEPEND="${CDEPEND}
+ virtual/logger"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.1.20-no_mkdir_run.patch
+ "${FILESDIR}"/${PN}-2.1.20-protocol1_by_default.patch
+ "${FILESDIR}"/${PN}-2.0.54-server_user.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --localstatedir=/var
+ --sysconfdir=/etc/burp
+ --enable-largefile
+ $(use_enable acl)
+ $(use_enable ipv6)
+ $(use_enable xattr)
+ )
+ # --runstatedir option will only work from autoconf-2.70 onwards
+ runstatedir='/run' \
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ # See https://github.com/grke/burp/issues/869
+ local -x CK_DEFAULT_TIMEOUT=10
+ default
+}
+
+src_install() {
+ default
+ keepdir /var/spool/burp
+ fowners -R root:${PN} /var/spool/burp
+ fperms 0770 /var/spool/burp
+
+ emake DESTDIR="${D}" install-configs
+ fowners -R root:${PN} /etc/burp
+ fperms 0750 /etc/burp
+ fperms 0640 /etc/burp/burp-server.conf
+ fperms 0750 /etc/burp/clientconfdir
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ systemd_dounit "${FILESDIR}"/${PN}.service
+}
+
+pkg_postinst() {
+ ewarn
+ ewarn "You are installing a development version of burp. These versions contain"
+ ewarn "new features but might have unexpected issues. It is recommended by upstream"
+ ewarn "to use the current stable version (i.e. currently the 2.2 branch) instead."
+ ewarn
+
+ elog "Burp ebuilds now support the autoupgrade mechanism in both"
+ elog "client and server mode. In both cases it is disabled by"
+ elog "default. You almost certainly do NOT want to enable it in"
+ elog "client mode because upgrades obtained this way will not be"
+ elog "managed by Portage."
+
+ if [[ ! -e /etc/burp/CA/index.txt ]]; then
+ elog ""
+ elog "At first run burp server will generate DH parameters and SSL"
+ elog "certificates. You should adjust configuration before."
+ elog "Server configuration is located at"
+ elog ""
+ elog " /etc/burp/burp-server.conf"
+ elog ""
+ fi
+
+ # According to PMS this can be a space-separated list of version
+ # numbers, even though in practice it is typically just one.
+ local oldver
+ for oldver in ${REPLACING_VERSIONS}; do
+ if [[ $(ver_cut 1 ${oldver}) -lt 2 ]]; then
+ ewarn "Starting with version 2.0.54 we no longer patch bedup to use"
+ ewarn "the server config file by default. If you use bedup, please"
+ ewarn "update your scripts to invoke it as"
+ ewarn ""
+ ewarn " bedup -c /etc/burp/burp-server.conf"
+ ewarn ""
+ ewarn "Otherwise deduplication will not work!"
+ break
+ fi
+ done
+}