summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Freeman <rich0@gentoo.org>2022-09-30 08:03:15 -0400
committerRichard Freeman <rich0@gentoo.org>2022-09-30 08:05:00 -0400
commit7ffdbf5be166203e5d7e582146a8ed16771d8dc2 (patch)
tree83d6743e1b1ee2166cac92fce5a43fd759a111fa /app-backup
parentmedia-sound/strawberry: Stabilize 1.0.8 x86, #873583 (diff)
downloadgentoo-7ffdbf5be166203e5d7e582146a8ed16771d8dc2.tar.gz
gentoo-7ffdbf5be166203e5d7e582146a8ed16771d8dc2.tar.bz2
gentoo-7ffdbf5be166203e5d7e582146a8ed16771d8dc2.zip
app-backup/duplicity: add 1.0.0
Signed-off-by: Richard Freeman <rich0@gentoo.org>
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/duplicity/Manifest1
-rw-r--r--app-backup/duplicity/duplicity-1.0.0.ebuild53
-rw-r--r--app-backup/duplicity/files/duplicity-1.0.0-fix-docs-cmd.patch20
3 files changed, 74 insertions, 0 deletions
diff --git a/app-backup/duplicity/Manifest b/app-backup/duplicity/Manifest
index a81c6e41afa4..3d94afb49aee 100644
--- a/app-backup/duplicity/Manifest
+++ b/app-backup/duplicity/Manifest
@@ -1,2 +1,3 @@
DIST duplicity-0.8.22.tar.gz 1408482 BLAKE2B 3a8b6eb79d5f67e8f274bdaaaf0bb5b6c9f0ebf91a3b6a849b876cdf2c9af0f5435946150b5db6ab5e524cedc5b98b40c456b1de0fe8c6e33c024fe3c7d881fa SHA512 474237e3ca9876fb124baf9871f781b8347c85e76b7b4191d6993a76fb4728500091c74ed0943c6c22d69651c08094b6d155eca742d1711bebe676734c84d12a
DIST duplicity-0.8.23.tar.gz 1385252 BLAKE2B 63042486e6e17d2d93af72f617990c879763d5921e230302f406b4f9e7c57a67284130f9f57849b9ffc8638614b55f0f8abdf6bb20201155b33b72bef952ec9f SHA512 083cf0060a8c7a8472c6ee4ffbb87e85edf0fcdaba95862a9f272cc03d8ab3d18b584a8d256473e6cfab9eed6f993382b846b692a8c0dd46fd3a2d8215e54e45
+DIST duplicity-rel.1.0.0.tar.bz2 802941 BLAKE2B 7b5f33b2b8b0f938a86688ea68838fd45a1405e69cc59e9cc082035253d123258f6a30239ecc470e9210b5bafeda556909fe94887517be8c75a2c18641de66b0 SHA512 a3a0a8eee8f2555f275676c24c3e0933ef0ba267b64eccb7765dad751e58aae3ed0ffac4c4cee3acd3dd76c93bb799edb7fe1430ae159389174cc37ab646f339
diff --git a/app-backup/duplicity/duplicity-1.0.0.ebuild b/app-backup/duplicity/duplicity-1.0.0.ebuild
new file mode 100644
index 000000000000..2d2b3174a000
--- /dev/null
+++ b/app-backup/duplicity/duplicity-1.0.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_8 python3_9 python3_10 python3_11 )
+
+inherit distutils-r1
+
+DESCRIPTION="Secure backup system using gnupg to encrypt data"
+HOMEPAGE="https://duplicity.gitlab.io/"
+SRC_URI="https://gitlab.com/duplicity/duplicity/-/archive/rel.${PV}/duplicity-rel.${PV}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="s3 test"
+
+CDEPEND="
+ net-libs/librsync
+ app-crypt/gnupg
+ dev-python/fasteners[${PYTHON_USEDEP}]
+"
+DEPEND="${CDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ app-arch/par2cmdline
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${CDEPEND}
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/future[${PYTHON_USEDEP}]
+ s3? ( dev-python/boto3[${PYTHON_USEDEP}] )
+"
+
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-docs-cmd.patch"
+)
+
+S="${WORKDIR}/duplicity-rel.${PV}"
+
+python_test() {
+ esetup.py test
+}
+
+pkg_postinst() {
+ elog "Duplicity has many optional dependencies to support various backends."
+ elog "Currently it's up to you to install them as necessary."
+}
diff --git a/app-backup/duplicity/files/duplicity-1.0.0-fix-docs-cmd.patch b/app-backup/duplicity/files/duplicity-1.0.0-fix-docs-cmd.patch
new file mode 100644
index 000000000000..e6c4278b572d
--- /dev/null
+++ b/app-backup/duplicity/files/duplicity-1.0.0-fix-docs-cmd.patch
@@ -0,0 +1,20 @@
+--- duplicity-rel.1.0.0/setup.py 2022-03-19 15:08:36.755624771 -0400
++++ duplicity-rel.1.0.0/setup.py 2022-03-19 15:09:38.332763172 -0400
+@@ -94,17 +94,6 @@
+ u'bin/rdiffdir.1'
+ ]
+ ),
+- (u'share/doc/duplicity-%s' % Version,
+- [
+- u'CHANGELOG.md',
+- u'CONTRIBUTING.md',
+- u'COPYING',
+- u'README.md',
+- u'README-LOG.md',
+- u'README-REPO.md',
+- u'README-TESTING.md',
+- ],
+- ),
+ ]
+
+ if not os.environ.get(u'READTHEDOCS') == u'True':