summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-02-05 00:59:02 -0500
committerTim Harder <radhermit@gentoo.org>2018-02-05 01:00:54 -0500
commit839a7204b3b390dea660ff2103642d6f4716dce0 (patch)
treedaf0a3d454c3161913f14cc3cde0fb6f638d047d /app-backup
parentapp-text/restview: version bump to 2.8.1 (diff)
downloadgentoo-839a7204b3b390dea660ff2103642d6f4716dce0.tar.gz
gentoo-839a7204b3b390dea660ff2103642d6f4716dce0.tar.bz2
gentoo-839a7204b3b390dea660ff2103642d6f4716dce0.zip
app-backup/duplicity: version bump to 0.7.16
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/duplicity/Manifest1
-rw-r--r--app-backup/duplicity/duplicity-0.7.16.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/app-backup/duplicity/Manifest b/app-backup/duplicity/Manifest
index f98fbd489ed0..20a59a91ee64 100644
--- a/app-backup/duplicity/Manifest
+++ b/app-backup/duplicity/Manifest
@@ -4,3 +4,4 @@ DIST duplicity-0.7.12.tar.gz 1552442 BLAKE2B 4a7d0609748bffa147994a4abdb88bc0d62
DIST duplicity-0.7.13.1.tar.gz 1553736 BLAKE2B 607a469abc7f152f564628fda444d0c30aa5d40ee1bc6d461d76c5e7fb5f1b22fa30168b5a7bfc77e03fc0597a05f4ac8f5aaa634a7925aae833a482b70a13bf SHA512 08672910e61a089086992a1106ffc1e161ae3173514d35ae854eac719a095e48efaf7e298c1329ba3b439c0e97236644e88c615a013bd0e8ea9d956b38346ca6
DIST duplicity-0.7.14.tar.gz 1556110 BLAKE2B 32d4d7f941a09e85915724352ec14d6ed1bdb6a36f55e2160fe4a272868ab6c92f4917f4672183f38dbb3f38a1fa188eedd62ed9063b89b6c31d240ca268fabf SHA512 d814a4da2b23fb586bf2a7a29532ba082756470786f883d9b8cfcd856eabf0db0cdd8e9af5557fe861e439ab058e7586652f91c82c9b99c123cd14c7598b8fc2
DIST duplicity-0.7.15.tar.gz 1563272 BLAKE2B 1a5487d863253298ecab0bf328bc7e4aa7ac7df4e2b2dd47fd60b674310bcb9046e96546860fb6f299cddeb3ad384abae615a065759798e7215addb064d4582b SHA512 7cdcf1c707e9bdbbc250afcd359978607454b1614128d2b7f09403867195795606794c5f193dc869579ae8c3a9251d7ef8f9acd66d4e69bce91344d7c046ca90
+DIST duplicity-0.7.16.tar.gz 1563676 BLAKE2B 67e1a205a880b2658ed265efa46590553537881d82af21f538fe0b524338ed8450ded1dcc30089ecf13892f5cccc284fe2acd3dbb1a17597557640ccbb1376cd SHA512 552f63848ce90ccd8481136df6c0918bbf2463dde00d4e54f0af3693dc5439551ac086dc43b7b7191d1dcf0b710d7391b6c627ce0effd14a59beb0b5fa06a804
diff --git a/app-backup/duplicity/duplicity-0.7.16.ebuild b/app-backup/duplicity/duplicity-0.7.16.ebuild
new file mode 100644
index 000000000000..b2f160dd6d9e
--- /dev/null
+++ b/app-backup/duplicity/duplicity-0.7.16.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 versionator
+
+DESCRIPTION="Secure backup system using gnupg to encrypt data"
+HOMEPAGE="http://www.nongnu.org/duplicity/"
+SRC_URI="https://code.launchpad.net/${PN}/$(get_version_component_range 1-2)-series/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="s3 test"
+
+CDEPEND="
+ net-libs/librsync
+ app-crypt/gnupg
+ dev-python/fasteners[${PYTHON_USEDEP}]
+"
+DEPEND="${CDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ app-arch/par2cmdline
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${CDEPEND}
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ s3? ( dev-python/boto[${PYTHON_USEDEP}] )
+"
+
+python_prepare_all() {
+ # workaround until failing test is fixed
+ local PATCHES=( "${FILESDIR}"/${PN}-0.6.24-skip-test.patch )
+
+ distutils-r1_python_prepare_all
+
+ sed -i "s/'COPYING',//" setup.py || die
+}
+
+python_test() {
+ esetup.py test
+}
+
+pkg_postinst() {
+ einfo "Duplicity has many optional dependencies to support various backends."
+ einfo "Currently it's up to you to install them as necessary."
+}