summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2016-05-15 15:39:50 -0400
committerMichael Orlitzky <mjo@gentoo.org>2016-05-15 15:41:56 -0400
commitd0efbfcd36bfa91b48b7b8b9c60aaa557260ace1 (patch)
tree8cc33a54c8ac13b46879f9366a00050810538868 /app-backup
parentapp-emulation/virtualbox: Added debug USE flag (bug #583052). (diff)
downloadgentoo-d0efbfcd36bfa91b48b7b8b9c60aaa557260ace1.tar.gz
gentoo-d0efbfcd36bfa91b48b7b8b9c60aaa557260ace1.tar.bz2
gentoo-d0efbfcd36bfa91b48b7b8b9c60aaa557260ace1.zip
app-backup/untangle-https-backup: new package to back up Untangle configs.
Package-Manager: portage-2.2.26
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/untangle-https-backup/Manifest1
-rw-r--r--app-backup/untangle-https-backup/metadata.xml8
-rw-r--r--app-backup/untangle-https-backup/untangle-https-backup-0.0.4.ebuild27
3 files changed, 36 insertions, 0 deletions
diff --git a/app-backup/untangle-https-backup/Manifest b/app-backup/untangle-https-backup/Manifest
new file mode 100644
index 000000000000..7c41a2667f14
--- /dev/null
+++ b/app-backup/untangle-https-backup/Manifest
@@ -0,0 +1 @@
+DIST untangle-https-backup-0.0.4.tar.gz 15603 SHA256 ebd67322c22f69eaf42884bf4503b8590b71b9f6ea13e449a7dbe71aa5420968 SHA512 15346786365e5ec1c8548ea1abb87d980442ac56839eef13626ebb39355c5715135885a887c6acaa2bec61b2ea6983d73354589c58afb8ccd076f85937277e0c WHIRLPOOL 33d8dbe2401b8c6888b742ff0a6347b0c7c5014305a9a0c215dd4c25565aee4ba5956de7e10c05dccaf45b05811a78a23024421d0bc54eb3a60088a6a2e5c736
diff --git a/app-backup/untangle-https-backup/metadata.xml b/app-backup/untangle-https-backup/metadata.xml
new file mode 100644
index 000000000000..45125b9b6e99
--- /dev/null
+++ b/app-backup/untangle-https-backup/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ <name>Michael Orlitzky</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-backup/untangle-https-backup/untangle-https-backup-0.0.4.ebuild b/app-backup/untangle-https-backup/untangle-https-backup-0.0.4.ebuild
new file mode 100644
index 000000000000..9a5085c09c0b
--- /dev/null
+++ b/app-backup/untangle-https-backup/untangle-https-backup-0.0.4.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{3_3,3_4,3_5} )
+PYTHON_REQ_USE="ssl(+)"
+inherit distutils-r1
+
+DESCRIPTION="Back up Untangle configurations via the web admin UI"
+HOMEPAGE="http://michael.orlitzky.com/code/untangle-https-backup.php"
+SRC_URI="http://michael.orlitzky.com/code/releases/${P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_install() {
+ distutils-r1_src_install
+ doman "doc/man8/${PN}.8"
+ dodoc "doc/${PN}.example.ini"
+}