summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVladimir Pavljuchenkov (SpiderX) <spiderx@spiderx.dp.ua>2021-01-07 17:46:35 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-01-28 09:36:21 +0200
commitdcfbcbd8b1de09fae19213ea10862011e09fee76 (patch)
tree7facd05c6983498ee41dd8326de8d11011562174 /app-backup
parentsys-power/thermald: use wheel group for policy controlling (diff)
downloadgentoo-dcfbcbd8b1de09fae19213ea10862011e09fee76.tar.gz
gentoo-dcfbcbd8b1de09fae19213ea10862011e09fee76.tar.bz2
gentoo-dcfbcbd8b1de09fae19213ea10862011e09fee76.zip
app-backup/zbackup: cmake eclass, EAPI 7 for live ebuild
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Vladimir Pavljuchenkov <spiderx@spiderx.dp.ua> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/zbackup/zbackup-9999.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/app-backup/zbackup/zbackup-9999.ebuild b/app-backup/zbackup/zbackup-9999.ebuild
index 864251576a57..a6bfc74d2f13 100644
--- a/app-backup/zbackup/zbackup-9999.ebuild
+++ b/app-backup/zbackup/zbackup-9999.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit cmake-utils git-r3
+inherit cmake git-r3
DESCRIPTION="A versatile deduplicating backup tool"
-HOMEPAGE="http://zbackup.org/ https://github.com/zbackup/zbackup"
+HOMEPAGE="https://github.com/zbackup/zbackup"
SRC_URI=""
EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
@@ -18,8 +18,8 @@ IUSE="libressl tartool"
DEPEND="app-arch/lzma
dev-libs/lzo:2
dev-libs/protobuf:0=
- sys-libs/libunwind:0
- sys-libs/zlib
+ sys-libs/libunwind:=
+ sys-libs/zlib:=
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:0= )"
RDEPEND="${DEPEND}"
@@ -32,5 +32,5 @@ src_configure() {
-DBUILD_TARTOOL="$(usex tartool)"
)
- cmake-utils_src_configure
+ cmake_src_configure
}