summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-08-24 15:41:27 +0200
committerMarek Szuba <marecki@gentoo.org>2020-08-24 19:07:27 +0200
commite84e21eb6a98af49a6315925b1a170184d364972 (patch)
treee7c1617165ca419e76ebf1f066804fa87b07ba3d /app-backup
parentapp-text/bibletime: bump to 3.0 (diff)
downloadgentoo-e84e21eb6a98af49a6315925b1a170184d364972.tar.gz
gentoo-e84e21eb6a98af49a6315925b1a170184d364972.tar.bz2
gentoo-e84e21eb6a98af49a6315925b1a170184d364972.zip
app-backup/burp: bump to 2.3.32
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/burp/Manifest1
-rw-r--r--app-backup/burp/burp-2.3.32.ebuild115
2 files changed, 116 insertions, 0 deletions
diff --git a/app-backup/burp/Manifest b/app-backup/burp/Manifest
index 30083c4b933e..32389e6d509d 100644
--- a/app-backup/burp/Manifest
+++ b/app-backup/burp/Manifest
@@ -1,2 +1,3 @@
DIST burp-2.2.18.tar.gz 632805 BLAKE2B 6106aa4bd96db035ad5893c2fe314537e620a67519295fdf99efaf2c5a639bedd15b4c8d95caa3daa3072dfac28a1ba7fd7bb4f949d9ea2b70bd13060a22f2c6 SHA512 beb14c61ace6d61b98a10fc4e6709eec9722e28990de862eef6a75984f9fbd0f903c5fe64d20ed84c95528a9889bc22618ba6d2318318cf5d515b35688db0a4d
DIST burp-2.3.30.tar.gz 617064 BLAKE2B 62aa65da16155d2a321d4ef700a83000e9754eeee53ad7605b97c589a09e1168cd4cece3076d2c4660c098967f5b19056875b5aa4f226f135a17965fc099bb44 SHA512 c315c30c064073f864058d1ec9341b6e800964f308fa5ea298759e35a58ff27a198a3b6886cc04692bc259f1cfe5a5e077542fd45d3e89813541af2e4ca03533
+DIST burp-2.3.32.tar.gz 617641 BLAKE2B f193b3ed42bb8456fbad72ca5625d4a32b498749d04fc187a87f68e03c1a4131dd8e7276bcd6ded40e551f17c6bda7c12ba538e0dc74a8d750bff91e4e2ae84b SHA512 a7393d5097b03a3684104693620ecc9646caf3f4556201977ea88462700274361b01f1134f9c18368ffec6a31d11b4a9bd9091af7a54ac98dfd724779dab41c6
diff --git a/app-backup/burp/burp-2.3.32.ebuild b/app-backup/burp/burp-2.3.32.ebuild
new file mode 100644
index 000000000000..34645f772590
--- /dev/null
+++ b/app-backup/burp/burp-2.3.32.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools systemd
+
+DESCRIPTION="Network backup and restore client and server for Unix and Windows"
+HOMEPAGE="https://burp.grke.org/"
+SRC_URI="https://github.com/grke/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="acl ipv6 libressl test xattr"
+
+RESTRICT="!test? ( test )"
+
+CDEPEND=" acct-group/burp
+ acct-user/burp
+ dev-libs/uthash
+ net-libs/librsync
+ sys-libs/ncurses:0=
+ sys-libs/zlib
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ acl? ( sys-apps/acl )
+ xattr? ( sys-apps/attr )"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig
+ test? ( dev-libs/check )"
+RDEPEND="${CDEPEND}
+ virtual/logger"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.1.20-no_mkdir_run.patch
+ "${FILESDIR}"/${PN}-2.1.20-protocol1_by_default.patch
+ "${FILESDIR}"/${PN}-2.0.54-server_user.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --localstatedir=/var
+ --sysconfdir=/etc/burp
+ --enable-largefile
+ $(use_enable acl)
+ $(use_enable ipv6)
+ $(use_enable xattr)
+ )
+ # --runstatedir option will only work from autoconf-2.70 onwards
+ runstatedir='/run' \
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ keepdir /var/spool/burp
+ fowners -R root:${PN} /var/spool/burp
+ fperms 0770 /var/spool/burp
+
+ emake DESTDIR="${D}" install-configs
+ fowners -R root:${PN} /etc/burp
+ fperms 0750 /etc/burp
+ fperms 0640 /etc/burp/burp-server.conf
+ fperms 0750 /etc/burp/clientconfdir
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ systemd_dounit "${FILESDIR}"/${PN}.service
+}
+
+pkg_postinst() {
+ ewarn
+ ewarn "You are installing a development version of burp. These versions contain"
+ ewarn "new features but might have unexpected issues. It is recommended by upstream"
+ ewarn "to use the current stable version (i.e. currently the 2.2 branch) instead."
+ ewarn
+
+ elog "Burp ebuilds now support the autoupgrade mechanism in both"
+ elog "client and server mode. In both cases it is disabled by"
+ elog "default. You almost certainly do NOT want to enable it in"
+ elog "client mode because upgrades obtained this way will not be"
+ elog "managed by Portage."
+
+ if [[ ! -e /etc/burp/CA/index.txt ]]; then
+ elog ""
+ elog "At first run burp server will generate DH parameters and SSL"
+ elog "certificates. You should adjust configuration before."
+ elog "Server configuration is located at"
+ elog ""
+ elog " /etc/burp/burp-server.conf"
+ elog ""
+ fi
+
+ # According to PMS this can be a space-separated list of version
+ # numbers, even though in practice it is typically just one.
+ local oldver
+ for oldver in ${REPLACING_VERSIONS}; do
+ if [[ $(ver_cut 1 ${oldver}) -lt 2 ]]; then
+ ewarn "Starting with version 2.0.54 we no longer patch bedup to use"
+ ewarn "the server config file by default. If you use bedup, please"
+ ewarn "update your scripts to invoke it as"
+ ewarn ""
+ ewarn " bedup -c /etc/burp/burp-server.conf"
+ ewarn ""
+ ewarn "Otherwise deduplication will not work!"
+ break
+ fi
+ done
+}