summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Roman <davidroman96@gmail.com>2018-08-07 12:42:52 +0200
committerMichał Górny <mgorny@gentoo.org>2018-08-15 12:41:52 +0200
commitf5d40dd50655a82f8f7d9637e8fefdb52e2d401d (patch)
tree6f01dcae08a8520e83598a1080c0e92f047a28e0 /app-backup
parentsci-geosciences/qgis: Fix build with USE=-webkit (diff)
downloadgentoo-f5d40dd50655a82f8f7d9637e8fefdb52e2d401d.tar.gz
gentoo-f5d40dd50655a82f8f7d9637e8fefdb52e2d401d.tar.bz2
gentoo-f5d40dd50655a82f8f7d9637e8fefdb52e2d401d.zip
app-backup/restic: verbump to 0.9.2
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/restic/Manifest1
-rw-r--r--app-backup/restic/restic-0.9.2.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/app-backup/restic/Manifest b/app-backup/restic/Manifest
index 55a668b58d5f..2fe74f43879f 100644
--- a/app-backup/restic/Manifest
+++ b/app-backup/restic/Manifest
@@ -1,3 +1,4 @@
DIST restic-0.8.3.tar.gz 48746281 BLAKE2B 4161326068165b5ba19e9ee0e6386aa1df29a961a42509a2cb7924958100b9412abd1dd27d299d1eef76fdd4731d4a56f0a68e796a46071229a3e6767d3a6bb7 SHA512 758b2c69af8aad6bb62dc750141d5f5a1954ca2b51350ef59c35fd10afefaddc4d8d0cdd5914f249594946db6138124a48fba531b8a24353f022ccea773a240c
DIST restic-0.9.0.tar.gz 51049118 BLAKE2B 4089a0eafe0f3778d540ffb87d5d773f1bb4296c3cb7a085a38cc1ac54742392790ccf61145ed3ff19a7e35b358e0b40c7f3edf6ee661e22ffd00efafa2bdee1 SHA512 c01e8450c7afbea59d86a53a5491e562ba5d1ab7fe3e96e0e5b53d96f4df2cf051d7abaef742ff2ecce759e2cd97386566e1c19260f0d74ae678edbe200aa885
DIST restic-0.9.1.tar.gz 51056544 BLAKE2B eb66381e284c94b17b0fa31f824f41b24a52d04555af6798fa9ac2f1dd0ca168d5e8a9fde922b205c420288002743b86a49a16a939c07a0f3fd942348f0348b6 SHA512 9d365bdcb561255e2103d7170d02e850e5cf767bc2e02e099d57ec9aad719ebd4319446f5162e64437ca9a8e1fdca273fd1c6cc4314013ca07b5ebdbeef93c2a
+DIST restic-0.9.2.tar.gz 27344284 BLAKE2B 17c121a0d4df470397b467e09ceac559848c34e6a43f289b68eff8b85af86a18a4d2e1340060812613cb7e9cecf86f706565a6bcce31fbcd5aab076a85b57c67 SHA512 e060e0e16031924df7347ec74972bf52c75c84cca8ae996b1c5dd8a6f42c9022062e004ec17af2ebc0b6e9480ecfdff4ca7f64956afab9b9799201848d0be731
diff --git a/app-backup/restic/restic-0.9.2.ebuild b/app-backup/restic/restic-0.9.2.ebuild
new file mode 100644
index 000000000000..89515ce18d02
--- /dev/null
+++ b/app-backup/restic/restic-0.9.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit bash-completion-r1 golang-vcs-snapshot
+
+DESCRIPTION="A backup program that is fast, efficient and secure"
+HOMEPAGE="https://restic.github.io/"
+SRC_URI="https://github.com/restic/restic/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+EGO_PN="github.com/restic/restic"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+
+RDEPEND="sys-fs/fuse:0"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${P}/src/${EGO_PN}"
+
+src_compile() {
+ local mygoargs=(
+ -v
+ -work
+ -x
+ -tags release
+ -ldflags "-X main.version=${PV}"
+ -asmflags "-trimpath=${S}"
+ -gcflags "-trimpath=${S}"
+ -o restic ${EGO_PN}/cmd/restic
+ )
+
+ GOPATH="${WORKDIR}/${P}:$(get_golibdir_gopath)" \
+ go build "${mygoargs[@]}" || die
+}
+
+src_test() {
+ GOPATH="${WORKDIR}/${P}:$(get_golibdir_gopath)" \
+ go test -timeout 30m -v -work -x ${EGO_PN}/cmd/... ${EGO_PN}/internal/... || die
+}
+
+src_install() {
+ dobin restic
+
+ newbashcomp doc/bash-completion.sh "${PN}"
+
+ insinto /usr/share/zsh/site-functions
+ newins doc/zsh-completion.zsh _restic
+
+ doman doc/man/*
+ dodoc doc/*.rst
+}