summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnton Fischl <github@fischl-online.de>2022-10-23 11:43:52 +0200
committerSam James <sam@gentoo.org>2022-10-31 18:44:47 +0000
commitfbf6b93f9fb3ff5db3ccc1776386bebedc3b441c (patch)
treeacf8cc59b84ddf4fc8f96516a1ef720a9560f4d5 /app-backup
parentsys-fs/ntfs3g: Stabilize 2022.10.3 arm64, #878901 (diff)
downloadgentoo-fbf6b93f9fb3ff5db3ccc1776386bebedc3b441c.tar.gz
gentoo-fbf6b93f9fb3ff5db3ccc1776386bebedc3b441c.tar.bz2
gentoo-fbf6b93f9fb3ff5db3ccc1776386bebedc3b441c.zip
app-backup/burp: remove 2.5.4
Signed-off-by: Anton Fischl <github@fischl-online.de> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/burp/Manifest1
-rw-r--r--app-backup/burp/burp-2.5.4-r1.ebuild118
-rw-r--r--app-backup/burp/burp-2.5.4.ebuild117
3 files changed, 0 insertions, 236 deletions
diff --git a/app-backup/burp/Manifest b/app-backup/burp/Manifest
index 5d3db1d94a8c..83ef3e04a4e9 100644
--- a/app-backup/burp/Manifest
+++ b/app-backup/burp/Manifest
@@ -1,2 +1 @@
DIST burp-2.4.0.tar.gz 624032 BLAKE2B 4a1ff48236dc631dd6d545480a33af3cdf8020c3088f1ca09ab66ac5cec8128d262b9b991bf9e3229c80f75a4746d338073a0a43fdb67a2fe21a0fd4f243469d SHA512 ea81a12e54c6d88b702dd09dc4fa5a724d1e322bdfba2643c9312a9077c9edc63f6ca0f6cb3a6ebecb6ad9feb1cc26c114277b2308d9903f4abb0442a9be7c19
-DIST burp-2.5.4.tar.gz 625018 BLAKE2B 83cb8e48c616f527b2271c6ea5855a303f2925d3d0b83182afc64fe139676a4b1b98349d0ba0636613d3409f100417c4a36b7b1f24bc64bba329940d4587cd2b SHA512 b283e34e76a6887517d72c99deac5e0299efa07dd922d1275666683cc3ba4b040b97e5ce4840cb06025926ea616778811bf4c9c6f9c7564da5122900cdd7bad0
diff --git a/app-backup/burp/burp-2.5.4-r1.ebuild b/app-backup/burp/burp-2.5.4-r1.ebuild
deleted file mode 100644
index fdcea9103813..000000000000
--- a/app-backup/burp/burp-2.5.4-r1.ebuild
+++ /dev/null
@@ -1,118 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit autotools systemd
-
-DESCRIPTION="Network backup and restore client and server for Unix and Windows"
-HOMEPAGE="https://burp.grke.org/"
-SRC_URI="https://github.com/grke/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="AGPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="acl ipv6 test xattr"
-
-RESTRICT="!test? ( test )"
-
-COMMON_DEPEND="acct-group/burp
- acct-user/burp
- dev-libs/uthash
- dev-libs/openssl:0=
- net-libs/librsync:=
- sys-libs/ncurses:0=
- sys-libs/libcap
- sys-libs/zlib
- virtual/libcrypt:=
- acl? ( sys-apps/acl )
- xattr? ( sys-apps/attr )"
-DEPEND="${COMMON_DEPEND}
- elibc_musl? ( sys-libs/queue-standalone )
- test? ( dev-libs/check )"
-BDEPEND=">=sys-devel/autoconf-2.71
- virtual/pkgconfig"
-RDEPEND="${COMMON_DEPEND}
- virtual/logger"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-2.1.20-no_mkdir_run.patch
- "${FILESDIR}"/${PN}-2.1.20-protocol1_by_default.patch
- "${FILESDIR}"/${PN}-2.0.54-server_user.patch
- "${FILESDIR}"/${PN}-2.4.0-fix-musl-strptime.patch
-)
-
-src_prepare() {
- default
-
- eautoreconf
-}
-
-src_configure() {
- local myeconfargs=(
- --localstatedir=/var
- --sysconfdir=/etc/burp
- --enable-largefile
- --runstatedir=/run
- $(use_enable acl)
- $(use_enable ipv6)
- $(use_enable xattr)
- )
- econf "${myeconfargs[@]}"
-}
-
-src_test() {
- # See https://github.com/grke/burp/issues/869
- local -x CK_DEFAULT_TIMEOUT=10
- default
-}
-
-src_install() {
- default
- keepdir /var/spool/burp
- fowners -R root:${PN} /var/spool/burp
- fperms 0770 /var/spool/burp
-
- emake DESTDIR="${D}" install-configs
- fowners -R root:${PN} /etc/burp
- fperms 0750 /etc/burp
- fperms 0640 /etc/burp/burp-server.conf
- fperms 0750 /etc/burp/clientconfdir
-
- newinitd "${FILESDIR}"/${PN}.initd ${PN}
- systemd_dounit "${FILESDIR}"/${PN}.service
-}
-
-pkg_postinst() {
- elog "Burp ebuilds now support the autoupgrade mechanism in both"
- elog "client and server mode. In both cases it is disabled by"
- elog "default. You almost certainly do NOT want to enable it in"
- elog "client mode because upgrades obtained this way will not be"
- elog "managed by Portage."
-
- if [[ ! -e ${EROOT}/etc/burp/CA/index.txt ]]; then
- elog ""
- elog "At first run burp server will generate DH parameters and SSL"
- elog "certificates. You should adjust configuration before."
- elog "Server configuration is located at"
- elog ""
- elog " ${EROOT}/etc/burp/burp-server.conf"
- elog ""
- fi
-
- # According to PMS this can be a space-separated list of version
- # numbers, even though in practice it is typically just one.
- local oldver
- for oldver in ${REPLACING_VERSIONS}; do
- if [[ $(ver_cut 1 ${oldver}) -lt 2 ]]; then
- ewarn "Starting with version 2.0.54 we no longer patch bedup to use"
- ewarn "the server config file by default. If you use bedup, please"
- ewarn "update your scripts to invoke it as"
- ewarn ""
- ewarn " bedup -c ${EROOT}/etc/burp/burp-server.conf"
- ewarn ""
- ewarn "Otherwise deduplication will not work!"
- break
- fi
- done
-}
diff --git a/app-backup/burp/burp-2.5.4.ebuild b/app-backup/burp/burp-2.5.4.ebuild
deleted file mode 100644
index f43a92ad64bd..000000000000
--- a/app-backup/burp/burp-2.5.4.ebuild
+++ /dev/null
@@ -1,117 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit autotools systemd
-
-DESCRIPTION="Network backup and restore client and server for Unix and Windows"
-HOMEPAGE="https://burp.grke.org/"
-SRC_URI="https://github.com/grke/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="AGPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="acl ipv6 test xattr"
-
-RESTRICT="!test? ( test )"
-
-COMMON_DEPEND="acct-group/burp
- acct-user/burp
- dev-libs/uthash
- dev-libs/openssl:0=
- net-libs/librsync:=
- sys-libs/ncurses:0=
- sys-libs/libcap
- sys-libs/zlib
- virtual/libcrypt:=
- acl? ( sys-apps/acl )
- xattr? ( sys-apps/attr )"
-DEPEND="${COMMON_DEPEND}
- elibc_musl? ( sys-libs/queue-standalone )
- test? ( dev-libs/check )"
-BDEPEND=">=sys-devel/autoconf-2.71
- virtual/pkgconfig"
-RDEPEND="${COMMON_DEPEND}
- virtual/logger"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-2.1.20-no_mkdir_run.patch
- "${FILESDIR}"/${PN}-2.1.20-protocol1_by_default.patch
- "${FILESDIR}"/${PN}-2.0.54-server_user.patch
-)
-
-src_prepare() {
- default
-
- eautoreconf
-}
-
-src_configure() {
- local myeconfargs=(
- --localstatedir=/var
- --sysconfdir=/etc/burp
- --enable-largefile
- --runstatedir=/run
- $(use_enable acl)
- $(use_enable ipv6)
- $(use_enable xattr)
- )
- econf "${myeconfargs[@]}"
-}
-
-src_test() {
- # See https://github.com/grke/burp/issues/869
- local -x CK_DEFAULT_TIMEOUT=10
- default
-}
-
-src_install() {
- default
- keepdir /var/spool/burp
- fowners -R root:${PN} /var/spool/burp
- fperms 0770 /var/spool/burp
-
- emake DESTDIR="${D}" install-configs
- fowners -R root:${PN} /etc/burp
- fperms 0750 /etc/burp
- fperms 0640 /etc/burp/burp-server.conf
- fperms 0750 /etc/burp/clientconfdir
-
- newinitd "${FILESDIR}"/${PN}.initd ${PN}
- systemd_dounit "${FILESDIR}"/${PN}.service
-}
-
-pkg_postinst() {
- elog "Burp ebuilds now support the autoupgrade mechanism in both"
- elog "client and server mode. In both cases it is disabled by"
- elog "default. You almost certainly do NOT want to enable it in"
- elog "client mode because upgrades obtained this way will not be"
- elog "managed by Portage."
-
- if [[ ! -e ${EROOT}/etc/burp/CA/index.txt ]]; then
- elog ""
- elog "At first run burp server will generate DH parameters and SSL"
- elog "certificates. You should adjust configuration before."
- elog "Server configuration is located at"
- elog ""
- elog " ${EROOT}/etc/burp/burp-server.conf"
- elog ""
- fi
-
- # According to PMS this can be a space-separated list of version
- # numbers, even though in practice it is typically just one.
- local oldver
- for oldver in ${REPLACING_VERSIONS}; do
- if [[ $(ver_cut 1 ${oldver}) -lt 2 ]]; then
- ewarn "Starting with version 2.0.54 we no longer patch bedup to use"
- ewarn "the server config file by default. If you use bedup, please"
- ewarn "update your scripts to invoke it as"
- ewarn ""
- ewarn " bedup -c ${EROOT}/etc/burp/burp-server.conf"
- ewarn ""
- ewarn "Otherwise deduplication will not work!"
- break
- fi
- done
-}