summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-benchmarks/expedite
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-benchmarks/expedite')
-rw-r--r--app-benchmarks/expedite/Manifest1
-rw-r--r--app-benchmarks/expedite/expedite-1.7.10.ebuild51
-rw-r--r--app-benchmarks/expedite/metadata.xml5
3 files changed, 57 insertions, 0 deletions
diff --git a/app-benchmarks/expedite/Manifest b/app-benchmarks/expedite/Manifest
new file mode 100644
index 000000000000..d75f7b4a8dda
--- /dev/null
+++ b/app-benchmarks/expedite/Manifest
@@ -0,0 +1 @@
+DIST expedite-1.7.10.tar.bz2 5736765 SHA256 91d0290ba3635a4440c389647643beaa8e39def2789d685d54a58a723398cc10 SHA512 13085583b68e8c44696e39d7c88b2b17cddfc3a1800d619810827830be9106062289fe6c79c5b1e84c568ee2f38c400251f2342f9c773c6ef4a1a0e3daa503f8 WHIRLPOOL 85fa61af7077ad58173ac3cb423f676040c4a7a07de9c2b73e0119e5d0a5d613f23d9911426807911b4287c121620ae8e254edfc96ea60157a5418ae68b10a90
diff --git a/app-benchmarks/expedite/expedite-1.7.10.ebuild b/app-benchmarks/expedite/expedite-1.7.10.ebuild
new file mode 100644
index 000000000000..bdd94549434e
--- /dev/null
+++ b/app-benchmarks/expedite/expedite-1.7.10.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+EKEY_STATE="snap"
+
+inherit enlightenment
+
+DESCRIPTION="Performance and correctness test suite for Evas"
+SRC_URI="http://download.enlightenment.org/releases/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+IUSE="directfb fbcon opengl X xcb"
+
+RDEPEND=">=dev-libs/eina-${PV}
+ >=media-libs/evas-${PV}[directfb?,fbcon?,opengl?,X?,xcb?]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ if use X ; then
+ if use xcb ; then
+ ewarn "You have enabled both 'X' and 'xcb', so we will use"
+ ewarn "X as it's considered the most stable for evas."
+ fi
+ E_ECONF+=(
+ --disable-xrender-xcb
+ $(use_enable opengl opengl-x11)
+ )
+ elif use xcb ; then
+ E_ECONF+=(
+ --enable-xrender-xcb
+ )
+ else
+ E_ECONF+=(
+ --disable-gl-xlib
+ --disable-software-xcb
+ --disable-gl-xcb
+ )
+ fi
+ E_ECONF+=(
+ $(use_enable directfb)
+ $(use_enable fbcon fb)
+ $(use_enable X simple-x11)
+ $(use_enable X software-x11)
+ $(use_enable X xrender-x11)
+ )
+ enlightenment_src_configure
+}
diff --git a/app-benchmarks/expedite/metadata.xml b/app-benchmarks/expedite/metadata.xml
new file mode 100644
index 000000000000..5e1261900709
--- /dev/null
+++ b/app-benchmarks/expedite/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>enlightenment</herd>
+</pkgmetadata>