summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGöktürk Yüksek <gokturk@binghamton.edu>2016-03-04 08:38:56 -0500
committerGöktürk Yüksek <gokturk@binghamton.edu>2016-03-04 14:11:00 -0500
commitd6fe49b01348744e98c66ceed41f6032e6df966b (patch)
tree0848d1bf9b55e056de99c380585a27cf756d903c /app-benchmarks/filebench/files
parentdev-python/pyminuit: added python3_5 (diff)
downloadgentoo-d6fe49b01348744e98c66ceed41f6032e6df966b.tar.gz
gentoo-d6fe49b01348744e98c66ceed41f6032e6df966b.tar.bz2
gentoo-d6fe49b01348744e98c66ceed41f6032e6df966b.zip
app-benchmarks/filebench: eapi bump, add new use flag, fix dependencies
The following changes have been made: - eapi bump to EAPI 6 - drop unused inherit eutils - remove unsued dependency on libaio: the program uses the aio functions defined in libc. libaio is not referenced in the source code. - remove the automagic dependency on dev-libs/libtecla: filebench provides tab-completion support using libtecla. However, there's no way to explicitly control it. Patch the sources to add a configure option for '--with-libtecla' and add a corresponding USE flag called 'auto-completion'. - drop parallel compilation workaround: the package compiles with different values of '-j' successfully. Most likely a carry-over from the initial ebuild. Package-Manager: portage-2.2.26
Diffstat (limited to 'app-benchmarks/filebench/files')
-rw-r--r--app-benchmarks/filebench/files/filebench-fix-automagic-libtecla-dependency.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/app-benchmarks/filebench/files/filebench-fix-automagic-libtecla-dependency.patch b/app-benchmarks/filebench/files/filebench-fix-automagic-libtecla-dependency.patch
new file mode 100644
index 000000000000..8d24a62a89d6
--- /dev/null
+++ b/app-benchmarks/filebench/files/filebench-fix-automagic-libtecla-dependency.patch
@@ -0,0 +1,22 @@
+From: Göktürk Yüksek <gokturk@binghamton.edu>
+Subject: [PATCH] Fix automagic dependency on libtecla
+
+Replace the unconditional AC_CHECK_LIB logic with AC_ARG_WITH to
+eliminate the automagic dependency on libtecla.
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -164,8 +164,11 @@
+ AC_CHECK_LIB([kstat], [kstat_open])
+ # Use libtecla for autocompletion if it is available. If it
+ # is, then conditionally compile auto_comp.c (see Makefile.am)
+-AC_CHECK_LIB([tecla], [cpl_add_completion])
+-AM_CONDITIONAL(AUTOCOMP_LIBTECLA, test "$ac_cv_lib_tecla_cpl_add_completion" = yes)
++AC_ARG_WITH([libtecla], AS_HELP_STRING([--with-libtecla], [Build with libtecla for autocompletion support (default: test)]))
++AS_IF([test "x$with_libtecla" != "xno"], [
++ AC_CHECK_LIB([tecla], [cpl_add_completion])
++])
++AM_CONDITIONAL([AUTOCOMP_LIBTECLA], [test "x$ac_cv_lib_tecla_cpl_add_completion" = "xyes"])
+ # Check that librt is installed and supports async IO. First line
+ # allows to add librt to the linkers path, second one checks
+ # if aio_wait() is in it, third one checks if aio_waitn() is there (usually