summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-03-12 20:13:55 +0100
committerConrad Kostecki <conikost@gentoo.org>2021-03-12 23:27:03 +0100
commitd1c8285a63955ea13e00ec30bab9e2b3390da2f8 (patch)
tree1a20b67ffaf1283e5c5fff39235b992432e5d1e4 /app-benchmarks/geekbench/geekbench-5.4.0.ebuild
parentaspell-dict-r1.eclass: take ownership (diff)
downloadgentoo-d1c8285a63955ea13e00ec30bab9e2b3390da2f8.tar.gz
gentoo-d1c8285a63955ea13e00ec30bab9e2b3390da2f8.tar.bz2
gentoo-d1c8285a63955ea13e00ec30bab9e2b3390da2f8.zip
app-benchmarks/geekbench: bump to version 5.4.0
Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-benchmarks/geekbench/geekbench-5.4.0.ebuild')
-rw-r--r--app-benchmarks/geekbench/geekbench-5.4.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-benchmarks/geekbench/geekbench-5.4.0.ebuild b/app-benchmarks/geekbench/geekbench-5.4.0.ebuild
new file mode 100644
index 000000000000..257bad69c379
--- /dev/null
+++ b/app-benchmarks/geekbench/geekbench-5.4.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A Cross-Platform Benchmark for Android, iOS, Linux, MacOS and Windows"
+HOMEPAGE="https://www.geekbench.com/"
+SRC_URI="https://cdn.geekbench.com/Geekbench-${PV}-Linux.tar.gz"
+
+KEYWORDS="-* ~amd64"
+LICENSE="geekbench"
+SLOT="5"
+
+RESTRICT="bindist mirror"
+
+S="${WORKDIR}/Geekbench-${PV}-Linux"
+
+QA_PREBUILT="
+ opt/geekbench5/geekbench5
+ opt/geekbench5/geekbench_x86_64
+"
+
+pkg_nofetch() {
+ elog "Please download ${A} from ${HOMEPAGE}/download/linux"
+ elog "and place it in your DISTDIR directory."
+}
+
+src_install() {
+ exeinto /opt/geekbench5
+ doexe geekbench5 geekbench_x86_64
+
+ insinto /opt/geekbench5
+ doins geekbench.plar
+
+ dodir /opt/bin
+ dosym ../geekbench5/geekbench5 /opt/bin/geekbench5
+}
+
+pkg_postinst() {
+ elog "If you have purchased a commercial license, you can enter"
+ elog "your email address and your license key with the following command:"
+ elog "geekbench5 -r <email address> <license key>"
+}