summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2019-11-01 14:37:47 -0700
committerZac Medico <zmedico@gentoo.org>2019-11-01 14:44:41 -0700
commit7ceb5329d410f058e0fbcb2b31ce76c24baf044d (patch)
tree4ee46fa40cb1bee84749b584dc0c8e0a19e77df7 /app-benchmarks/hey/hey-0.1.2.ebuild
parentdev-libs/libpcre2: x86 stable (bug #699052) (diff)
downloadgentoo-7ceb5329d410f058e0fbcb2b31ce76c24baf044d.tar.gz
gentoo-7ceb5329d410f058e0fbcb2b31ce76c24baf044d.tar.bz2
gentoo-7ceb5329d410f058e0fbcb2b31ce76c24baf044d.zip
app-benchmarks/hey: Bump to version 0.1.2
Reported-by: Jesse Adelman <jesse@boldandbusted.com> Closes: https://bugs.gentoo.org/699108 Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-benchmarks/hey/hey-0.1.2.ebuild')
-rw-r--r--app-benchmarks/hey/hey-0.1.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-benchmarks/hey/hey-0.1.2.ebuild b/app-benchmarks/hey/hey-0.1.2.ebuild
new file mode 100644
index 000000000000..639ee500ec44
--- /dev/null
+++ b/app-benchmarks/hey/hey-0.1.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit go-module
+
+DESCRIPTION="HTTP load generator, ApacheBench (ab) replacement, formerly known as rakyll/boom"
+HOMEPAGE="https://github.com/rakyll/hey"
+SRC_URI="https://github.com/rakyll/hey/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="Apache-2.0 BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="test"
+IUSE=""
+DEPEND=""
+RDEPEND=""
+
+src_compile() {
+ export -n GOCACHE XDG_CACHE_HOME
+ go build -o ./bin/${PN} || die
+}
+
+src_install() {
+ dobin ./bin/${PN}
+ dodoc README.md
+}