summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-benchmarks/i7z
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-benchmarks/i7z')
-rw-r--r--app-benchmarks/i7z/Manifest1
-rw-r--r--app-benchmarks/i7z/files/i7z-0.27.2-ncurses.patch22
-rw-r--r--app-benchmarks/i7z/i7z-0.27.2.ebuild39
-rw-r--r--app-benchmarks/i7z/metadata.xml10
4 files changed, 72 insertions, 0 deletions
diff --git a/app-benchmarks/i7z/Manifest b/app-benchmarks/i7z/Manifest
new file mode 100644
index 000000000000..55c39a270a67
--- /dev/null
+++ b/app-benchmarks/i7z/Manifest
@@ -0,0 +1 @@
+DIST i7z-0.27.2.tar.gz 51226 SHA256 a7f72d65732c17eef0df4f284927fe744fc650075f2364c51c9497534d8f47f1 SHA512 d693fda4d12bf7b0d8e694d9f97876fcd2cad4556c950b4eab09ae21d121e63e221e1e1b27bcf23a241fd868b09165639ecfafeaa126144ad809199fcaca1cbb WHIRLPOOL aaea6bc544a554703cd85f7e2e075588114a6c807e1311421300464f1468560423e987f1582b5e58a2fd48eb1753559958ea39ed9ab97e621718e7f46e8c476e
diff --git a/app-benchmarks/i7z/files/i7z-0.27.2-ncurses.patch b/app-benchmarks/i7z/files/i7z-0.27.2-ncurses.patch
new file mode 100644
index 000000000000..2d0a5a1e9b87
--- /dev/null
+++ b/app-benchmarks/i7z/files/i7z-0.27.2-ncurses.patch
@@ -0,0 +1,22 @@
+Index: Makefile
+===================================================================
+--- Makefile (revision 109)
++++ Makefile (working copy)
+@@ -19,7 +19,7 @@
+
+ CC ?= gcc
+
+-LIBS += -lncurses -lpthread -lrt -lm
++LIBS += `pkg-config --libs ncurses` -lpthread -lrt -lm
+ INCLUDEFLAGS =
+
+ BIN = i7z
+@@ -42,7 +42,7 @@
+
+ #http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=644728 for -ltinfo on debian
+ static-bin: message $(OBJ)
+- $(CC) $(CFLAGS) $(LDFLAGS) -o $(BIN) $(OBJ) -static-libgcc -DNCURSES_STATIC -static -lpthread -lncurses -lrt -lm -ltinfo
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $(BIN) $(OBJ) -static-libgcc -DNCURSES_STATIC -static -lpthread `pkg-config --static --libs ncurses` -lrt -lm
+
+ # perfmon-bin: message $(OBJ)
+ # $(CC) $(CFLAGS) $(LDFLAGS) -o $(PERFMON-BIN) perfmon-i7z.c helper_functions.c $(LIBS)
diff --git a/app-benchmarks/i7z/i7z-0.27.2.ebuild b/app-benchmarks/i7z/i7z-0.27.2.ebuild
new file mode 100644
index 000000000000..e79f9494ff6c
--- /dev/null
+++ b/app-benchmarks/i7z/i7z-0.27.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils flag-o-matic qmake-utils toolchain-funcs
+
+DESCRIPTION="A better i7 (and now i3, i5) reporting tool for Linux"
+HOMEPAGE="http://code.google.com/p/i7z/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="X"
+
+RDEPEND="
+ sys-libs/ncurses
+ X? ( dev-qt/qtgui:4 )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-ncurses.patch
+ tc-export CC
+}
+
+src_compile() {
+ default
+ if use X; then
+ cd GUI
+ eqmake4 ${PN}_GUI.pro && emake clean && emake
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${ED}" docdir=/usr/share/doc/${PF} install
+ use X && dosbin GUI/i7z_GUI
+}
diff --git a/app-benchmarks/i7z/metadata.xml b/app-benchmarks/i7z/metadata.xml
new file mode 100644
index 000000000000..00ecf9d76c06
--- /dev/null
+++ b/app-benchmarks/i7z/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="google-code">i7z</remote-id>
+ </upstream>
+</pkgmetadata>