summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2020-05-31 13:39:00 +0200
committerPacho Ramos <pacho@gentoo.org>2020-05-31 14:42:22 +0200
commit9eda907a2533811b443338bb02428561a5f9e5b5 (patch)
tree82e0bae4d5974f822626be36ebcddcf5d1f8e78f /app-benchmarks/i7z
parentnet-misc/r8168: Bump to 8.048.03 (diff)
downloadgentoo-9eda907a2533811b443338bb02428561a5f9e5b5.tar.gz
gentoo-9eda907a2533811b443338bb02428561a5f9e5b5.tar.bz2
gentoo-9eda907a2533811b443338bb02428561a5f9e5b5.zip
app-benchmarks/i7z: Fix for gcc10 and some typos
(from Debian) Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'app-benchmarks/i7z')
-rw-r--r--app-benchmarks/i7z/files/gcc-10.patch17
-rw-r--r--app-benchmarks/i7z/files/typos.patch25
-rw-r--r--app-benchmarks/i7z/i7z-93_p20131012-r2.ebuild5
3 files changed, 44 insertions, 3 deletions
diff --git a/app-benchmarks/i7z/files/gcc-10.patch b/app-benchmarks/i7z/files/gcc-10.patch
new file mode 100644
index 000000000000..206b2c143402
--- /dev/null
+++ b/app-benchmarks/i7z/files/gcc-10.patch
@@ -0,0 +1,17 @@
+Author: Andreas Beckmann <anbe@debian.org>
+Description: fix FTBFS with gcc-10
+ gcc-10 defaults to -fno-common
+ see https://gcc.gnu.org/gcc-10/porting_to.html
+Bug-Debian: https://bugs.debian.org/957351
+
+--- a/i7z_Dual_Socket.c
++++ b/i7z_Dual_Socket.c
+@@ -37,7 +37,7 @@ float Read_Voltage_CPU(int cpu_num);
+ extern struct program_options prog_options;
+ FILE *fp_log_file;
+
+-struct timespec global_ts;
++extern struct timespec global_ts;
+ extern FILE *fp_log_file_freq_1, *fp_log_file_freq_2;
+
+ extern char* CPU_FREQUENCY_LOGGING_FILE_single;
diff --git a/app-benchmarks/i7z/files/typos.patch b/app-benchmarks/i7z/files/typos.patch
new file mode 100644
index 000000000000..9b1f3b952166
--- /dev/null
+++ b/app-benchmarks/i7z/files/typos.patch
@@ -0,0 +1,25 @@
+Author: Andreas Beckmann <anbe@debian.org>
+Description: fix typos found by Lintian
+
+--- a/helper_functions.c
++++ b/helper_functions.c
+@@ -528,7 +528,7 @@ void Test_Or_Make_MSR_DEVICE_FILES()
+ n=`expr $n + 1`; \
+ done; \
+ ");
+- printf ("i7z DEBUG: modprobbing for msr\n");
++ printf ("i7z DEBUG: modprobing for msr\n");
+ system ("modprobe msr");
+ } else {
+ printf ("i7z DEBUG: You DO NOT have root privileges, mknod to create device entries won't work out\n");
+--- a/perfmon-i7z/helper_functions.cpp
++++ b/perfmon-i7z/helper_functions.cpp
+@@ -484,7 +484,7 @@ void Test_Or_Make_MSR_DEVICE_FILES()
+ n=`expr $n + 1`; \
+ done; \
+ ");
+- printf ("i7z DEBUG: modprobbing for msr\n");
++ printf ("i7z DEBUG: modprobing for msr\n");
+ system ("modprobe msr");
+ } else {
+ printf ("i7z DEBUG: You DONOT have root privileges, mknod to create device entries won't work out\n");
diff --git a/app-benchmarks/i7z/i7z-93_p20131012-r2.ebuild b/app-benchmarks/i7z/i7z-93_p20131012-r2.ebuild
index 47b4c7b42ecc..c2e8656b7af9 100644
--- a/app-benchmarks/i7z/i7z-93_p20131012-r2.ebuild
+++ b/app-benchmarks/i7z/i7z-93_p20131012-r2.ebuild
@@ -36,14 +36,13 @@ PATCHES=(
"${FILESDIR}"/install-i7z_rw_registers.patch
"${FILESDIR}"/use_stdbool.patch
"${FILESDIR}"/nehalem.patch
+ "${FILESDIR}"/gcc-10.patch
+ "${FILESDIR}"/typos.patch
)
S="${WORKDIR}/${PN}-${COMMIT}"
src_configure() {
- # Workaround to build with gcc-10 until I find a patch
- append-cflags -fcommon
-
tc-export CC PKG_CONFIG
cd GUI || die
use qt5 && eqmake5 ${PN}_GUI.pro