summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-benchmarks/libc-bench
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-benchmarks/libc-bench')
-rw-r--r--app-benchmarks/libc-bench/Manifest1
-rw-r--r--app-benchmarks/libc-bench/files/respect-flags.patch23
-rw-r--r--app-benchmarks/libc-bench/libc-bench-20110206.ebuild29
-rw-r--r--app-benchmarks/libc-bench/metadata.xml8
4 files changed, 61 insertions, 0 deletions
diff --git a/app-benchmarks/libc-bench/Manifest b/app-benchmarks/libc-bench/Manifest
new file mode 100644
index 000000000000..d702501f23db
--- /dev/null
+++ b/app-benchmarks/libc-bench/Manifest
@@ -0,0 +1 @@
+DIST libc-bench-20110206.tar.gz 3135 SHA256 6825260aa5f15f4fbc7957ec578e9c859cbbe210e025ec74c4a0d05677523794 SHA512 72f68616ab189f39f766c98afbb83bf3470a4e14ccb1dfe139a9006227262197546897da8f360bf48ba2c8854730aa385ca16270ec2e6cf2b531205550726f38 WHIRLPOOL 4145b3e55ae3fa22b14055deb9d5948b6bd891cd62da99199136c82cda4285d0332a8ee48764c32ecf47703e9f20825af064bb34448e0f124bd48987b67e0050
diff --git a/app-benchmarks/libc-bench/files/respect-flags.patch b/app-benchmarks/libc-bench/files/respect-flags.patch
new file mode 100644
index 000000000000..19958fd1c91b
--- /dev/null
+++ b/app-benchmarks/libc-bench/files/respect-flags.patch
@@ -0,0 +1,23 @@
+diff -Naur libc-bench-20110206.orig//Makefile libc-bench-20110206/Makefile
+--- libc-bench-20110206.orig//Makefile 2011-01-31 02:13:00.000000000 -0500
++++ libc-bench-20110206/Makefile 2012-08-09 22:12:24.000000000 -0400
+@@ -2,8 +2,7 @@
+ SRCS = $(sort $(wildcard *.c))
+ OBJS = $(SRCS:.c=.o)
+
+-CFLAGS = -Os
+-LDFLAGS = -static
++LDFLAGS += -static
+ LIBS = -lpthread -lrt -lpthread
+
+
+@@ -12,9 +11,6 @@
+ clean:
+ rm -f $(OBJS) libc-bench
+
+-test: all
+- ./libc-bench
+-
+ libc-bench: $(OBJS)
+ $(CC) $(LDFLAGS) -o $@ $(OBJS) $(LIBS)
+
diff --git a/app-benchmarks/libc-bench/libc-bench-20110206.ebuild b/app-benchmarks/libc-bench/libc-bench-20110206.ebuild
new file mode 100644
index 000000000000..ba48983a776e
--- /dev/null
+++ b/app-benchmarks/libc-bench/libc-bench-20110206.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Time and memory-efficiency tests of various C/POSIX standard library functions"
+HOMEPAGE="http://www.etalabs.net/libc-bench.html http://git.musl-libc.org/cgit/libc-bench/"
+SRC_URI="http://www.etalabs.net/releases/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/respect-flags.patch
+}
+
+src_configure() {
+ tc-export CC
+ CFLAGS+=" ${CPPFLAGS}"
+}
+
+src_install() {
+ dobin libc-bench
+}
diff --git a/app-benchmarks/libc-bench/metadata.xml b/app-benchmarks/libc-bench/metadata.xml
new file mode 100644
index 000000000000..1e7587374fdf
--- /dev/null
+++ b/app-benchmarks/libc-bench/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>blueness@gentoo.org</email>
+ <name>Anthony G. Basile</name>
+ </maintainer>
+</pkgmetadata>