summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger (asterix) <m.mairkeimberger@gmail.com>2016-07-03 16:15:24 +0200
committerPatrice Clement <monsieurp@gentoo.org>2016-07-07 07:18:23 +0000
commitb4b9543d00f947d318f671b4a47477a70d35ff6d (patch)
treed00e5a2ef034ebbf2ed39be6d704408140da1bcd /app-benchmarks/piozone
parentapp-benchmarks/ltp: remove unused patch (diff)
downloadgentoo-b4b9543d00f947d318f671b4a47477a70d35ff6d.tar.gz
gentoo-b4b9543d00f947d318f671b4a47477a70d35ff6d.tar.bz2
gentoo-b4b9543d00f947d318f671b4a47477a70d35ff6d.zip
app-benchmarks/piozone: remove unused patch
Closes: https://github.com/gentoo/gentoo/pull/1826 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-benchmarks/piozone')
-rw-r--r--app-benchmarks/piozone/files/piozone-1.0-gentoo.diff49
1 files changed, 0 insertions, 49 deletions
diff --git a/app-benchmarks/piozone/files/piozone-1.0-gentoo.diff b/app-benchmarks/piozone/files/piozone-1.0-gentoo.diff
deleted file mode 100644
index aa9a91d5ea35..000000000000
--- a/app-benchmarks/piozone/files/piozone-1.0-gentoo.diff
+++ /dev/null
@@ -1,49 +0,0 @@
-diff -Naur piozone-1.0.orig/Makefile piozone-1.0/Makefile
---- piozone-1.0.orig/Makefile 2003-07-10 18:54:51.000000000 -0300
-+++ piozone-1.0/Makefile 2003-07-10 19:02:41.000000000 -0300
-@@ -19,3 +19,6 @@
-
- dist: version distclean
- (PACKNAME=`basename \`pwd\`` ; cd .. ; $(TAR) cf - $$PACKNAME | $(GZIP) -9 >$$PACKNAME.tar.gz)
-+
-+install:
-+ install -D piozone /usr/bin/piozone
-diff -Naur piozone-1.0.orig/piozone.c piozone-1.0/piozone.c
---- piozone-1.0.orig/piozone.c 2003-07-10 18:54:51.000000000 -0300
-+++ piozone-1.0/piozone.c 2003-07-10 14:48:44.000000000 -0300
-@@ -20,7 +20,7 @@
- #include <fcntl.h>
- #include <time.h>
- #include <signal.h>
--
-+#define uint64_t u_int64_t
- #define KiB ((uint64_t) 1024)
- #define MiB ((uint64_t) 1024*KiB)
- #define GiB ((uint64_t) 1024*MiB)
-@@ -73,7 +73,7 @@
- int count = 0;
- int nr = 0;
-
-- llseek(fd, off, SEEK_SET);
-+ lseek64(fd, off, SEEK_SET);
- signal(SIGALRM, sigalrm_handler);
- stopf = 0;
- printf("Testing... ");
-@@ -121,7 +121,7 @@
- printf("Testing... ");
- alarm(ts);
- while (!stopf &&
-- llseek(fd, off+((rand()&area)*MiB), SEEK_SET) != -1 &&
-+ lseek64(fd, off+((rand()&area)*MiB), SEEK_SET) != -1 &&
- (nr = read(fd, iobuf, len)) == len)
- {
- print_dial();
-@@ -159,7 +159,7 @@
- off = 0;
- del = 64*GiB;
-
-- while (del > 8*KiB && llseek(fd, off+del, SEEK_SET) != -1)
-+ while (del > 8*KiB && lseek64(fd, off+del, SEEK_SET) != -1)
- {
- if (read(fd, buf, 8*KiB) < 0)
- del >>= 1;