summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrahmajit Das <brahmajit.xyz@gmail.com>2023-09-06 03:54:04 +0000
committerArthur Zamarin <arthurzam@gentoo.org>2023-09-25 10:04:46 +0300
commitd19d062191044a4501fd5d968426621820540ac8 (patch)
tree50b3a1d344c08beaa7ae8e50b96ef91997298dbb /app-benchmarks/pipebench
parentdev-libs/libx86emu: add 3.5 (diff)
downloadgentoo-d19d062191044a4501fd5d968426621820540ac8.tar.gz
gentoo-d19d062191044a4501fd5d968426621820540ac8.tar.bz2
gentoo-d19d062191044a4501fd5d968426621820540ac8.zip
app-benchmarks/pipebench: Fix call to undeclared function atoi
Closes: https://bugs.gentoo.org/894336 Signed-off-by: Brahmajit Das <brahmajit.xyz@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/32643 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-benchmarks/pipebench')
-rw-r--r--app-benchmarks/pipebench/files/pipebench-0.40-fix-build-clang16.patch12
-rw-r--r--app-benchmarks/pipebench/pipebench-0.40-r3.ebuild24
2 files changed, 36 insertions, 0 deletions
diff --git a/app-benchmarks/pipebench/files/pipebench-0.40-fix-build-clang16.patch b/app-benchmarks/pipebench/files/pipebench-0.40-fix-build-clang16.patch
new file mode 100644
index 000000000000..1cc891bd7f08
--- /dev/null
+++ b/app-benchmarks/pipebench/files/pipebench-0.40-fix-build-clang16.patch
@@ -0,0 +1,12 @@
+Bug: https://bugs.gentoo.org/894336
+--- a/pipebench.c
++++ b/pipebench.c
+@@ -28,6 +28,8 @@
+ */
+ #include <stdio.h>
+ #include <unistd.h>
++#include <stdlib.h>
++#include <string.h>
+ #include <time.h>
+ #include <signal.h>
+ #include <sys/time.h>
diff --git a/app-benchmarks/pipebench/pipebench-0.40-r3.ebuild b/app-benchmarks/pipebench/pipebench-0.40-r3.ebuild
new file mode 100644
index 000000000000..39367bba594d
--- /dev/null
+++ b/app-benchmarks/pipebench/pipebench-0.40-r3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Measures the speed of stdin/stdout communication"
+HOMEPAGE="https://www.habets.pp.se/synscan/programs_pipebench.html"
+SRC_URI="https://www.habets.pp.se/synscan/files/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~x86 ~x86-linux"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.40-fix-build-system.patch
+ "${FILESDIR}"/${PN}-0.40-fix-build-clang16.patch
+)
+
+src_configure() {
+ append-cflags -Wall -w -pedantic
+ tc-export CC
+}