summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-03-12 22:45:22 +0100
committerConrad Kostecki <conikost@gentoo.org>2020-03-12 23:46:55 +0100
commitdb5fa11ef69957741fcd21b08910b2dcf5e167bd (patch)
treebf5bc0d0b9f431203496afeac0ca7b40a6dc82c7 /app-benchmarks/stress-ng/files/stress-ng-0.11.02-makefile.patch
parentnet-vpn/networkmanager-strongswan: prepare for nm-1.22 bump (diff)
downloadgentoo-db5fa11ef69957741fcd21b08910b2dcf5e167bd.tar.gz
gentoo-db5fa11ef69957741fcd21b08910b2dcf5e167bd.tar.bz2
gentoo-db5fa11ef69957741fcd21b08910b2dcf5e167bd.zip
app-benchmarks/stress-ng: bump to version 0.11.02
Package-Manager: Portage-2.3.93, Repoman-2.3.20 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-benchmarks/stress-ng/files/stress-ng-0.11.02-makefile.patch')
-rw-r--r--app-benchmarks/stress-ng/files/stress-ng-0.11.02-makefile.patch64
1 files changed, 64 insertions, 0 deletions
diff --git a/app-benchmarks/stress-ng/files/stress-ng-0.11.02-makefile.patch b/app-benchmarks/stress-ng/files/stress-ng-0.11.02-makefile.patch
new file mode 100644
index 000000000000..bce1907d139d
--- /dev/null
+++ b/app-benchmarks/stress-ng/files/stress-ng-0.11.02-makefile.patch
@@ -0,0 +1,64 @@
+Always respect users CFLAGS, enable verbose output when compiling
+and don't install compressed man pages.
+
+--- a/Makefile
++++ b/Makefile
+@@ -21,7 +21,7 @@
+ # Codename "synthetic system strainer"
+ #
+
+-CFLAGS += -Wall -Wextra -DVERSION='"$(VERSION)"' -O2 -std=gnu99
++CFLAGS += -Wall -Wextra -DVERSION='"$(VERSION)"' -std=gnu99
+
+ #
+ # Pedantic flags
+@@ -357,12 +357,10 @@
+ .o: stress-ng.h Makefile
+
+ .c.o: stress-ng.h Makefile $(SRC)
+- @echo "CC $<"
+- @$(CC) $(CFLAGS) -c -o $@ $<
++ $(CC) $(CFLAGS) -c -o $@ $<
+
+ stress-ng: $(OBJS)
+- @echo "LD $@"
+- @$(CC) $(CPPFLAGS) $(CFLAGS) $(OBJS) -lm $(LDFLAGS) -o $@
++ $(CC) $(CPPFLAGS) $(CFLAGS) $(OBJS) -lm $(LDFLAGS) -o $@
+ @sync
+
+ makeconfig:
+@@ -383,7 +381,7 @@
+ sed '$$ s/.$$//' >> apparmor-data.c
+ @echo "};" >> apparmor-data.c
+ @echo "const size_t g_apparmor_data_len = sizeof(g_apparmor_data);" >> apparmor-data.c
+- @echo "CC $<"
++ echo "CC $<"
+ @$(CC) -c apparmor-data.c -o apparmor-data.o
+ @rm -rf apparmor-data.c apparmor-data.bin
+
+@@ -399,12 +397,12 @@
+ core-perf.o: core-perf.c core-perf-event.c
+ @$(CC) $(CFLAGS) -E core-perf-event.c | grep "PERF_COUNT" | sed 's/,/ /' | \
+ awk {'print "#define _SNG_" $$1 " (1)"'} > core-perf-event.h
+- @echo CC $<
+- @$(CC) $(CFLAGS) -c -o $@ $<
++ echo CC $<
++ $(CC) $(CFLAGS) -c -o $@ $<
+
+ stress-vecmath.o: stress-vecmath.c
+- @echo CC $<
+- @$(CC) $(CFLAGS) -fno-builtin -c -o $@ $<
++ echo CC $<
++ $(CC) $(CFLAGS) -fno-builtin -c -o $@ $<
+ @touch stress-ng.c
+
+ $(OBJS): stress-ng.h Makefile
+@@ -453,7 +451,7 @@
+ mkdir -p ${DESTDIR}${BINDIR}
+ cp stress-ng ${DESTDIR}${BINDIR}
+ mkdir -p ${DESTDIR}${MANDIR}
+- cp stress-ng.1.gz ${DESTDIR}${MANDIR}
++ cp stress-ng.1 ${DESTDIR}${MANDIR}
+ mkdir -p ${DESTDIR}${JOBDIR}
+ cp -rp example-jobs/*.job ${DESTDIR}${JOBDIR}
+ mkdir -p ${DESTDIR}${BASHDIR}