summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2018-05-05 02:04:56 +0200
committerMichał Górny <mgorny@gentoo.org>2018-05-15 18:26:08 +0200
commitbaed68221030b4fe96e31ba2dc74702eb43b27b2 (patch)
tree564c0084800737f6ef7440b4f1af75c2807045f4 /app-benchmarks/stress-ng
parentprofiles: package.use.mask include consumers of virtual/mysql[embedded] (diff)
downloadgentoo-baed68221030b4fe96e31ba2dc74702eb43b27b2.tar.gz
gentoo-baed68221030b4fe96e31ba2dc74702eb43b27b2.tar.bz2
gentoo-baed68221030b4fe96e31ba2dc74702eb43b27b2.zip
app-benchmarks/stress-ng: Bump to version 0.09.26
Closes: https://bugs.gentoo.org/650140 Closes: https://github.com/gentoo/gentoo/pull/8264 Package-Manager: Portage-2.3.35, Repoman-2.3.9
Diffstat (limited to 'app-benchmarks/stress-ng')
-rw-r--r--app-benchmarks/stress-ng/Manifest1
-rw-r--r--app-benchmarks/stress-ng/files/makefile.patch81
-rw-r--r--app-benchmarks/stress-ng/metadata.xml17
-rw-r--r--app-benchmarks/stress-ng/stress-ng-0.09.27.ebuild30
4 files changed, 128 insertions, 1 deletions
diff --git a/app-benchmarks/stress-ng/Manifest b/app-benchmarks/stress-ng/Manifest
index b126cefbbce5..7c1932c99a04 100644
--- a/app-benchmarks/stress-ng/Manifest
+++ b/app-benchmarks/stress-ng/Manifest
@@ -1,2 +1,3 @@
DIST stress-ng-0.05.12.tar.gz 280758 BLAKE2B 0d25a0ecddf75cfd19a0bd26c2ca7390d8d999d8e0de4735e71dcda52de9fbce33800475a8137985469eeadad21f57d14530f69bdd2284f82e6df487b5f8ec32 SHA512 ee622b1d8fd1b3ddee6119f5a43cedb427e3524bb6ef10f7ac96c305567c9919574e9103949825e2bea3391c302b6e2b5871667bc8f8609844765b64ec760bc8
DIST stress-ng-0.06.00.tar.gz 311761 BLAKE2B 725e902344602a9922b2d39a247a7b6c4d88cd69506addb9b8910221a5d6aa438b69cc1f3ac5c8265de2be7e0973b9dfbc4f93493f4437ee23d4f84c8712cd5d SHA512 a23a3f020e1fa777c6141db8f9d91833b9758172974be0db341c757eb7b407520b80bc9889eb7b6348cfa64d8f8976ba6ad8761a5fbc31055accd8fbceb8de66
+DIST stress-ng-0.09.27.tar.xz 344456 BLAKE2B 4609f438372c6d52e0e7e7f5ed1a29e1a32282c8cd2c978e9599d396fbb3c9da0fde6c3814f13ec4519e8d3d9c020171757d66cec12257195b5436598223493c SHA512 15295a7e2dbd2fc89d66fae57902b182ae4f84dac8a4aa5c0f80a81789ca2e04459aa9adba6f9b6735e05d687fedef1bc0d77ff9269044a46c8dca612bff883a
diff --git a/app-benchmarks/stress-ng/files/makefile.patch b/app-benchmarks/stress-ng/files/makefile.patch
new file mode 100644
index 000000000000..eecb12cad5b4
--- /dev/null
+++ b/app-benchmarks/stress-ng/files/makefile.patch
@@ -0,0 +1,81 @@
+--- a/Makefile 2018-04-27 17:02:16.000000000 +0200
++++ b/Makefile 2018-05-13 20:54:08.741008488 +0200
+@@ -21,7 +21,7 @@
+ # Codename "portable pressure producer"
+ #
+
+-CFLAGS += -Wall -Wextra -DVERSION='"$(VERSION)"' -O2 -std=gnu99
++CFLAGS += -Wall -Wextra -DVERSION='"$(VERSION)"'
+
+ #
+ # Pedantic flags
+@@ -314,12 +314,9 @@
+ .o: stress-ng.h Makefile
+
+ .c.o: stress-ng.h Makefile $(SRC)
+- @echo "CC $<"
+- @$(CC) $(CFLAGS) -c -o $@ $<
+
+ stress-ng: info $(OBJS)
+- @echo "LD $@"
+- @$(CC) $(CPPFLAGS) $(CFLAGS) $(OBJS) -lm $(LDFLAGS) -lc -o $@
++ $(CC) $(CPPFLAGS) $(CFLAGS) $(OBJS) -lm $(LDFLAGS) -lc -o $@
+ @sync
+
+ .PHONY: info
+@@ -339,8 +336,7 @@
+ sed '$$ s/.$$//' >> apparmor-data.c
+ @echo "};" >> apparmor-data.c
+ @echo "const size_t g_apparmor_data_len = sizeof(g_apparmor_data);" >> apparmor-data.c
+- @echo "CC $<"
+- @$(CC) -c apparmor-data.c -o apparmor-data.o
++ $(CC) $(CFLAGS) $(CPPFLAGS) -c apparmor-data.c -o apparmor-data.o
+ @rm -rf apparmor-data.c
+
+ #
+@@ -353,20 +349,15 @@
+ stress-personality.c: personality.h
+
+ perf.o: perf.c perf-event.c
+- @$(CC) -E perf-event.c | grep "PERF_COUNT" | sed 's/,/ /' | awk {'print "#define _SNG_" $$1 " (1)"'} > perf-event.h
+- @echo CC $<
+- @$(CC) $(CFLAGS) -c -o $@ $<
++ $(CC) $(CFLAGS) $(CPPFLAGS) -E perf-event.c | grep "PERF_COUNT" | sed 's/,/ /' | awk {'print "#define _SNG_" $$1 " (1)"'} > perf-event.h
++ $(CC) $(CFLAGS) $(CPPFLAGS) -c -o $@ $<
+
+ stress-vecmath.o: stress-vecmath.c
+- @echo CC $<
+- @$(CC) $(CFLAGS) -fno-builtin -c -o $@ $<
++ $(CC) $(CFLAGS) $(CPPFLAGS) -fno-builtin -c -o $@ $<
+ @touch stress-ng.c
+
+ $(OBJS): stress-ng.h Makefile
+
+-stress-ng.1.gz: stress-ng.1
+- gzip -c $< > $@
+-
+ .PHONY: dist
+ dist:
+ rm -rf stress-ng-$(VERSION)
+@@ -386,7 +377,7 @@
+
+ .PHONY: clean
+ clean:
+- @rm -f stress-ng $(OBJS) stress-ng.1.gz stress-ng.pdf
++ @rm -f stress-ng $(OBJS) stress-ng.pdf
+ @rm -f stress-ng-$(VERSION).tar.xz
+ @rm -f personality.h
+ @rm -f perf-event.h
+@@ -398,10 +389,10 @@
+ STRESS_NG=./stress-ng debian/tests/fast-test-all
+
+ .PHONY: install
+-install: stress-ng stress-ng.1.gz
++install: stress-ng
+ mkdir -p ${DESTDIR}${BINDIR}
+ cp stress-ng ${DESTDIR}${BINDIR}
+ mkdir -p ${DESTDIR}${MANDIR}
+- cp stress-ng.1.gz ${DESTDIR}${MANDIR}
++ cp stress-ng.1 ${DESTDIR}${MANDIR}
+ mkdir -p ${DESTDIR}${JOBDIR}
+ cp -rp example-jobs/*.job ${DESTDIR}${JOBDIR}
diff --git a/app-benchmarks/stress-ng/metadata.xml b/app-benchmarks/stress-ng/metadata.xml
index 6f49eba8f496..2fbf8ab09005 100644
--- a/app-benchmarks/stress-ng/metadata.xml
+++ b/app-benchmarks/stress-ng/metadata.xml
@@ -1,5 +1,20 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<!-- maintainer-needed -->
+ <maintainer type="person">
+ <email>ck+gentoo@bl4ckb0x.de</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ Stress-ng will stress test a computer system in various selectable ways.
+ It was designed to exercise various physical subsystems of a computer
+ as well as the various operating system kernel interfaces.
+ It features 200 stress tests, 70 CPU specific stress tests,
+ that exercise floating point, integer, bit manipulation and control flow
+ and over 20 virtual memory stress tests.
+ </longdescription>
</pkgmetadata>
diff --git a/app-benchmarks/stress-ng/stress-ng-0.09.27.ebuild b/app-benchmarks/stress-ng/stress-ng-0.09.27.ebuild
new file mode 100644
index 000000000000..125fd0edb3e2
--- /dev/null
+++ b/app-benchmarks/stress-ng/stress-ng-0.09.27.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Stress test for a computer system with various selectable ways"
+HOMEPAGE="http://kernel.ubuntu.com/~cking/stress-ng/"
+SRC_URI="http://kernel.ubuntu.com/~cking/tarballs/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-libs/libaio
+ dev-libs/libbsd
+ dev-libs/libgcrypt:0=
+ net-misc/lksctp-tools
+ sys-apps/attr
+ sys-apps/keyutils
+ sys-libs/libapparmor
+ sys-libs/libcap
+ sys-libs/zlib:="
+
+RDEPEND="${DEPEND}"
+
+DOCS=( "README" "README.Android" "TODO" "syscalls.txt" )
+
+PATCHES=( "${FILESDIR}/makefile.patch" )
+
+QA_WX_LOAD="usr/bin/stress-ng"