summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2017-01-28 07:13:51 +0000
committerGöktürk Yüksek <gokturk@gentoo.org>2017-01-28 23:26:15 -0500
commitba0b857a1ff9347dce82b9abb67285ba45529ea3 (patch)
tree5dc82a5d04c2d6343dcc023661569dd8f38850dd /app-benchmarks/sysbench/sysbench-9999.ebuild
parentapp-benchmarks/sysbench: bump to 1.0_pre20170122 (diff)
downloadgentoo-ba0b857a1ff9347dce82b9abb67285ba45529ea3.tar.gz
gentoo-ba0b857a1ff9347dce82b9abb67285ba45529ea3.tar.bz2
gentoo-ba0b857a1ff9347dce82b9abb67285ba45529ea3.zip
app-benchmarks/sysbench: sync live ebuild
Diffstat (limited to 'app-benchmarks/sysbench/sysbench-9999.ebuild')
-rw-r--r--app-benchmarks/sysbench/sysbench-9999.ebuild22
1 files changed, 12 insertions, 10 deletions
diff --git a/app-benchmarks/sysbench/sysbench-9999.ebuild b/app-benchmarks/sysbench/sysbench-9999.ebuild
index f6055be8c1da..814a38182c64 100644
--- a/app-benchmarks/sysbench/sysbench-9999.ebuild
+++ b/app-benchmarks/sysbench/sysbench-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -10,43 +10,45 @@ DESCRIPTION="System performance benchmark"
HOMEPAGE="https://github.com/akopytov/sysbench"
EGIT_REPO_URI="https://github.com/akopytov/sysbench.git"
-EGIT_BRANCH="1.0"
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS=""
-IUSE="aio lua mysql postgres test"
+IUSE="aio mysql postgres test"
RDEPEND="aio? ( dev-libs/libaio )
- lua? ( dev-lang/lua:= )
mysql? ( virtual/libmysqlclient )
postgres? ( dev-db/postgresql:= )"
DEPEND="${RDEPEND}
- sys-devel/libtool:=
+ app-editors/vim-core
+ dev-lang/luajit:=
+ dev-libs/concurrencykit
dev-libs/libxslt
+ sys-devel/libtool:=
+ virtual/pkgconfig
test? ( dev-util/cram )"
-REQUIRED_USE="
- mysql? ( lua )
- postgres? ( lua )"
-
src_prepare() {
default
sed -i -e "/^htmldir =/s:=.*:=/usr/share/doc/${PF}/html:" doc/Makefile.am || die
+ # remove bundled libs
+ rm -r third_party/luajit/luajit third_party/concurrency_kit/ck || die
+
./autogen.sh || die
}
src_configure() {
local myeconfargs=(
$(use_enable aio aio)
- $(use_with lua lua)
$(use_with mysql mysql)
$(use_with postgres pgsql)
--without-attachsql
--without-drizzle
--without-oracle
+ --with-system-luajit
+ --with-system-ck
)
econf "${myeconfargs[@]}"