summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-benchmarks/wrk/files/wrk-3.1.1-makefile.patch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-benchmarks/wrk/files/wrk-3.1.1-makefile.patch')
-rw-r--r--app-benchmarks/wrk/files/wrk-3.1.1-makefile.patch54
1 files changed, 54 insertions, 0 deletions
diff --git a/app-benchmarks/wrk/files/wrk-3.1.1-makefile.patch b/app-benchmarks/wrk/files/wrk-3.1.1-makefile.patch
new file mode 100644
index 000000000000..595c69ac1572
--- /dev/null
+++ b/app-benchmarks/wrk/files/wrk-3.1.1-makefile.patch
@@ -0,0 +1,54 @@
+diff --git i/Makefile w/Makefile
+index d956c6b..48be677 100644
+--- i/Makefile
++++ w/Makefile
+@@ -1,4 +1,4 @@
+-CFLAGS := -std=c99 -Wall -O2 -D_REENTRANT
++CFLAGS += -std=c99 -Wall -D_REENTRANT
+ LIBS := -lpthread -lm -lcrypto -lssl
+
+ TARGET := $(shell uname -s | tr '[A-Z]' '[a-z]' 2>/dev/null || echo unknown)
+@@ -23,38 +23,31 @@ BIN := wrk
+ ODIR := obj
+ OBJ := $(patsubst %.c,$(ODIR)/%.o,$(SRC)) $(ODIR)/bytecode.o
+
+-LDIR = deps/luajit/src
+-LIBS := -lluajit $(LIBS)
+-CFLAGS += -I$(LDIR)
+-LDFLAGS += -L$(LDIR)
++LIBS := $(shell pkg-config --libs luajit) $(LIBS)
++CFLAGS += $(shell pkg-config --cflags luajit)
+
+ all: $(BIN)
+
+ clean:
+ $(RM) $(BIN) obj/*
+- @$(MAKE) -C deps/luajit clean
+
+ $(BIN): $(OBJ)
+ @echo LINK $(BIN)
+- @$(CC) $(LDFLAGS) -o $@ $^ $(LIBS)
++ @$(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ $(LIBS)
+
+-$(OBJ): config.h Makefile $(LDIR)/libluajit.a | $(ODIR)
++$(OBJ): config.h Makefile | $(ODIR)
+
+ $(ODIR):
+ @mkdir -p $@
+
+ $(ODIR)/bytecode.o: src/wrk.lua
+ @echo LUAJIT $<
+- @$(SHELL) -c 'cd $(LDIR) && ./luajit -b $(CURDIR)/$< $(CURDIR)/$@'
++ @$(SHELL) -c 'luajit -b $(CURDIR)/$< $(CURDIR)/$@'
+
+ $(ODIR)/%.o : %.c
+ @echo CC $<
+ @$(CC) $(CFLAGS) -c -o $@ $<
+
+-$(LDIR)/libluajit.a:
+- @echo Building LuaJIT...
+- @$(MAKE) -C $(LDIR) BUILDMODE=static
+-
+ .PHONY: all clean
+ .SUFFIXES:
+ .SUFFIXES: .c .o .lua