summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2018-11-09 12:12:00 +0100
committerPatrice Clement <monsieurp@gentoo.org>2019-01-20 23:56:30 +0100
commit3699f64fa928e498f86e3d6761ff2d20712042cd (patch)
tree31fa5f956a516916f1a5689dac94f17afe686d96 /app-benchmarks/wrk/files/wrk-4.1.0-r1-makefile.patch
parentdev-util/pkgcheck: don't run pplugincache for all py versions (diff)
downloadgentoo-3699f64fa928e498f86e3d6761ff2d20712042cd.tar.gz
gentoo-3699f64fa928e498f86e3d6761ff2d20712042cd.tar.bz2
gentoo-3699f64fa928e498f86e3d6761ff2d20712042cd.zip
app-benchmarks/wrk: bump to EAPI 7.
I will also proxy maintain this package. Signed-off-by: Conrad Kostecki <conrad@kostecki.com> Package-Manager: Portage-2.3.51, Repoman-2.3.11 Closes: https://github.com/gentoo/gentoo/pull/10374 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-benchmarks/wrk/files/wrk-4.1.0-r1-makefile.patch')
-rw-r--r--app-benchmarks/wrk/files/wrk-4.1.0-r1-makefile.patch37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-benchmarks/wrk/files/wrk-4.1.0-r1-makefile.patch b/app-benchmarks/wrk/files/wrk-4.1.0-r1-makefile.patch
new file mode 100644
index 000000000000..6e7dd317b8fb
--- /dev/null
+++ b/app-benchmarks/wrk/files/wrk-4.1.0-r1-makefile.patch
@@ -0,0 +1,37 @@
+--- a/Makefile 2018-01-21 07:00:58.000000000 +0100
++++ b/Makefile 2018-11-09 11:58:57.000000000 +0100
+@@ -1,4 +1,4 @@
+-CFLAGS += -std=c99 -Wall -O2 -D_REENTRANT
++CFLAGS += -std=c99 -Wall -D_REENTRANT
+ LIBS := -lpthread -lm -lssl -lcrypto
+
+ TARGET := $(shell uname -s | tr '[A-Z]' '[a-z]' 2>/dev/null || echo unknown)
+@@ -24,7 +24,7 @@
+
+ ODIR := obj
+ OBJ := $(patsubst %.c,$(ODIR)/%.o,$(SRC)) $(ODIR)/bytecode.o $(ODIR)/version.o
+-LIBS := -lluajit-5.1 $(LIBS)
++LIBS := $(shell pkg-config luajit --libs) $(LIBS)
+
+ DEPS :=
+ CFLAGS += -I$(ODIR)/include
+@@ -51,8 +51,7 @@
+ $(RM) -rf $(BIN) obj/*
+
+ $(BIN): $(OBJ)
+- @echo LINK $(BIN)
+- @$(CC) $(LDFLAGS) -o $@ $^ $(LIBS)
++ $(CC) $(LDFLAGS) -o $@ $^ $(LIBS)
+
+ $(OBJ): config.h Makefile $(DEPS) | $(ODIR)
+
+@@ -67,8 +66,7 @@
+ @echo 'const char *VERSION="$(VER)";' | $(CC) -xc -c -o $@ -
+
+ $(ODIR)/%.o : %.c
+- @echo CC $<
+- @$(CC) $(CFLAGS) -c -o $@ $<
++ $(CC) $(CFLAGS) -c -o $@ $<
+
+ # Dependencies
+