summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2019-02-21 20:44:02 +0100
committerPatrice Clement <monsieurp@gentoo.org>2019-02-22 22:08:25 +0100
commit50a19d3c52f3a304f4770349aaa5affac5b69306 (patch)
treec1f838be9ccf52d060d6ea0f3a317ea5131fe6a3 /app-benchmarks
parentapp-dicts/myspell-de: remove old. (diff)
downloadgentoo-50a19d3c52f3a304f4770349aaa5affac5b69306.tar.gz
gentoo-50a19d3c52f3a304f4770349aaa5affac5b69306.tar.bz2
gentoo-50a19d3c52f3a304f4770349aaa5affac5b69306.zip
app-benchmarks/interbench: new package.
The Linux interactivity benchmark. It is designed to measure the effect of changed in Linux kernel design or system configuration changes such as CPU, I/O scheduler and filesystem changes and options. Closes: https://bugs.gentoo.org/100145 Package-Manager: Portage-2.3.60, Repoman-2.3.12 Signed-off-by: Conrad Kostecki <conrad@kostecki.com> Closes: https://github.com/gentoo/gentoo/pull/10316 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-benchmarks')
-rw-r--r--app-benchmarks/interbench/Manifest1
-rw-r--r--app-benchmarks/interbench/files/interbench-0.31-makefile.patch16
-rw-r--r--app-benchmarks/interbench/interbench-0.31.ebuild37
-rw-r--r--app-benchmarks/interbench/metadata.xml22
4 files changed, 76 insertions, 0 deletions
diff --git a/app-benchmarks/interbench/Manifest b/app-benchmarks/interbench/Manifest
new file mode 100644
index 000000000000..1a3e159db559
--- /dev/null
+++ b/app-benchmarks/interbench/Manifest
@@ -0,0 +1 @@
+DIST interbench-0.31.tar.gz 38791 BLAKE2B 8f5605c763be6be0fcb5b240d5022c578af98d470a8bdf61f0ebc2abe56e6439fa37b5ac4e3eae16c7aab902cc08fab25f0cb34a92c0eea05b287b7bef2abbb4 SHA512 ccad7f5a7ea10c3c56809725145bad17970c4fa8aafc4b962e4e79c56bfa05025fee140e5b70ec407158aca59bba47e6bbff14329516d9383801ffe4c0797a23
diff --git a/app-benchmarks/interbench/files/interbench-0.31-makefile.patch b/app-benchmarks/interbench/files/interbench-0.31-makefile.patch
new file mode 100644
index 000000000000..712c54f482c8
--- /dev/null
+++ b/app-benchmarks/interbench/files/interbench-0.31-makefile.patch
@@ -0,0 +1,16 @@
+--- a/Makefile 2016-10-21 04:28:00.000000000 +0200
++++ b/Makefile 2018-11-01 16:56:36.000000000 +0100
+@@ -1,8 +1,9 @@
+-CC=gcc
+-CFLAGS=-W -Wall -g -O2 -s -pipe
+-LDFLAGS=-lrt -lm -pthread
++CC ?= gcc
++CFLAGS+=-W -Wall
++LDFLAGS+=-lrt -lm -pthread
+
+-interbench: interbench.o hackbench.o -lm
++interbench: interbench.o hackbench.o
++ $(CC) $(CFLAGS) -o interbench interbench.o hackbench.o $(LDFLAGS)
+ interbench.o: interbench.c
+ hackbench.o: hackbench.c
+
diff --git a/app-benchmarks/interbench/interbench-0.31.ebuild b/app-benchmarks/interbench/interbench-0.31.ebuild
new file mode 100644
index 000000000000..bab121c0d448
--- /dev/null
+++ b/app-benchmarks/interbench/interbench-0.31.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="A Linux interactivity benchmark"
+HOMEPAGE="
+ http://interbench.kolivas.org/
+ https://github.com/ckolivas/interbench/
+"
+SRC_URI="https://github.com/ckolivas/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-2+"
+SLOT="0"
+
+PATCHES=( "${FILESDIR}/${P}-makefile.patch" )
+
+DOCS=(
+ "readme"
+ "readme.interactivity"
+)
+
+src_prepare() {
+ default
+
+ tc-export CC
+}
+
+src_install() {
+ dobin interbench
+ doman interbench.8
+
+ einstalldocs
+}
diff --git a/app-benchmarks/interbench/metadata.xml b/app-benchmarks/interbench/metadata.xml
new file mode 100644
index 000000000000..f86ed635b546
--- /dev/null
+++ b/app-benchmarks/interbench/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>ck+gentoo@bl4ckb0x.de</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ This benchmark application is designed to benchmark interactivity in Linux.
+ It is designed to measure the effect of changes in Linux kernel design or system
+ configuration changes such as CPU, I/O scheduler and filesystem changes and options.
+ With careful benchmarking, different hardware can be compared.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/ckolivas/interbench/issues</bugs-to>
+ <remote-id type="github">ckolivas/interbench</remote-id>
+ </upstream>
+</pkgmetadata>