summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-01-24 13:57:38 +0100
committerDavid Seifert <soap@gentoo.org>2020-01-24 13:57:38 +0100
commitb057c4d36b3fb73987c4ebb1dcc804252e55c1f5 (patch)
tree7812ea7f2079c9bf36c89452073d6b1573e3428a /app-benchmarks
parentsys-apps/nosig: Replaced DESCRIPTION with something more meaningful (diff)
downloadgentoo-b057c4d36b3fb73987c4ebb1dcc804252e55c1f5.tar.gz
gentoo-b057c4d36b3fb73987c4ebb1dcc804252e55c1f5.tar.bz2
gentoo-b057c4d36b3fb73987c4ebb1dcc804252e55c1f5.zip
app-benchmarks/iozone: Version bump to 3.488
Bug: https://bugs.gentoo.org/706232 Package-Manager: Portage-2.3.85, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-benchmarks')
-rw-r--r--app-benchmarks/iozone/Manifest1
-rw-r--r--app-benchmarks/iozone/files/iozone-3.488-gcc10-fno-common.patch13
-rw-r--r--app-benchmarks/iozone/iozone-3.488.ebuild65
3 files changed, 79 insertions, 0 deletions
diff --git a/app-benchmarks/iozone/Manifest b/app-benchmarks/iozone/Manifest
index 1a001458f1ee..312115badbdd 100644
--- a/app-benchmarks/iozone/Manifest
+++ b/app-benchmarks/iozone/Manifest
@@ -1,3 +1,4 @@
DIST iozone3_471.tar 1853440 BLAKE2B 280c821a439ad1bacbd749278385481678d644a59c14395482c8a088b0578285f389f376fb32ce3c3abde598f50d693fb0c7c9a3d6597765547a71c76d21ea1c SHA512 c61b2b8b5af3dccdb99b26aef8a0a4f2f5f467fc3985ac72ed4bb4fb36e4b7684ca6dbaa5bbc05ae0a4e73852e048e9fd2495eda9313f5abc4e631499d683aec
DIST iozone3_484.tar 1863680 BLAKE2B 72d3d3125aec2dfc504bb00684ef325e85edffe0d6efcd519cd692cfa2b9b792a44c00313dc96eabbbb3ab850a7a440b3ca3d5b955c4f6092b08f92ebe5c332b SHA512 bb1ac0c1724a5d3c20e90c56c0b4a438b4aa50384cddc76f4b77f2c465f052fd3fae9217b77688a2c6caf5e90611123a97ea0cd8074b3678068a90e6dd7857b7
DIST iozone3_487.tar 1873920 BLAKE2B f27edb85ebfd19e55dea239a4e5d595a84981c0249ec57148efdcce90a85a5cbf1e17f319de820a06410c66390ddd38efe1b90b31ed98c3bf979eea6fb25ccc7 SHA512 2f3a9d259ca531e45124e8ad55358706e2f9615f50fbf434e786b832622aa5f673dbed1b2706c6450c200e0af7f7374e40402e0b06ad116d5f2a0704a6156a1a
+DIST iozone3_488.tar 1873920 BLAKE2B 60e97d588a273c1af7a8c83ec207593fcf43766f92171774b974aa04a8df690a1a84aae4b448e4a6f9e4e9c7dc3cd98ad327a0ea196779e6dbe3a88326314eaf SHA512 033f9e6e7395fe84ae6f4ae8737544e399ac0f16e82ba95eed2a2d0df52b7efcbe0c9282abc68d3c5b53d859073c74bff2e8c34bc35e1e1cc887ed36ad5d840b
diff --git a/app-benchmarks/iozone/files/iozone-3.488-gcc10-fno-common.patch b/app-benchmarks/iozone/files/iozone-3.488-gcc10-fno-common.patch
new file mode 100644
index 000000000000..e990040efb67
--- /dev/null
+++ b/app-benchmarks/iozone/files/iozone-3.488-gcc10-fno-common.patch
@@ -0,0 +1,13 @@
+Bug: https://bugs.gentoo.org/706232
+
+--- a/src/current/iozone.c
++++ b/src/current/iozone.c
+@@ -1676,7 +1676,7 @@
+
+ char pit_hostname[40];
+ char pit_service[8];
+-int junk;
++extern int junk;
+
+ /*
+ * Host ports used to listen, and handle errors.
diff --git a/app-benchmarks/iozone/iozone-3.488.ebuild b/app-benchmarks/iozone/iozone-3.488.ebuild
new file mode 100644
index 000000000000..3f6941869e61
--- /dev/null
+++ b/app-benchmarks/iozone/iozone-3.488.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Filesystem benchmarking program"
+HOMEPAGE="http://www.iozone.org/"
+SRC_URI="http://www.iozone.org/src/current/${PN}${PV/./_}.tar"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+S="${WORKDIR}/${PN}${PV/./_}"
+
+PATCHES=( "${FILESDIR}"/${PN}-3.488-gcc10-fno-common.patch )
+
+src_prepare() {
+ default
+
+ # Options FIX
+ sed -e '/CC =.*/d' \
+ -e '/CFLAGS =.*/d' \
+ -e 's:-O[23]:$(CFLAGS):g' \
+ -e 's:-Dlinux:$(LDFLAGS) -Dlinux:g' \
+ -i src/current/makefile || die
+}
+
+src_configure() {
+ tc-export CC
+
+ case ${ARCH} in
+ x86|alpha) PLATFORM="linux";;
+ arm) PLATFORM="linux-arm";;
+ ppc) PLATFORM="linux-powerpc";;
+ ppc64) PLATFORM="linux-powerpc64";;
+ amd64) PLATFORM="linux-AMD64";;
+ ia64) PLATFORM="linux-ia64";;
+ s390) PLATFORM="linux-S390";;
+ *) PLATFORM="linux-${ARCH}";;
+ esac
+}
+
+src_compile() {
+ emake -C src/current ${PLATFORM}
+}
+
+src_test() {
+ cd "${T}" || die
+ "${S}"/src/current/iozone testfile || die "self test failed"
+}
+
+src_install() {
+ dosbin src/current/{iozone,fileop}
+
+ # decompress pre-compressed file to make QA check happy
+ gunzip docs/Iozone_ps.gz || die
+
+ dodoc docs/I* docs/Run_rules.doc src/current/Changes.txt
+ doman docs/iozone.1
+ cd src/current || die
+ dodoc Generate_Graphs Gnuplot.txt gengnuplot.sh gnu3d.dem
+}