summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-01-07 13:58:16 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-01-07 18:28:54 +0100
commit993862383100f21f6136eb04c77546cc2a0d17ca (patch)
tree31582a71ed609d73c114d2f69b3146061c3c3f6d /app-cdr/dolphin-plugins-mountiso
parentkde-apps/umbrello: 20.12.1 version bump (diff)
downloadgentoo-993862383100f21f6136eb04c77546cc2a0d17ca.tar.gz
gentoo-993862383100f21f6136eb04c77546cc2a0d17ca.tar.bz2
gentoo-993862383100f21f6136eb04c77546cc2a0d17ca.zip
app-cdr/dolphin-plugins-mountiso: 20.12.1 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-cdr/dolphin-plugins-mountiso')
-rw-r--r--app-cdr/dolphin-plugins-mountiso/Manifest1
-rw-r--r--app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-20.12.1.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/app-cdr/dolphin-plugins-mountiso/Manifest b/app-cdr/dolphin-plugins-mountiso/Manifest
index 6dbf959ee8b7..9fc222f37860 100644
--- a/app-cdr/dolphin-plugins-mountiso/Manifest
+++ b/app-cdr/dolphin-plugins-mountiso/Manifest
@@ -1,2 +1,3 @@
DIST dolphin-plugins-20.08.3.tar.xz 230272 BLAKE2B 1978ffebe88d95350cac0892c56e127507b6ddd6d5675bca8f420990552e20ff271e6f5742a2bdeff685c82464e70177ac83e5e9368547eb175a3e8133d77624 SHA512 2010be567ef025375caac92e90c0259faea1eb58bdbc55e441e42a10af68b6313391707a7f6b6b10285ba80dcbdee92468fa5088970eb98d4ea8afea145976d9
DIST dolphin-plugins-20.12.0.tar.xz 236436 BLAKE2B ed8b525c8934b3f1b41f53a9c22a1db211632b58a015e93d507eb46943920fc22e245b81e360bf30d75fe066a2a6ed36857bd3b446faf07b32132ef5755c1eb1 SHA512 a5ed5ae83ba8d2f0af5521f2219191acee2693aae656d829d425a8f9d7d21857511fdda3730dcc88e910ab5a2b6b76817a324498cffa390be3fa616bc57dd106
+DIST dolphin-plugins-20.12.1.tar.xz 238592 BLAKE2B 32b8e7e92e16b65f10255eff940496bd77fd544ba96e63db1a914ab97b3e9049cbec5c3136ddbc9d124c6d01e44b3d897e2e497ddd753c0c00960c17f503f91d SHA512 fbccd9d6e276d37e7874c4dcc31ea209e4e17bcac8feeb2ede386bb3ce8510428eba1e5fe58a1551fe81f61810454f177db61ce8607faa45a03509bafd303aad
diff --git a/app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-20.12.1.ebuild b/app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-20.12.1.ebuild
new file mode 100644
index 000000000000..d19413eb48b5
--- /dev/null
+++ b/app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-20.12.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_HANDBOOK="false"
+KDE_RELEASE_SERVICE="true"
+KDE_ORG_CATEGORY="sdk"
+KDE_ORG_NAME="dolphin-plugins"
+MY_PLUGIN_NAME="mountiso"
+KFMIN=5.75.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.15.1
+inherit ecm kde.org
+
+DESCRIPTION="Dolphin plugin for ISO loopback device mounting"
+HOMEPAGE="https://apps.kde.org/en/dolphin_plugins"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-apps/dolphin-${PVCUT}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/ktextwidgets-${KFMIN}:5
+ >=kde-frameworks/solid-${KFMIN}:5
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ ecm_src_prepare
+ # kxmlgui, qtnetwork only required by dropbox
+ ecm_punt_bogus_dep Qt5 Network
+ ecm_punt_bogus_dep KF5 XmlGui
+ # delete non-${PN} translations
+ if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ find po -type f -name "*po" -and -not -name "*${MY_PLUGIN_NAME}plugin" -delete || die
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_${MY_PLUGIN_NAME}=ON
+ -DBUILD_bazaar=OFF
+ -DBUILD_dropbox=OFF
+ -DBUILD_git=OFF
+ -DBUILD_hg=OFF
+ -DBUILD_svn=OFF
+ )
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+ rm "${D}"/usr/share/metainfo/org.kde.dolphin-plugins.metainfo.xml || die
+}