summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-03-05 15:20:28 +0100
committerMichał Górny <mgorny@gentoo.org>2019-03-05 15:29:00 +0100
commitc2053cef1bfc7e7b94f6358ad5f3b6f75161cd61 (patch)
treefe91350a10dcdb0ec1750e3994645ae7f77cdcdf /app-cdr/gcdemu
parentapp-cdr/cdemu: Bump to 3.2.1 (diff)
downloadgentoo-c2053cef1bfc7e7b94f6358ad5f3b6f75161cd61.tar.gz
gentoo-c2053cef1bfc7e7b94f6358ad5f3b6f75161cd61.tar.bz2
gentoo-c2053cef1bfc7e7b94f6358ad5f3b6f75161cd61.zip
app-cdr/gcdemu: Bump to 3.2.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-cdr/gcdemu')
-rw-r--r--app-cdr/gcdemu/Manifest1
-rw-r--r--app-cdr/gcdemu/gcdemu-3.2.1.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/app-cdr/gcdemu/Manifest b/app-cdr/gcdemu/Manifest
index 940a7d37e5b4..c0977f314481 100644
--- a/app-cdr/gcdemu/Manifest
+++ b/app-cdr/gcdemu/Manifest
@@ -1 +1,2 @@
DIST gcdemu-3.2.0.tar.bz2 52144 BLAKE2B f349e4482905b0ac59bce5d6af74000e05ff9b7257c7ec8755106ac8fe316d59d19de8b72705fd9cccfa888d170776667ee07fe90311a81e78f251fee85601ee SHA512 61a1775c874c9c3604ce88758039ef80b262463ae180e791eb545811fa2176e4bf07c4dbcd3be5f17d446fdef92317a0ff64ce8d27f26aeaeee9d8134b6a95ea
+DIST gcdemu-3.2.1.tar.bz2 52231 BLAKE2B f6b0025f6c5e79fe7312bf15b467327152e561db33f6190847e4e702cb98ff8005b37fe997c721b5c76cd64d64bafef1c015a9151c0ee200c52efcb849c93dba SHA512 c2da75d985981ccd0b44f210745670501fecd0ae7c60bde783fc5f91ab4c629c6eab9e8b35df906b5669b6518d3bdf36c5814b513c0f3e2d703659d23df1c82e
diff --git a/app-cdr/gcdemu/gcdemu-3.2.1.ebuild b/app-cdr/gcdemu/gcdemu-3.2.1.ebuild
new file mode 100644
index 000000000000..8ab6ae82ae0c
--- /dev/null
+++ b/app-cdr/gcdemu/gcdemu-3.2.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python3_{4,5,6,7} )
+
+inherit cmake-utils gnome2-utils python-single-r1 xdg-utils
+
+DESCRIPTION="Gtk+ GUI for controlling cdemu-daemon"
+HOMEPAGE="http://cdemu.org/"
+SRC_URI="mirror://sourceforge/cdemu/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# librsvg for pixbuf-loader
+RDEPEND="${PYTHON_DEPS}
+ app-cdr/cdemu-daemon:0/7
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ gnome-base/librsvg:2
+ x11-libs/gdk-pixbuf[introspection]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/libnotify[introspection]"
+DEPEND="
+ dev-util/desktop-file-utils
+ >=dev-util/intltool-0.21
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS README )
+
+src_prepare() {
+ cmake-utils_src_prepare
+ python_fix_shebang src/gcdemu
+}
+
+src_configure() {
+ local mycmakeargs=( -DPOST_INSTALL_HOOKS=OFF )
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ gnome2_schemas_update
+}