summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-cdr/gnomebaker
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-cdr/gnomebaker')
-rw-r--r--app-cdr/gnomebaker/Manifest1
-rw-r--r--app-cdr/gnomebaker/files/gnomebaker-0.6.4-implicits.patch30
-rw-r--r--app-cdr/gnomebaker/files/gnomebaker-0.6.4-ldadd.patch11
-rw-r--r--app-cdr/gnomebaker/files/gnomebaker-0.6.4-libnotify-0.7.patch18
-rw-r--r--app-cdr/gnomebaker/files/gnomebaker-0.6.4-mimetype.patch8
-rw-r--r--app-cdr/gnomebaker/files/gnomebaker-0.6.4-seldata.patch31
-rw-r--r--app-cdr/gnomebaker/gnomebaker-0.6.4-r1.ebuild59
-rw-r--r--app-cdr/gnomebaker/metadata.xml8
8 files changed, 166 insertions, 0 deletions
diff --git a/app-cdr/gnomebaker/Manifest b/app-cdr/gnomebaker/Manifest
new file mode 100644
index 000000000000..9ed23e7a2937
--- /dev/null
+++ b/app-cdr/gnomebaker/Manifest
@@ -0,0 +1 @@
+DIST gnomebaker-0.6.4.tar.gz 1276117 SHA256 6e1ef94cafca7536fc3211a7abd4732f6dc5adc3c7c1b73184f5a87738117fb7 SHA512 954a05724d8d036580edbd5ded11bfd4389965b831ccf2d5a10dbd542c54db4f0519aa3277c6ebc139f55a2475987c48b557cc002e86d9cccca473f187666e34 WHIRLPOOL f951cc19ebd3d107e0d2386c2e58cc678521a31c1fd40e77769dc6758fefa86d375d92bd7bad3770c5e54e6e2de41357a5c66efbdab0276b09f41516049d1d47
diff --git a/app-cdr/gnomebaker/files/gnomebaker-0.6.4-implicits.patch b/app-cdr/gnomebaker/files/gnomebaker-0.6.4-implicits.patch
new file mode 100644
index 000000000000..bbc8ec7abc52
--- /dev/null
+++ b/app-cdr/gnomebaker/files/gnomebaker-0.6.4-implicits.patch
@@ -0,0 +1,30 @@
+--- a/src/preferences.h
++++ b/src/preferences.h
+@@ -85,6 +85,7 @@
+
+ gboolean preferences_init();
+ void preferences_finalise();
++int preferences_get_default_backend();
+
+ gchar *preferences_get_copy_data_cd_image();
+ gchar *preferences_get_copy_dvd_image();
+--- a/src/backend.h
++++ b/src/backend.h
+@@ -30,6 +30,7 @@
+
+
+ gboolean backend_is_backend_supported(enum backend b);
++gboolean backend_does_prog_exist(gchar* program);
+
+
+ #endif /* _BACKEND_H_ */
+--- a/src/gnomebaker.c
++++ b/src/gnomebaker.c
+@@ -32,6 +32,7 @@
+ #include "splashdlg.h"
+ #include "gbcommon.h"
+ #include <libgnomevfs/gnome-vfs-mime-utils.h>
++#include <libgnomevfs/gnome-vfs-ops.h>
+ #include <gst/gst.h>
+ #include "media.h"
+ #include "dataproject.h"
diff --git a/app-cdr/gnomebaker/files/gnomebaker-0.6.4-ldadd.patch b/app-cdr/gnomebaker/files/gnomebaker-0.6.4-ldadd.patch
new file mode 100644
index 000000000000..b8e4cf1ed551
--- /dev/null
+++ b/app-cdr/gnomebaker/files/gnomebaker-0.6.4-ldadd.patch
@@ -0,0 +1,11 @@
+--- a/src/Makefile.in
++++ b/src/Makefile.in
+@@ -255,7 +255,7 @@ gnomebaker_SOURCES = \
+ cairofillbar.c cairofillbar.h \
+ backend.c backend.h
+
+-gnomebaker_LDADD = @GNOMEBAKER_LIBS@
++gnomebaker_LDADD = @GNOMEBAKER_LIBS@ -lm
+ gnomebaker_LDFLAGS = -export-dynamic
+ all: all-am
+
diff --git a/app-cdr/gnomebaker/files/gnomebaker-0.6.4-libnotify-0.7.patch b/app-cdr/gnomebaker/files/gnomebaker-0.6.4-libnotify-0.7.patch
new file mode 100644
index 000000000000..772d4f5d23d9
--- /dev/null
+++ b/app-cdr/gnomebaker/files/gnomebaker-0.6.4-libnotify-0.7.patch
@@ -0,0 +1,18 @@
+--- a/src/gblibnotify.c
++++ b/src/gblibnotify.c
+@@ -87,7 +87,15 @@
+ #ifdef HAVE_LIBNOTIFY
+ #if (LIBNOTIFY_VERSION_MINOR >= 3)
+ gint x, y;
++#ifdef NOTIFY_CHECK_VERSION
++#if NOTIFY_CHECK_VERSION (0, 7, 0)
++ global_notify = notify_notification_new (subject, content, "");
++#else
+ global_notify = notify_notification_new (subject, content, "", NULL);
++#endif
++#else
++ global_notify = notify_notification_new (subject, content, "", NULL);
++#endif
+ /* not sure if we have to free the pixbuf since it could be used internally in libnotify */
+ GdkPixbuf *icon_pixbuf = gbcommon_get_icon_for_name("gnomebaker-48", 48);
+ /* I think they changed the api between 0.3.0 and 0.3.1+ */
diff --git a/app-cdr/gnomebaker/files/gnomebaker-0.6.4-mimetype.patch b/app-cdr/gnomebaker/files/gnomebaker-0.6.4-mimetype.patch
new file mode 100644
index 000000000000..c0e29e66ad34
--- /dev/null
+++ b/app-cdr/gnomebaker/files/gnomebaker-0.6.4-mimetype.patch
@@ -0,0 +1,8 @@
+--- a/gnomebaker.desktop.in
++++ b/gnomebaker.desktop.in
+@@ -17,4 +17,4 @@ X-MultipleArgs=false
+ Type=Application
+ Categories=AudioVideo;DiscBurning;
+ StartupNotify=true
+-
++MimeType=application/x-cd-image;application/x-cdrdao-toc;application/x-toc;application/x-cue;x-content/blank-cd;x-content/blank-dvd;x-content/blank-bd;x-content/blank-hddvd;
diff --git a/app-cdr/gnomebaker/files/gnomebaker-0.6.4-seldata.patch b/app-cdr/gnomebaker/files/gnomebaker-0.6.4-seldata.patch
new file mode 100644
index 000000000000..0be6f1e09c43
--- /dev/null
+++ b/app-cdr/gnomebaker/files/gnomebaker-0.6.4-seldata.patch
@@ -0,0 +1,31 @@
+--- a/src/filebrowser.c
++++ b/src/filebrowser.c
+@@ -866,7 +866,7 @@ filebrowser_get_selection(gboolean from_
+ else
+ tree = glade_xml_get_widget(gnomebaker_getxml(), widget_browser_filelist);
+
+- GtkSelectionData *selection_data = g_new0(GtkSelectionData, 1);
++ GtkSelectionData *selection_data = g_slice_new0(GtkSelectionData);
+ filebrowser_on_drag_data_get(tree, NULL, selection_data, 0, 0, NULL);
+ return selection_data;
+ }
+--- a/src/gnomebaker.c
++++ b/src/gnomebaker.c
+@@ -529,7 +529,7 @@ gnomebaker_on_add_files(gpointer widget,
+ }
+
+ /*gtk_selection_data_set_uris(selection_data, uris);*/
+- selection_data = g_new0(GtkSelectionData, 1);
++ selection_data = g_slice_new0(GtkSelectionData);
+ gtk_selection_data_set(selection_data, selection_data->target, 8,
+ (const guchar*)text->str, strlen(text->str) * sizeof(gchar));
+ GB_TRACE("gnomebaker_on_add_files - [%s]\n", selection_data->data);
+@@ -1073,7 +1073,7 @@ gnomebaker_select_files_or_folders(const
+ }
+
+ /*gtk_selection_data_set_uris(selection_data, uris);*/
+- selection_data = g_new0(GtkSelectionData, 1);
++ selection_data = g_slice_new0(GtkSelectionData);
+ gtk_selection_data_set(selection_data, selection_data->target, 8,
+ (const guchar*)text->str, strlen(text->str) * sizeof(gchar));
+ GB_TRACE("gnomebaker_select_files_or_folders - [%s]\n", selection_data->data);
diff --git a/app-cdr/gnomebaker/gnomebaker-0.6.4-r1.ebuild b/app-cdr/gnomebaker/gnomebaker-0.6.4-r1.ebuild
new file mode 100644
index 000000000000..9a9f805ff0db
--- /dev/null
+++ b/app-cdr/gnomebaker/gnomebaker-0.6.4-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+GCONF_DEBUG=no
+inherit eutils gnome2
+
+DESCRIPTION="GnomeBaker is a GTK2/Gnome cd burning application"
+HOMEPAGE="http://sourceforge.net/projects/gnomebaker"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ia64 ppc ppc64 sparc x86"
+IUSE="dvdr flac libnotify mp3 vorbis"
+
+COMMON_DEPEND="app-cdr/cdrdao
+ dev-libs/libxml2
+ >=gnome-base/libglade-2
+ >=gnome-base/libgnomeui-2
+ >=media-libs/gstreamer-0.10:0.10
+ virtual/cdrtools
+ x11-libs/cairo
+ x11-libs/gtk+:2
+ dvdr? ( app-cdr/dvd+rw-tools )
+ libnotify? ( x11-libs/libnotify )"
+RDEPEND="${COMMON_DEPEND}
+ >=media-libs/gst-plugins-good-0.10:0.10
+ flac? ( >=media-plugins/gst-plugins-flac-0.10:0.10 )
+ mp3? ( >=media-plugins/gst-plugins-mad-0.10:0.10 )
+ vorbis? ( >=media-plugins/gst-plugins-vorbis-0.10:0.10 )"
+DEPEND="${COMMON_DEPEND}
+ app-text/rarian
+ dev-util/intltool
+ virtual/pkgconfig
+ sys-devel/gettext"
+
+src_prepare() {
+ G2CONF="$(use_enable libnotify)"
+
+ epatch \
+ "${FILESDIR}"/${P}-libnotify-0.7.patch \
+ "${FILESDIR}"/${P}-ldadd.patch \
+ "${FILESDIR}"/${P}-seldata.patch \
+ "${FILESDIR}"/${P}-mimetype.patch \
+ "${FILESDIR}"/${P}-implicits.patch
+
+ gnome2_src_prepare
+}
+
+src_install() {
+ gnome2_src_install \
+ gnomebakerdocdir=/usr/share/doc/${P} \
+ docdir=/usr/share/gnome/help/${PN}/C \
+ gnomemenudir=/usr/share/applications
+
+ rm -rf "${ED}"/usr/share/doc/${P}/*.make "${ED}"/var
+}
diff --git a/app-cdr/gnomebaker/metadata.xml b/app-cdr/gnomebaker/metadata.xml
new file mode 100644
index 000000000000..ffe73314bd8c
--- /dev/null
+++ b/app-cdr/gnomebaker/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>media-optical</herd>
+ <upstream>
+ <remote-id type="sourceforge">gnomebaker</remote-id>
+ </upstream>
+</pkgmetadata>