summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-cdr/graveman/graveman-0.3.12_p5-r2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-cdr/graveman/graveman-0.3.12_p5-r2.ebuild')
-rw-r--r--app-cdr/graveman/graveman-0.3.12_p5-r2.ebuild70
1 files changed, 70 insertions, 0 deletions
diff --git a/app-cdr/graveman/graveman-0.3.12_p5-r2.ebuild b/app-cdr/graveman/graveman-0.3.12_p5-r2.ebuild
new file mode 100644
index 000000000000..374136100df0
--- /dev/null
+++ b/app-cdr/graveman/graveman-0.3.12_p5-r2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="Graphical frontend for cdrecord, mkisofs, readcd and sox using GTK+2"
+HOMEPAGE="http://graveman.tuxfamily.org/"
+SRC_URI="http://graveman.tuxfamily.org/sources/${PN}-${PV/_p/-}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 sparc x86"
+IUSE="debug dvdr flac mp3 nls vorbis"
+
+RDEPEND="
+ app-cdr/cdrdao
+ >=dev-libs/glib-2.4:2
+ >=gnome-base/libglade-2.4:2.0
+ media-libs/libmng
+ virtual/cdrtools
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-2.4:2
+ dvdr? ( app-cdr/dvd+rw-tools )
+ flac? ( media-libs/flac )
+ mp3? ( media-libs/libid3tag
+ media-libs/libmad
+ media-sound/sox )
+ nls? ( virtual/libintl )
+ vorbis? (
+ media-libs/libogg
+ media-libs/libvorbis
+ media-sound/sox )
+"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+S=${WORKDIR}/${P/_p/-}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/joliet-long.patch \
+ "${FILESDIR}"/rename.patch \
+ "${FILESDIR}"/desktop-entry.patch
+
+ if use mp3 || use vorbis; then
+ epatch "${FILESDIR}"/sox.patch
+ fi
+
+ # Fix tests
+ echo glade/dialog_media.glade >> po/POTFILES.in
+ echo glade/window_welcome.glade >> po/POTFILES.in
+ echo src/flac.c >> po/POTFILES.in
+
+ eautoreconf # Needed for build only the needed translations
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable debug) \
+ $(use_enable flac) \
+ $(use_enable mp3) \
+ $(use_enable vorbis ogg)
+}