summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-cdr/mode2cdmaker
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-cdr/mode2cdmaker')
-rw-r--r--app-cdr/mode2cdmaker/Manifest1
-rw-r--r--app-cdr/mode2cdmaker/files/mode2cdmaker-1.5.1-gentoo.patch46
-rw-r--r--app-cdr/mode2cdmaker/metadata.xml5
-rw-r--r--app-cdr/mode2cdmaker/mode2cdmaker-1.5.1.ebuild35
4 files changed, 87 insertions, 0 deletions
diff --git a/app-cdr/mode2cdmaker/Manifest b/app-cdr/mode2cdmaker/Manifest
new file mode 100644
index 000000000000..3d79c9d5bca7
--- /dev/null
+++ b/app-cdr/mode2cdmaker/Manifest
@@ -0,0 +1 @@
+DIST mode2cdmaker-1.5.1-src.zip 57049 SHA256 d38f47cffe5d1276d1af9e8998a1100dc93e4d708cf284e6c3d8822f2bb6f38d SHA512 854aea23ae83521f689c5e4d91e6b3aba3e0977a987eb5a88fd340bb2b3f795ba76bf227a84727f3792b4f2453b4a4710d5e3782ccbfda79569506c23e77302f WHIRLPOOL 35b8dba61839c478bfcf1a6d83db51f9691b985b72402a317e7a9a1aabc1181419f6ed4d615d7429ce0f3fea599735446e5c9f830c1ad32f8f212fd4877f0489
diff --git a/app-cdr/mode2cdmaker/files/mode2cdmaker-1.5.1-gentoo.patch b/app-cdr/mode2cdmaker/files/mode2cdmaker-1.5.1-gentoo.patch
new file mode 100644
index 000000000000..502819c11df3
--- /dev/null
+++ b/app-cdr/mode2cdmaker/files/mode2cdmaker-1.5.1-gentoo.patch
@@ -0,0 +1,46 @@
+diff -ur mode2cdmaker-1.5.1.orig/Makefile.linux mode2cdmaker-1.5.1/Makefile.linux
+--- mode2cdmaker-1.5.1.orig/Makefile.linux 2003-02-01 16:27:18.000000000 +0200
++++ mode2cdmaker-1.5.1/Makefile.linux 2008-06-15 19:24:14.000000000 +0300
+@@ -4,8 +4,8 @@
+ output=mode2cdmaker
+
+ all:
+- gcc -c $(srcs)
+- gcc -o $(output) $(objs)
++ $(CC) ${CFLAGS} -DMAX_PATH=512 -c $(srcs)
++ $(CC) ${LDFLAGS} -o $(output) $(objs)
+
+ clean:
+ -rm -f $(objs) $(output)
+diff -ur mode2cdmaker-1.5.1.orig/mkvcdfs.c mode2cdmaker-1.5.1/mkvcdfs.c
+--- mode2cdmaker-1.5.1.orig/mkvcdfs.c 2003-03-14 19:57:38.000000000 +0200
++++ mode2cdmaker-1.5.1/mkvcdfs.c 2008-06-15 19:23:25.000000000 +0300
+@@ -120,6 +120,7 @@
+ #endif
+ #endif
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <fcntl.h>
+ #include <string.h>
+ #include <ctype.h>
+@@ -629,7 +630,7 @@
+ next_command[1]=(char*)malloc(256);
+ while (fgets(next_command[1],256,pf))
+ {
+- next_command[1][lstrlen(next_command[1])-1]=0;
++ next_command[1][strlen(next_command[1])-1]=0;
+ parse_params(2,next_command,idepth+1);
+ }
+ fclose(pf);
+diff -ur mode2cdmaker-1.5.1.orig/vcdisofs.c mode2cdmaker-1.5.1/vcdisofs.c
+--- mode2cdmaker-1.5.1.orig/vcdisofs.c 2003-02-02 00:02:44.000000000 +0200
++++ mode2cdmaker-1.5.1/vcdisofs.c 2008-06-15 19:19:59.000000000 +0300
+@@ -80,6 +80,8 @@
+ #include <windows.h>
+ #endif
+ #include <stdio.h>
++#include <stdlib.h>
++#include <string.h>
+ #include <time.h>
+ #include "defaults.h"
+
diff --git a/app-cdr/mode2cdmaker/metadata.xml b/app-cdr/mode2cdmaker/metadata.xml
new file mode 100644
index 000000000000..3ca6ae763b34
--- /dev/null
+++ b/app-cdr/mode2cdmaker/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>media-optical</herd>
+</pkgmetadata>
diff --git a/app-cdr/mode2cdmaker/mode2cdmaker-1.5.1.ebuild b/app-cdr/mode2cdmaker/mode2cdmaker-1.5.1.ebuild
new file mode 100644
index 000000000000..94e9b586fe95
--- /dev/null
+++ b/app-cdr/mode2cdmaker/mode2cdmaker-1.5.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Utility to create mode-2 CDs, for example XCDs"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI="mirror://gentoo/${P}-src.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+}
+
+src_compile() {
+ tc-export CC
+ emake -f Makefile.linux || die
+}
+
+src_install() {
+ dobin mode2cdmaker || die
+ dodoc {bugs,compatibility,readme}.txt
+}