summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-cdr/uif2iso
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-cdr/uif2iso')
-rw-r--r--app-cdr/uif2iso/Manifest1
-rw-r--r--app-cdr/uif2iso/files/0.1.7-Makefile10
-rw-r--r--app-cdr/uif2iso/metadata.xml13
-rw-r--r--app-cdr/uif2iso/uif2iso-0.1.7c.ebuild32
4 files changed, 56 insertions, 0 deletions
diff --git a/app-cdr/uif2iso/Manifest b/app-cdr/uif2iso/Manifest
new file mode 100644
index 000000000000..32fa02655c7e
--- /dev/null
+++ b/app-cdr/uif2iso/Manifest
@@ -0,0 +1 @@
+DIST uif2iso-0.1.7c.zip 113727 SHA256 b78dde3e8bc28559f73e2feb46d41c8f57b511ddbe25d63ada704ef8697528ec SHA512 22e2e2d156cae7f2f72ba5959bf3b4282609397d148e6a98666382003ce568e185a90e6af8821829d302c1efea1ca2c6d155df0181c6a29294d70de8adc9591f WHIRLPOOL df4a0446faec70dcb30316a576d49cdf074b042e99a85ccb4dbd0273bc72a5b5a5e37d74c5326728fb80bd34da8783c5dd070c97c9476ff0a1c245b2d5520d56
diff --git a/app-cdr/uif2iso/files/0.1.7-Makefile b/app-cdr/uif2iso/files/0.1.7-Makefile
new file mode 100644
index 000000000000..0b8a2bd95355
--- /dev/null
+++ b/app-cdr/uif2iso/files/0.1.7-Makefile
@@ -0,0 +1,10 @@
+# We replace the makefile since the upstream one is not suitable for
+# us :(
+
+OBJS := $(patsubst %.c,%.o,$(wildcard *.c))
+
+CFLAGS += -DMAGICISO_IS_SHIT
+
+LDLIBS = -lz
+
+uif2iso: $(OBJS)
diff --git a/app-cdr/uif2iso/metadata.xml b/app-cdr/uif2iso/metadata.xml
new file mode 100644
index 000000000000..fadf539e8a0b
--- /dev/null
+++ b/app-cdr/uif2iso/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>media-optical</herd>
+ <maintainer>
+ <email>flameeyes@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
+ uif2iso is a program that can convert images taken with the
+ MagicISO software under Windows, with its proprietary UIF format,
+ into standard ISO9660 images.
+ </longdescription>
+</pkgmetadata>
diff --git a/app-cdr/uif2iso/uif2iso-0.1.7c.ebuild b/app-cdr/uif2iso/uif2iso-0.1.7c.ebuild
new file mode 100644
index 000000000000..b33613eab5e3
--- /dev/null
+++ b/app-cdr/uif2iso/uif2iso-0.1.7c.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Converts MagicISO CD-images to iso"
+HOMEPAGE="http://aluigi.org/mytoolz.htm#uif2iso"
+SRC_URI="mirror://gentoo/${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="sys-libs/zlib"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S="${WORKDIR}/src"
+
+src_compile() {
+ # Yes we use our own makefile, I'll try to explain this to
+ # upstream _again_.
+ emake CC="$(tc-getCC)" -f "${FILESDIR}/0.1.7-Makefile" || die "emake failed"
+}
+
+src_install() {
+ dobin ${PN} || die "failed to install"
+
+ dodoc "${WORKDIR}"/${PN}.txt "${WORKDIR}"/README
+}