summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-cdr/webcdwriter/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-cdr/webcdwriter/files')
-rw-r--r--app-cdr/webcdwriter/files/2.8.2-javac-flags.patch67
-rw-r--r--app-cdr/webcdwriter/files/configure.patch16
-rw-r--r--app-cdr/webcdwriter/files/webcdwriter.rc30
3 files changed, 113 insertions, 0 deletions
diff --git a/app-cdr/webcdwriter/files/2.8.2-javac-flags.patch b/app-cdr/webcdwriter/files/2.8.2-javac-flags.patch
new file mode 100644
index 000000000000..3236d74a4b2b
--- /dev/null
+++ b/app-cdr/webcdwriter/files/2.8.2-javac-flags.patch
@@ -0,0 +1,67 @@
+diff -ur webCDwriter-2.8.2.orig/configure webCDwriter-2.8.2/configure
+--- webCDwriter-2.8.2.orig/configure 2007-03-20 15:14:30.000000000 +0200
++++ webCDwriter-2.8.2/configure 2008-06-07 13:56:36.000000000 +0300
+@@ -47,6 +47,9 @@
+ --destDir=*)
+ DESTDIR=`echo $1 | sed "s:--destDir=::g"`
+ ;;
++ --javac-flags=*)
++ JAVACFLAGS=`echo $1 | sed "s:--javac-flags=::g"`
++ ;;
+ --doNotCompileCDWserver)
+ doNotCompileCDWserver="on"
+ ;;
+@@ -105,6 +108,8 @@
+
+ --destDir use a prefix invisible to the installed files
+
++--javac-flags flags for javac
++
+ --doNotCompileCDWserver if you want to install CDWserver Pro
+
+ --doNotCompileWebCDcreator use the precompiled and signed webCDcreator
+@@ -152,7 +157,7 @@
+ }
+ }
+ EOF
+-javac Test.java 2> /dev/null \
++javac ${JAVACFLAGS} Test.java Test0.java \
+ && webCDcreator="webCDcreator.jar $webCDcreator" \
+ && echo " OK -> will build webCDcreator.jar" \
+ || echo " not found -> will use precompiled webCDcreator.jar"
+@@ -284,12 +289,15 @@
+ forPluginRSA=""
+ fi
+
++echo "JAVACFLAGS=${JAVACFLAGS}"
++
+ cat webCDcreator/Makefile.in \
+ | sed s/@nosCert@/"$nosCert"/g \
+ | sed s/@sunCert@/"$sunCert"/g \
+ | sed s/@all@/"$webCDcreator"/g \
+ | sed s/@4pi@/"$forPlugin"/g \
+ | sed s/@4ns@/"$forPluginRSA"/g \
++ | sed s_@JAVACFLAGS@_"$JAVACFLAGS"_g \
+ > webCDcreator/Makefile
+
+
+diff -ur webCDwriter-2.8.2.orig/webCDcreator/Makefile.in webCDwriter-2.8.2/webCDcreator/Makefile.in
+--- webCDwriter-2.8.2.orig/webCDcreator/Makefile.in 2007-04-21 01:22:20.000000000 +0300
++++ webCDwriter-2.8.2/webCDcreator/Makefile.in 2008-06-07 13:57:56.000000000 +0300
+@@ -14,6 +14,7 @@
+
+ nosCert=@nosCert@
+ sunCert=@sunCert@
++JAVACFLAGS=@JAVACFLAGS@
+
+ all: @all@
+
+@@ -21,7 +22,7 @@
+ $(MAKE) -C icons
+
+ webCDcreator.jar: *.java icons/up.jpg
+- javac -encoding ISO-8859-1 -source 1.4 -target 1.4 *.java
++ javac -encoding ISO-8859-1 ${JAVACFLAGS} *.java netscape/security/*.java
+ jar cfm webCDcreator.jar Manifest \
+ gpl.html \
+ *.class \
diff --git a/app-cdr/webcdwriter/files/configure.patch b/app-cdr/webcdwriter/files/configure.patch
new file mode 100644
index 000000000000..1ea64f7c28df
--- /dev/null
+++ b/app-cdr/webcdwriter/files/configure.patch
@@ -0,0 +1,16 @@
+--- configure.old 2004-05-01 20:45:25.000000000 +0200
++++ configure 2004-09-24 15:07:52.489668584 +0200
+@@ -202,11 +202,11 @@
+ MAKE=gmake
+ ;;
+ Linux)
+- cxxflags="-D_REENTRANT"
++ cxxflags="$CXXFLAGS -D_REENTRANT"
+ if [ "$DEBUG" = "yes" ]; then
+ cxxflags="-g $cxxflags"
+ else
+- cxxflags="-O2 $cxxflags"
++ cxxflags=" $cxxflags"
+ fi
+ lflags="-lcrypt -lpthread"
+ if [ "$PRO" = "yes" ]; then
diff --git a/app-cdr/webcdwriter/files/webcdwriter.rc b/app-cdr/webcdwriter/files/webcdwriter.rc
new file mode 100644
index 000000000000..ce02364306c0
--- /dev/null
+++ b/app-cdr/webcdwriter/files/webcdwriter.rc
@@ -0,0 +1,30 @@
+#!/sbin/runscript
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting CDWserver"
+ for tool in cdrdao cdrecord mkisofs readcd
+ do
+ if [ -e /usr/bin/$tool ]
+ then
+ cp /usr/bin/$tool /var/CDWserver/bin
+ fi
+ done
+ start-stop-daemon --start --quiet --pidfile /var/run/CDWserver.pid \
+ --exec /usr/sbin/CDWserver
+ eend $?
+ touch /var/lock/subsys/CDWserver
+}
+
+stop() {
+ ebegin "Stopping CDWserver"
+ start-stop-daemon --stop --quiet --pidfile /var/run/CDWserver.pid
+ eend $?
+ rm -f /var/lock/subsys/CDWserver
+}