summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-cdr/xfburn
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-cdr/xfburn')
-rw-r--r--app-cdr/xfburn/Manifest2
-rw-r--r--app-cdr/xfburn/metadata.xml20
-rw-r--r--app-cdr/xfburn/xfburn-0.5.2.ebuild38
-rw-r--r--app-cdr/xfburn/xfburn-0.5.4.ebuild40
4 files changed, 100 insertions, 0 deletions
diff --git a/app-cdr/xfburn/Manifest b/app-cdr/xfburn/Manifest
new file mode 100644
index 000000000000..c9dbe1ef0363
--- /dev/null
+++ b/app-cdr/xfburn/Manifest
@@ -0,0 +1,2 @@
+DIST xfburn-0.5.2.tar.bz2 760833 SHA256 63682aab3c30c77e464b2b3b84606d1e1dcefc98e7042072fa09b729d6f84412 SHA512 3c6f27e2c8e5200d620bf32f938a1fb044b371a9fe0b5474ba8c1a487c79a7761e144ec8490f04c2389c96bc980b9f2bdfebce9d24dea30c5caae451bb9dcf5e WHIRLPOOL a88f482d899ecaf89666f34b583b90b02f080ec2dc074f4809b98c8e65a824f3f229dd006c8ccbcd3c580e3c3885bea0a0c9fa04ef8871071b6bc9e237029164
+DIST xfburn-0.5.4.tar.bz2 773300 SHA256 9a0053ff106ae475871a2bed328d5d7c5a2fc4280a24e956ca85b6a13a9fc1f6 SHA512 66bd82aa80fcd53d5d505b01a33cdbffdcf547a05a11bdbe688387420ee682a28564397acaf85a52852625909648c01cc18f289736ac54d2806725f46c875481 WHIRLPOOL 06d77abf0b0cca28306a67dd0703557c38b40f57df8511a49be1850db0c3097ee8d47377f50d4a2cfbf3312873e93f147d70cdb43eab014f04f8412ed8ed747c
diff --git a/app-cdr/xfburn/metadata.xml b/app-cdr/xfburn/metadata.xml
new file mode 100644
index 000000000000..9251991fca79
--- /dev/null
+++ b/app-cdr/xfburn/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>xfce@gentoo.org</email>
+ <name>XFCE Team</name>
+ </maintainer>
+ <herd>media-optical</herd>
+ <upstream>
+ <maintainer>
+ <email>mario@xfce.org</email>
+ </maintainer>
+ </upstream>
+ <upstream>
+ <maintainer>
+ <email>bugs@da.mcbf.net</email>
+ <name>David Mohr</name>
+ </maintainer>
+ </upstream>
+</pkgmetadata>
diff --git a/app-cdr/xfburn/xfburn-0.5.2.ebuild b/app-cdr/xfburn/xfburn-0.5.2.ebuild
new file mode 100644
index 000000000000..b537f3aba14e
--- /dev/null
+++ b/app-cdr/xfburn/xfburn-0.5.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="GTK+ based CD and DVD burning application"
+HOMEPAGE="http://goodies.xfce.org/projects/applications/xfburn"
+SRC_URI="mirror://xfce/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 arm ~ppc x86"
+IUSE="debug gstreamer +udev"
+
+RDEPEND=">=dev-libs/glib-2.32
+ >=dev-libs/libburn-0.4.2
+ >=dev-libs/libisofs-0.6.2
+ >=x11-libs/gtk+-2.24:2
+ >=xfce-base/exo-0.6
+ >=xfce-base/libxfce4ui-4.10
+ gstreamer? ( >=media-libs/gst-plugins-base-0.10.20:0.10 )
+ udev? ( virtual/libgudev:= )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ $(use_enable udev gudev)
+ $(use_enable gstreamer)
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README TODO )
+}
diff --git a/app-cdr/xfburn/xfburn-0.5.4.ebuild b/app-cdr/xfburn/xfburn-0.5.4.ebuild
new file mode 100644
index 000000000000..2329ba0f32d8
--- /dev/null
+++ b/app-cdr/xfburn/xfburn-0.5.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="GTK+ based CD and DVD burning application"
+HOMEPAGE="http://goodies.xfce.org/projects/applications/xfburn"
+SRC_URI="mirror://xfce/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 arm ~ppc x86"
+IUSE="debug gstreamer +udev"
+
+RDEPEND=">=dev-libs/glib-2.32:=
+ >=dev-libs/libburn-0.4.2:=
+ >=dev-libs/libisofs-0.6.2:=
+ >=x11-libs/gtk+-2.24:2=
+ >=xfce-base/exo-0.6:=
+ >=xfce-base/libxfce4ui-4.10:=
+ gstreamer? (
+ media-libs/gstreamer:1.0=
+ media-libs/gst-plugins-base:1.0= )
+ udev? ( virtual/libgudev:= )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ $(use_enable udev gudev)
+ $(use_enable gstreamer)
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README TODO )
+}