summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-07-23 21:17:43 +0200
committerDavid Seifert <soap@gentoo.org>2022-07-23 21:17:43 +0200
commit28dbb866f85f950c8a3dd51e4a622fd9f6db2266 (patch)
treef8424b15903e880281b64b7e572f9aaea303bc3b /app-cdr
parentapp-cdr/b5i2iso: update EAPI 6 -> 8 (diff)
downloadgentoo-28dbb866f85f950c8a3dd51e4a622fd9f6db2266.tar.gz
gentoo-28dbb866f85f950c8a3dd51e4a622fd9f6db2266.tar.bz2
gentoo-28dbb866f85f950c8a3dd51e4a622fd9f6db2266.zip
app-cdr/bin2iso: update EAPI 6 -> 8
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-cdr')
-rw-r--r--app-cdr/bin2iso/bin2iso-19b-r3.ebuild (renamed from app-cdr/bin2iso/bin2iso-19b-r2.ebuild)18
-rw-r--r--app-cdr/bin2iso/files/bin2iso-19b-fixes.patch24
2 files changed, 34 insertions, 8 deletions
diff --git a/app-cdr/bin2iso/bin2iso-19b-r2.ebuild b/app-cdr/bin2iso/bin2iso-19b-r3.ebuild
index 4abbf52bf1c3..3a14eccc6f75 100644
--- a/app-cdr/bin2iso/bin2iso-19b-r2.ebuild
+++ b/app-cdr/bin2iso/bin2iso-19b-r3.ebuild
@@ -1,28 +1,30 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit toolchain-funcs
DESCRIPTION="converts RAW format (.bin/.cue) files to ISO/WAV format"
HOMEPAGE="http://users.andara.com/~doiron/bin2iso/"
SRC_URI="mirror://gentoo/${P}.tar.bz2"
+S="${WORKDIR}/${PN}"
LICENSE="public-domain"
SLOT="0"
KEYWORDS="~alpha amd64 ppc sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE=""
-S=${WORKDIR}/${PN}
-
-PATCHES=( "${FILESDIR}"/${P}-sanity-checks.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-sanity-checks.patch
+ "${FILESDIR}"/${P}-fixes.patch
+)
src_compile() {
- $(tc-getCC) ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} bin2iso19b_linux.c -o ${PN} || die "compile failed"
+ tc-export CC
+ emake bin2iso19b_linux
}
src_install() {
- dobin ${PN}
+ newbin bin2iso19b_linux bin2iso
dodoc readme.txt
}
diff --git a/app-cdr/bin2iso/files/bin2iso-19b-fixes.patch b/app-cdr/bin2iso/files/bin2iso-19b-fixes.patch
new file mode 100644
index 000000000000..fc28945ea990
--- /dev/null
+++ b/app-cdr/bin2iso/files/bin2iso-19b-fixes.patch
@@ -0,0 +1,24 @@
+--- a/bin2iso19b_linux.c
++++ b/bin2iso19b_linux.c
+@@ -1,6 +1,12 @@
++#ifndef _POSIX_C_SOURCE
++#define _POSIX_C_SOURCE 200809L
++#endif
++
+ #include <stdio.h>
+ #include <string.h>
+ #include <stdlib.h>
++#include <unistd.h>
++#include <sys/types.h>
+
+ #define DEBUG 0
+ #define CHECK 0 /* don't bother checking bin for validity... */
+@@ -111,7 +117,7 @@
+ unsigned long size; /* track size in bytes */
+ } tTrack;
+
+-buffered_fread(unsigned char *array, unsigned int size) {
++int buffered_fread(unsigned char *array, unsigned int size) {
+ unsigned int i;
+
+ if(INBUF_WIDX == 0) {